[Solved by update] KDE crash handler

Hi! I am having an issue with Garuda Linux since couple of days. My whole screen and the opened apps kind of breaks and every opened apps closes for a second and then relaunch ,and I see a small red cross on the battery icon on the top then, I get this pop up:
Screenshot_Latte Dock_1

when I hover on the battery icon , it says "No batteries available" .

My inxi -Faz :

╰─λ inxi -Faz
System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=de5d217e-066e-4f77-ae74-fa2915025141
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=0b2da2c7-3e4a-4feb-86d0-3854418997ca loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Laptop 14s-dq3xxx v: N/A serial: <filter> Chassis: type: 10
serial: <filter>
Mobo: HP model: 88E9 v: 81.17 serial: <filter> UEFI: AMI v: F.21 date: 09/09/2021
Battery:   ID-1: BAT0 charge: 34.2 Wh (91.7%) condition: 37.3/41.0 Wh (90.9%) volts: 12.9 min: 11.4
model: HP Primary type: Li-ion serial: <filter> status: Charging cycles: 79
CPU:       Info: Dual Core model: Intel Celeron N4500 bits: 64 type: MCP arch: Tremont family: 6
model-id: 9C (156) stepping: 0 microcode: 1D cache: L2: 4 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4454
Speed: 2670 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 2670 2: 2756
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel JasperLake [UHD Graphics] vendor: Hewlett-Packard driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:4e55 class-ID: 0300
Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-4:3
chip-ID: 0408:5365 class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
OpenGL: renderer: Mesa Intel UHD Graphics (JSL) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:4dc8 class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard
driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-8:5
chip-ID: 0bda:b00e class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 29.51 GiB (12.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNV256G KIOXIA size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HP00AE00 temp: 66.8 C scheme: GPT
Partition: ID-1: / raw-size: 229.41 GiB size: 229.41 GiB (100.00%) used: 29.51 GiB (12.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 229.41 GiB size: 229.41 GiB (100.00%) used: 29.51 GiB (12.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 229.41 GiB size: 229.41 GiB (100.00%) used: 29.51 GiB (12.9%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 229.41 GiB size: 229.41 GiB (100.00%) used: 29.51 GiB (12.9%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 7.48 GiB used: 361 MiB (4.7%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 73.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 199 Uptime: 3h 35m wakeups: 1 Memory: 7.48 GiB used: 3.68 GiB (49.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: apt: 0 pacman: 1500
lib: 435 flatpak: 0 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.08

Does it happen always, at startup or under specific conditions, applications or workload?
I think it would be important also to collect as much info as possible when it happens. Journal, dmesg, etc ...

1 Like

I don't know, I just do usual works,, code editor , firefox and just 2 or 3 apps opened at one time,, it doesn't happen on statup , it happens anytime

It is difficult without precise information.
My suggestion would be to first check if a btrfs balance is suggested in the Garuda assistant, then if a balance is suggested but changes nothing, you could try switching to the lts kernel, since 5.15 is the major update in the last couple of days.
If nothing changes, you could check in the pacman log what else changed.
Then you could restore a previous working snapshot, make sure that it hopefully works and update ignoring the suspect package.
But this could be a nightmare...
I hope the balance or the lts kernel help...

1 Like

I updated my system and everything is good now :slight_smile: