[SOLVED] Broadcom BCM57780 Ethernet not working on live disk

I try to install garuda lxqt on a laptop
Laptop is connected via ethernet
On this pc there is à debian ubuntu and internet works well on it.
But during garuda installation i Have a warning message "no connection to internet"
I am New to garuda and couldn't setup correctly my connection. Didn't find how to connect to my box.
Any advice is welcome.

Christophe D.

Post the output of inxi -Fxxxz as text so we can see what hardware the laptop has.

1 Like

here is the copy of the output of inxi

[email protected]:~$ inxi -Fxxxz
System:    Host: HAL Kernel: 4.4.0-210-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Unity 7.4.5 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
           Distro: Ubuntu 16.04 xenial
Machine:   System: Acer (portable) product: Aspire 7741 v: Rev
           Mobo: Acer model: Aspire 7741 v: Rev
           Bios: Phoenix v: V1.04 date: 02/26/2010
CPU:       Dual core Intel Core i3 M 330 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8512
           clock speeds: min/max: 933/2133 MHz 1: 1066 MHz 2: 2133 MHz
           3: 1066 MHz 4: 1333 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
           bus-ID: 02:00.0 chip-ID: 1002:68e0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: AMD CEDAR (DRM 2.43.0 / 4.4.0-210-generic, LLVM 6.0.0)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:3b56
           Card-2 Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
           driver: snd_hda_intel bus-ID: 02:00.1 chip-ID: 1002:aa68
           Sound: Advanced Linux Sound Architecture v: k4.4.0-210-generic
Network:   Card-1: Broadcom and subsidiaries NetLink BCM57780 Gigabit Ethernet PCIe
           driver: tg3 v: 3.137 bus-ID: 03:00.0 chip-ID: 14e4:1692
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 05:00.0 chip-ID: 168c:002a
           IF: wlp5s0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (58.9% used)
           ID-1: /dev/sda model: TOSHIBA_MK3265GS size: 320.1GB serial: 30F5S195S temp: 30C
Partition: ID-1: / size: 290G used: 172G (63%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 48.0C mobo: 33.0C gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 220 Uptime: 7 min Memory: 1145.0/3814.2MB
           Init: systemd v: 229 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35

Check here:

https://wiki.archlinux.org/index.php/Network_configuration/Ethernet#Broadcom_BCM57780

2 Likes

Also, you can install without an internet connection if necessary and fix your issue afterwards.

2 Likes

Try wireless connection.

USB Android phone tethering is another option for a temporary internet connection.

2 Likes

i tried modprobe commands but didn't work. I decided to make the installation without internet and it worked! Internet worked at first boot .
I discover garuda and i am very impressed. I hope it won't be too complicated to switch to arch from debian. Thanks for all your advices.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.