Solution of the add/remove software's opening issue

in my case it is not opening at all ,
what should i do??
can i do this ??

Hi there, welcome to the community.

I know that it's a nice workaround to manually install libalpm, but it may potentially break your system. It is a serious warning :warning:.

5 Likes

I tried this solution. It failed and I was able to timeshift to an earlier point, but I dont have a timeshift far enough back to restore a version before pacman 6 update.
(I guess this was a issue for a few days before I noticed)

Is this a temporary issue that I can wait for a official solution soon or do I need to take more drastic steps to fix this issue?

All you have to do is wait, till pamac devs fix the issue.
And welcome to the community.

4 Likes

Thanks. That was a lot quicker response that I expected.

1 Like

Also, you should see this thread for the latest updates.

1 Like

exactly the same problem for me

same problem for me too... Add/Remove Software not opening. Well.....lets wait till it get fixed.

now, I've got another problem alongside - cannot update my software packages, even from terminal:

sudo pacman -Syyu
sudo pacman -Syu
sudo pacman -Syyuu

none of the above is working :tired_face:

Error:

E: ts: Failed to get partition list.
First run mode (config file not found)
Selected default snapshot type: BTRFS
E: System disk not found!
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

Try this one

1 Like

It worked it worked :star_struck: :star_struck: :star_struck: :star_struck:
Thanks a lot mate :handshake: :grin:

When will the Add/Remove Applications start to work? I am updating OS everyday but still the software installation program failed to start...

Start reading the posts.

1 Like

So we need to wait till Arch Linux fixes the Pacman issue. :frowning_face:

No. No. No. Read.

2 Likes

Well if you're in that much of a rush perhaps you should put your money where your mouth is and offer @guinix a bounty to fix pamac personally for you ASAP.

Otherwise just relax, and when it's ready it's ready.

Pay up, or pipe down, it's free open source software and if the timetable isn't fast enough for you then you can always go back to Windows or get used to using the terminal.

3 Likes

So its not only for me, but for all other users, the software program fails to show up. In that case, i will just wait till it get fixed. i dont want to break my system (Pacman 6 - manual intervention). Hope this issue will be solved automatically through regular updates.

The "pacman 6 - manual intervention" has to be addressed anyway.
The config merge must be done, and must be done properly.
Otherwise there is no way that you'll be able to update your system and have "add/remove software" working (whenever this will be updated) or to install equivalent tools

3 Likes

Ok... I will try "pacman 6 - manual intervention". As i am new to Garuda OS, i am afraid to do.

Now i installed gparted using terminal. its pretty easy.

sudo pacman -S <package-name>
1 Like

I think you already did it, since you can use pacman successfully :wink:
And I see a post where you corrected the #TotalDownload :slight_smile: so you should be fine.
Just wait, keep on practicing with pacman, and maybe when add/remove software will be fixed you'll even don't want it anymore :blush:

4 Likes