Softwares complain about address boundary error after updating

Hey guys, I’ve encountered the most severe problem in recent 15 months happy with garuda, in which all my attempts failed.
All updates after Mar 16 caused several softwares unable to run, terminated by SIGSEGV.

First, vivaldi, which repeats lines like

[0320/101342.352244:ERROR:process_memory_range.cc(75)] read out of range
[0320/101342.352250:ERROR:process_memory_range.cc(75)] read out of range

and finally fish: Job 2, 'vivaldi-stable' terminated by signal SIGSEGV (Address boundary error)
But, sudo downgrade vivaldi from 6.6.3271.50 to 6.6.3271.48 makes it runnable.

Second, krunner, which only says fish: Job 2, 'krunner' terminated by signal SIGSEGV (Address boundary error)
and using shortcut causes Plasma Workspace saying

Lauching Krunner(Failed)
Remote peer disconnected

(BTW, I cannot either switch between activities. Dunno if they are related)
I cannot downgrade it, as it’s 6.0.0, and everything with kde6 worked quite well in the very first few days.

Last one is obs-studio, whose stderr is libDeckLinkAPI.so: cannot open shared object file: No such file or directory, fish: Process 12146, 'obs' from job 2, 'obs | pbcopy' terminated by signal SIGSEGV (Address boundary error)
And stdout:

debug: Found portal inhibitor
debug: Attempted path: share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: share/obs/obs-studio/locale/fr-FR.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/fr-FR.ini
debug: Attempted path: share/obs/obs-studio/themes
debug: Attempted path: /usr/share/obs/obs-studio/themes
debug: Attempted path: share/obs/obs-studio/themes/Yami.qss
debug: Attempted path: /usr/share/obs/obs-studio/themes/Yami.qss
warning: [Safe Mode] Unclean shutdown detected!
warning: [Safe Mode] User elected to launch normally.
info: Using EGL/X11
info: CPU Name: AMD Ryzen 7 5800H with Radeon Graphics
info: CPU Speed: 4091.784MHz
info: Physical Cores: 8, Logical Cores: 16
info: Physical Memory: 15388MB Total, 5510MB Free
info: Kernel Version: Linux 6.8.1-zen1-1-zen
info: Distribution: "Garuda Linux" Unknown
info: Desktop Environment: KDE (KDE)
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
info: Qt Version: 6.6.2 (runtime), 6.6.2 (compiled)
info: Portable mode: false
info: OBS 30.1.0-1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
	samples per sec: 48000
	speakers:        2
	max buffering:   960 milliseconds
	buffering type:  dynamically increasing
info: ---------------------------------
info: Initializing OpenGL...
info: Loading up OpenGL on adapter AMD AMD Radeon Graphics (radeonsi, renoir, LLVM 17.0.6, DRM 3.57, 6.8.1-zen1-1-zen)
info: OpenGL loaded successfully, version 4.6 (Core Profile) Mesa 24.0.3-arch1.1, shading language 4.60
info: ---------------------------------
info: video settings reset:
	base resolution:   1920x1080
	output resolution: 1920x1080
	downscale filter:  Bicubic
	fps:               60/1
	format:            NV12
	YUV mode:          Rec. 709/Partial
info: NV12 texture support enabled
info: P010 texture support not available
info: Audio monitoring device:
	name: Par défaut
	id: default
info: ---------------------------------
warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-output-ui.so'
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
warning: Failed to initialize module 'decklink.so'
info: [pipewire] Available captures:
info: [pipewire]     - Desktop capture
info: [pipewire]     - Window capture
warning: v4l2loopback not installed, virtual camera disabled
info: NVENC supported
info: VAAPI: API version 1.21
info: FFmpeg VAAPI H264 encoding supported

sudo downgrade obs-studio from 30.1.0 to 30.0.2 makes it runnable, without virtual camera(may be incompatible with plugin?).

Here’s garuda-inxi

System:
  Kernel: 6.8.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b9a22b62-ad33-4e69-ada0-0426e5da4baa rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A wm: kwin_x11 dm: SDDM
    Distro: Garuda base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA506QE_FA506QE
    v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: FA506QE v: 1.0 serial: <filter>
    uuid: 3785b871-b0a8-0d4c-8640-0ad4b5eccd24 UEFI: American Megatrends LLC.
    v: FA506QE.306 date: 06/06/2022
Battery:
  ID-1: BAT1 charge: 33.8 Wh (100.0%) condition: 33.8/48.1 Wh (70.2%)
    volts: 12.4 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: full
CPU:
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics socket: FP6 bits: 64
    type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1962 high: 4078 min/max: 400/4463 base/boost: 3200/4450
    scaling: driver: amd-pstate-epp governor: powersave volts: 1.2 V
    ext-clock: 100 MHz cores: 1: 3262 2: 3267 3: 4078 4: 400 5: 3264 6: 400
    7: 3263 8: 400 9: 400 10: 400 11: 3726 12: 3264 13: 4078 14: 400 15: 400
    16: 400 bogomips: 102209
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0300
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 69.0 C
  Device-3: Goodong Industry USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:2 chip-ID: 3252:0001
    class-ID: 0e02 serial: <filter>
  Display: server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1521 built: 2020
    res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: radeonsi inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    renoir LLVM 17.0.6 DRM 3.57 6.8.1-zen1-1-zen) device-ID: 1002:1638
    memory: 500 MiB unified: no
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.0.3-arch1.1
    device-ID: 1002:1638 surfaces: xcb,xlib device: 1 type: discrete-gpu
    name: NVIDIA GeForce RTX 3050 Ti Laptop GPU driver: nvidia v: 550.54.14
    device-ID: 10de:25a0 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.3-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:2291 class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt, snd_sof_amd_vangogh, snd_sof_amd_acp63 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.8.1-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.4 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  IF-ID-2: utun state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Info: services: NetworkManager, sshd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 13d3:3563
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 2.33 TiB used: 128.26 GiB (5.4%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Yangtze Memory
    model: ZHITAI TiPlus7100 2TB size: 1.86 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: ZTA22003 temp: 48.9 C scheme: MBR
  SMART: yes health: PASSED on: 171d 21h cycles: 664
    read-units: 15,418,220 [7.89 TB] written-units: 5,320,804 [2.72 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: SK Hynix model: HFM512GD3JX013N
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 41000C20 temp: 40.9 C
    scheme: GPT
  SMART: yes health: PASSED on: 1y 235d 6h cycles: 12,564
    read-units: 61,806,188 [31.6 TB] written-units: 45,845,423 [23.4 TB]
Partition:
  ID-1: / raw-size: 143.81 GiB size: 143.81 GiB (100.00%)
    used: 128.24 GiB (89.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p8
    maj-min: 259:12
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 26.5 MiB (10.4%) fs: vfat block-size: 512 B dev: /dev/nvme1n1p1
    maj-min: 259:5
  ID-3: /home raw-size: 143.81 GiB size: 143.81 GiB (100.00%)
    used: 128.24 GiB (89.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p8
    maj-min: 259:12
  ID-4: /var/log raw-size: 143.81 GiB size: 143.81 GiB (100.00%)
    used: 128.24 GiB (89.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p8
    maj-min: 259:12
  ID-5: /var/tmp raw-size: 143.81 GiB size: 143.81 GiB (100.00%)
    used: 128.24 GiB (89.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p8
    maj-min: 259:12
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.03 GiB used: 5.8 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 87.4 C mobo: 40.0 C gpu: amdgpu temp: 69.0 C
  Fan Speeds (rpm): cpu: 3200
Info:
  Memory: total: 16 GiB note: est. available: 15.03 GiB used: 4.1 GiB (27.3%)
  Processes: 394 Power: uptime: 34m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 5.97 GiB services: org_kde_powerdevil, power-profiles-daemon,
    upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2222 libs: 466 tools: octopi,paru Compilers:
    clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi (sudo) default: Bash v: 5.2.26
    running-in: asciinema inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2022-12-27
  Last full system update: 2024-03-19
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       Yes
  Failed units:            preload.service 

Is my problem generic? My cousin, also a garuda user, says that he can run krunner normally. I really wanna know how come. Could anybody help me out?

Hi there, welcome to the forum.
Have you tried booting to the latest working snapshot, restore it, reboot and update again?
Maybe something went wrong with the last update.

1 Like

Thx for reply~
I did, yes I did.
The problem emerge on Mar 18
Tried to update at least 3 times that day, 2 times yesterday and 1 time today
All result in the SIGSEGV

For krunner, check if this helps:

For Vivaldi, try to search as well, there are some reports with that message, but at a quick look (no time at the moment) I couldn’t find any useful tip.
In general, you could start digging into the pacman.log with some variance of

cat /var/log/pacman.log | grep '2024-03-18' | egrep 'installed|upgraded|removed'

to see if something important was upgraded or removed on that day.
I know, it will be a mission impossible… :wink:

2 Likes

Why saying so?

But the thing is that I can run vivaldi as soon as I ran sudo downgrade vivaldi:

loading packages...
warning: downgrading package vivaldi (6.6.3271.50-1 => 6.6.3271.48-1)
resolving dependencies...
looking for conflicting packages...

Packages (1) vivaldi-6.6.3271.48-1

Total Installed Size:  364.54 MiB
Net Upgrade Size:        1.24 MiB

:: Proceed with installation? [Y/n]  
(1/1) checking keys in keyring                                               [--------------------------------------------] 100%
(1/1) checking package integrity                                             [--------------------------------------------] 100%
(1/1) loading package files                                                  [--------------------------------------------] 100%
(1/1) checking for file conflicts                                            [--------------------------------------------] 100%
(1/1) checking available disk space                                          [--------------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 993
:: Processing package changes...
(1/1) downgrading vivaldi                                                    [--------------------------------------------] 100%
:: Running post-transaction hooks...
(1/8) Arming ConditionNeedsUpdate...
(2/8) Foreign/AUR package notification
asciiquarium-transparent-git r24.cfe288e-1
boxes 2.3.0-1
clash-geoip 20240212-1
clash-premium-bin 2023.08.17-1
clash-verge 1.3.8-1
digital-rain-git r8.d3963c4-3
dingtalk-bin 7.5.0.40221-1
electron18 18.3.15-4
electron19 19.1.9-5
electron21 21.4.4-1
electron25 25.9.8-5
fcitx5-input-support 2021.09-1
gn-m76 0.1576.81ee1967-1
haskell-connection 0.3.1-238
haskell-x509-store 1.6.9-61
haskell-x509-system 1.6.7-64
haskell-x509-validation 1.6.12-66
js78 78.15.0-4
kdav5 1:5.115.0-1
khotkeys 5.27.10-1
kjs 5.115.0-1
kpeoplevcard 0.1-2
kquickcharts5 5.115.0-1
krunner5 5.115.0-1
kwin-scripts-forceblur 0.6.1-1.3
libsidplay 1.36.59-10
plasma5-applets-eventcalendar 76-1.4
plasma5-applets-netspeed 2.0-1
plugdata-git r6676.23daa5a6a-1
rime-ice-git r473.c2e02af-2
rootactions-servicemenu 2.7.3-1
screenplain 0.9.0-1
slides 0.9.0-2
stacer 1.1.0-1.4
swhkd-git 1.2.1.r73.ga4d2ffe-1
ttf-lxgw-wenkai 1.320-1
typstfmt-git r312.4802bdf-1
wayshot 1.3.1-2
(3/8) Orphaned package notification...
bluetooth-autoconnect 1.3-1.5
bluez-qt5 5.115.0-1
boost 1.83.0-5
cargo-tauri 1.5.11-1
chrono-date 3.0.1-3
cython 3.0.9-1
electron 1:29-1
electron18 18.3.15-4
electron19 19.1.9-5
electron21 21.4.4-1
electron22 22.3.27-5
electron25 25.9.8-5
electron27 27.3.5-1
eventviews 24.02.0-1
frameworkintegration5 5.115.0-1
geocode-glib 3.26.4-4
gn-m76 0.1576.81ee1967-1
go 2:1.22.1-1
gperf 3.1-5
gptfdisk 1.0.10-1
grantlee 5.3.1-1
haskell-connection 0.3.1-238
haskell-hsyaml 0.2.1.3-2
jq 1.7.1-1
js78 78.15.0-4
kactivities-stats5 5.115.0-1
kcalendarcore5 5.115.0-1
kcmutils5 5.115.0-1
kdav5 1:5.115.0-1
kdeplasma-addons 6.0.2-4
kdesu5 5.115.0-1
kdiagram5 2.8.0-1
kdnssd5 5.115.0-1
kdsoap-qt5 2.2.0-1
kfilemetadata5 5.115.0-1
kholidays5 1:5.115.0-1
kidletime5 5.115.0-1
kimageannotator-qt5 0.7.1-2
kirigami-addons5 0.11.0-7
kjs 5.115.0-1
knotifyconfig5 5.115.0-1
kpeoplevcard 0.1-2
kquickcharts5 5.115.0-1
krunner5 5.115.0-1
ktexteditor5 5.115.0-1
ldns 1.8.3-2
lib32-readline 8.2.010-1
libcddb 1.3.2-7
libibus 1.5.29-3
libindicator-gtk3 12.10.1-10
libkdcraw5 24.02.0-1
libportal-qt5 0.7.1-2
libqaccessibilityclient-qt5 0.6.0-1
libsidplay 1.36.59-10
libvisual 0.4.2-1
libxres 1.2.2-1
lld 17.0.6-1
m17n-lib 1.8.4-2
mcfly 0.8.4-2
modemmanager-qt5 5.115.0-1
moreutils 0.69-1
networkmanager-qt5 5.115.0-1
nlohmann-json 3.11.2-2
ntp 4.2.8.p17-1
openfortivpn 1.21.0-1
openssl-1.1 1.1.1.w-1
oxygen-sounds 6.0.2-3
pnpm 8.15.2-2
purpose5 5.115.0-3
python-appdirs 1.4.4-9
python-beaker 1.12.0-4
python-nspektr 0.5.0-1
python-rx 3.2.0-4
qgpgme-qt5 1.23.2-1
qqc2-desktop-style5 5.115.0-1
qt5-networkauth 5.15.13-1
qtkeychain-qt5 0.14.2-1
rest 0.8.1+r4+ge5ee6ef-1
scdoc 1.11.3-1
sysfsutils 2.1.1-1
tinycompress 1.2.11-1
vmware-keymaps 1.0-3.1
webrtc-audio-processing 0.3.1-4
xorg-server-xvfb 21.1.11-2
yasm 1.3.0-6
zenstates-git r6.0bc27f4-1
(4/8) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/passwd.pacnew
/etc/shells.pacnew
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pam.d/kde.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/ssh/sshd_config.pacnew
/etc/pacman.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
/etc/plymouth/plymouthd.conf.pacnew
/etc/texmf/web2c/fmtutil.cnf.pacsave
Please check and merge
(5/8) Updating icon theme caches...
(6/8) Updating the desktop file MIME type cache...
(7/8) Performing snapper post snapshots for the following configurations...
==> root: 994
(8/8) Syncing all file systems...
add vivaldi to IgnorePkg? [y/N] n

Things are getting more weird.
I did a garuda-update immediately after downgrading.
It says there are only 2 packages to update: obs-studio and vivaldi
How’s it possible there’s no upgrade in the recent 16 hrs?! I even updated something in the morning(then I rolled back)
After that, my vivaldi 6.6.3271.50 worked! But obs still terminated by signal SIGSEGV

Also, 'merkuro-calendar' terminated by signal SIGSEGV (Address boundary error)

Suspecting that there are some incompatible api or something, I tried to rebuild everything using paru -Qqn | paru -S -
But got a lot of errors like

error: snapper-support: signature from "TNE <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/snapper-support-1.1.2-3-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n

and finally

error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Maybe vivaldi is an exception. But there must be something affecting obs and kde things.
It must be sort of system level thing I guess?

Don’t know if this is relevant, my snapper tools is quite ugly now, not using kvantum-dark theme as before

Does this persist after deleting the cached file?

2 Likes

Solved, though dunno why and how.

The last time I saw such errors was in a virtual machine containing eos, which I hadn’t booted for months, with GPG signs expired. Deleting at that time make no use, rather caused much trouble, which prevented me from trying so today.

Anyway, I tried to boot to the earliest snapshot, which contains runnable krunner.
Ran paru -Qqn | paru -S - again. Unfortunately 4 packages(0.39 MiB) failed to download. So I ran garuda-update instead.
Dunno if paru is aware of the previous pending task, but he said that there’re 320 packages to update and total install size is almost 5G, containing krunner(6.0.0-1) and merkuro(24.02.0-1). After that and a reboot, things worked quite acceptable:

  • :+1::
    • krunner and merkuro-canlendar work just fine
    • plasma shell no longer restarts upon my searching in the, uh, pop-up-on-meta panel
    • Vivaldi is also working
  • :person_shrugging::
    • obs still doesn’t work, till I downgraded it
    • still cannot switch activity. Maybe that’s another story

Using arch, I’m really a gambler, maybe I should consider using garuda in nix. :eyes:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.