Snapshot notification after restoring an old snapshot

Yesterday after updating my system using the "upd" fish alias I had to restore a snapshot because booting the OS would end up in a black screen after the garuda loading screen. Tried ctrl+alt+f2 and unplugging the hdmi but they didn't work, well whatever. So I booted into a old snapshot and in the timeshift application I restored the booted snapshot, but now whenever I boot into the system normally I get this notification. System also feels sluggish but that might be related the to the system update, I'll wait a couple weeks for a new updates and if those don't work I'll do a reinstall. Just wondering if there is something I should do about this notification.


Hi and welcome to the community :beers:

PS: Bear with me with my little knowledge of Linux

  1. Click on the snapshot that safe to restore on timeshift.
  2. Click on restore and it will make [LIVE] before restoring snapshot
  3. Wait a while and it will be make the boot default snapshot.

I hope this will help you. Because this is based on my experience when the SDDM problem came up just recently. Good luck :smiley:

Hey, thank you for replying.
I think I've done all of those steps correctly already but I'll make sure by listing it again.

  1. I booted to a working snapshot from grub
  2. I restored the working snapshot from timeshift
  3. I rebooted and I got a working system again
    But still I'm getting the notification that I've booted into a snapshot "original posts picture" I don't think it's harmful in anyway but still kind of odd.
sudo update-grub

Hello, good Freitag and thanks for the reply.
I did a another system upgrade and grub-update but no change.
I'm pretty sure the grub was updated when I restored the snapshot because without it I would still be booting into the broken one.

update-grub before system update/upgrade.

Just an idea, I never got this message.

Well, I have nothing to upgrade but I did grub-update and rebooted.
grub.cfg and grub-btrfs.cfg both updated, I checked with

ls /boot/grub/
.rw-r--r--  33k root 24 huhti 00:50  ξ˜• grub-btrfs.cfg
.rw-------  14k root 24 huhti 00:50  ξ˜• grub.cfg

I'm still getting the notification, kernel is also up to date.

ls /boot/
drwx------   - root  1 tammi  1970  ο„• efi
drwxr-xr-x   - root 24 huhti 00:50  ο„• grub
drwxr-xr-x   - root 25 helmi 16:38  ο„• memtest86+
.rw-r--r-- 41k root 15 maalis 14:42 ο…› amd-ucode.img
.rw-r--r-- 60M root 24 huhti 00:24  ο…› initramfs-linux-zen-fallback.img
.rw-r--r-- 37M root 24 huhti 00:24  ο…› initramfs-linux-zen.img
.rw-r--r-- 10M root 24 huhti 00:23  ο€– vmlinuz-linux-zen
sudo grub-install
sudo update-grub

Still the same, no difference.

Are there two entries in grub for garuda linux try second entry

1 Like

Thank you
I've been blind this whole time, there was a second entry in my grub for /dev/sdc2/ where my install is located. How can I fix this and only have this install show up in grub?

sudo grub-install
sudo update-grub

Thank you very much
Okey, this fixes that the first selection in grub menu is right but the /dev/sdc2 still stays there. I think this is a "none problem" but just letting everyone else who might see this in the future know.

I have the same problem and I don`t know how to check if there is two entries as am a newbie please help

when I run this " sudo grub-install" I get this error
Installing for i386-pc platform.
grub-install: error: install device isn't specified.

From Configuring the bootloader - Gentoo Wiki

grub-install --target=x86_64-efi --efi-directory=/boot

Might be worth trying if you are running on 64 bit processor.

Thanks for your support @ETO
after I run this "grub-install --target=x86_64-efi --efi-directory=/boot"
I get this error "Installing for x86_64-efi platform.
grub-install: error: /boot doesn't look like an EFI partition."

It seems like you have a bios install
Run lsblk and try to find what disk your /boot partition is located

sda      8:0    0 232,9G  0 disk
sdb      8:16   0 111,8G  0 disk
sdc      8:32   0 465,8G  0 disk
β”œβ”€sdc1   8:33   0   260M  0 part /boot/efi
β”œβ”€sdc2   8:34   0 456,7G  0 part /run/timeshift/backup
└─sdc3   8:35   0   8,8G  0 part [SWAP]

It usually is on the /dev/sda but in my case I would run

grub-install /dev/sdc

But for you it probably is

grub-install /dev/sda

Must be

sudo grub-install /dev/sdc1
1 Like

I also just noticed /dev/sdc2 shouldn't probably be mounted in there.

sda      8:0    0 232,9G  0 disk
sdb      8:16   0 111,8G  0 disk
sdc      8:32   0 465,8G  0 disk
β”œβ”€sdc1   8:33   0   260M  0 part /boot/efi
β”œβ”€sdc2   8:34   0 456,7G  0 part /run/timeshift/backup
└─sdc3   8:35   0   8,8G  0 part [SWAP]
sdd      8:48   0 232,9G  0 disk
└─sdd1   8:49   0 232,9G  0 part
sde      8:64   0 931,5G  0 disk
└─sde1   8:65   0 931,5G  0 part
sdf      8:80   0 238,5G  0 disk
└─sdf1   8:81   0 238,5G  0 part
sdg      8:96   0 167,7G  0 disk
└─sdg1   8:97   0 167,7G  0 part
zram0  254:0    0   2,9G  0 disk [SWAP]
zram1  254:1    0   2,9G  0 disk [SWAP]
zram2  254:2    0   2,9G  0 disk [SWAP]
zram3  254:3    0   2,9G  0 disk [SWAP]
zram4  254:4    0   2,9G  0 disk [SWAP]
zram5  254:5    0   2,9G  0 disk [SWAP]
zram6  254:6    0   2,9G  0 disk [SWAP]
zram7  254:7    0   2,9G  0 disk [SWAP]