Snapper problems

So for proper order and to get Snapper to take boot snapshots we need to launch a separate tool and check a couple of extra boxes? This on top of Snapper not keeping the correct time and keeping more snapshots than you told Snapper to keep which from talking to peeps both of these behaviors are the norm.

You make it sound like this is some great hardship. What's the problem? Nothing could be easier.

Are you sure you want boot snapshots? Most people do not need those. Pre- and post-update snapshots are more useful for most people.

If you are having trouble getting Snapper configured the way you want, open up a new thread and ask for help. I'm sure the community can help you get it sorted out.

Your comment makes it sound like you are practically trying to be unhappy with the software ("why do I need to take extra steps to get more snapshots", + "I am getting too many snapshots" = :exploding_head:).

7 Likes

Snapper keeping more snapshots than I have it set for is a huge problem in my book. Today again I had to go in and remove a dozen older snapshots over the 10 I have it set to save. That is a lot of drive space that doesn't need to be eaten up. The second thing is the timestamps, I don't care that Snapper is using military time but it could at least have the actual time the snapshot was taken and not be several hours off. At first I thought maybe Snapper was grabbing the time from the bios and so I checked the bios and it's correct. I can agree with you on the boot snapshots cause if the update is important enough or large enough I can just manually create another snapshot before rebooting. As for having to launch a second app to set settings that are part of Snapper no that should never be the case, all setting for a particular program should be in that program.

The snapper cleanup job reduces the snapshots to match the settings you have set. If that isn't happening, something is wrong in your config.

I have no idea what you are referring to. It sounds like something is wrong with your system setup.

The settings for snapper are all in snapper. Btrfs Assistant is a tool that makes it easier but it isn't a requirement to use it. You can change the settings in the snapper config files or via the snapper program.

You seem to have some misunderstandings of how this all works. Either way, I agree with @BluishHumility, if you have issues and want help, you should open a topic for that.

5 Likes

Too many snapshots being kept is a Snapper issue documented by more than a few people like myself who have our setting correct. As for the time stamp for snapshots being wrong no one is addressing that. That said I have either put in a issue ticket covering both issues or commented on a open issue ticket over a month back with no progress on either issue from what I can see.

So, I have now separated this from the other topic,
now only your garuda-inxi is missing.

3 Likes

The problem isn't that it doesn't work, the problem is that some people have a misunderstanding of what it is supposed to do.

Maybe if you shared an example of what you are talking about? The snapper time isn't wrong on any of my snapshots across numerous installs.

What "issue tickets" are you referring to, specifically?

3 Likes

Is this what you mean by the snapshot timestamps being wrong?

The highlighted manual snapshot is one I just created (minutes are right - just took the screenshot a few minutes after I made the snapshot, but hours are wrong). It seems Snapper uses UTC on my system instead of AET - is this the same for you, or are your minutes also completely off?

Imo it's not a dealbreaker, I'm used to Librewolf using UTC anyways :slight_smile:

2 Likes

Exact the hours were always wrong.

I think the way snapper is set up by default is really good for most users. It will clean your snapshots once a day. But this will lead to more snapshots than you set, if you do a lot of updates during a day or if you have enabled hourly snapshots.

But I also don't want to keep more snapshots than I have set in BTRFS-Assistant. I have fixed that by editing /usr/lib/systemd/system/snapper-cleanup.timer and changing OnUnitActiveSec to 1 hour:

[Timer]
OnBootSec=10m
OnUnitActiveSec=1h

This will clean up your snapshots every hour using the number of snapshots you specified in BTRFS-Assistant. Don't forget to enable Snapper cleanup enabled in the Snapper Settings of BTRFS-Assistant for each config, but this should be set by default. I use this mainly for my home volume, because I want to have hourly snapshots there, but only for the last 6h.

You can run a manual cleanup with sudo /usr/lib/snapper/systemd-helper --cleanup.

3 Likes

daltoi is right. I just switched to Timeshift after being fed up with Snapper's timestamps on snapshots being off by hours and after checking how many snapshot I had and finding the previous day it had done automatic hourly snapshots when I changed noting in Snapper.

1 Like

You sure do like to whine in lots of topics about this.

That being said, Snapper will always take hourly snapshots if you have timeline snapshots enabled. That is what it is supposed to do.

4 Likes

I never whine, which means your statement isn't remotely remotely true. Now that said I will reiterate that Snapper does seem to have it's issues. As I clearly stated I did not have hourly snapshots checked when I found Snapper taking them, so it was the last straw with it and I replaced it with Timeshift.

You aren't listening. When snapper timeline snapshots are enabled it always takes hourly snapshots.

The settings you have checked are what snapshots are saved when the cleanup job runs.

4 Likes

I suggest we continue this "branch" of the topic where it belongs:

There where some questions made to the OP (examples, tickets, etc.) but not yet answered.

6 Likes

I get it just fine. In the tool I had hourly set to ZERO, so no it should not have been doing hourly.

That is wrong so you clearly don't understand.

When hourly is set to 0 that does not mean don't take hourly snapshots.

Those settings are for the cleanup job. It means reduce the hourly snapshots to 0 when the cleanup job runs.

No hourly snapshots. Only on Updates / install / uninstall:
Uncheck Enable timeline snapshots and Snapper timeline enabled

Hourly snapshots:

3 Likes