Snapper fails with error when installing

garuda-inxi
╰─λ garuda-inxi
System:
Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1dd90d13-befd-4a0d-a81d-dd5d56786fbb rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Beats 15 Notebook PC v: N/A
serial: <filter> Chassis: type: 10 serial: N/A
Mobo: HP model: 22A9 v: 72.48 serial: <filter> UEFI: American Megatrends
v: F.46 date: 04/18/2018
Battery:
ID-1: BAT0 charge: 11.2 Wh (100.0%) condition: 11.2/11.2 Wh (100.0%)
volts: 16.8 min: 14.6 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: Charging cycles: 100
Device-1: hidpp_battery_0
model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: AMD A10-7300 Radeon R6 10 Compute Cores 4C+6G socket: P0
bits: 64 type: MT MCP arch: Steamroller family: 0x15 (21)
model-id: 0x30 (48) stepping: 1 microcode: 0x6003109
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 1100 min/max: 1100/1900 boost: enabled
base/boost: 1900/1900 scaling: driver: acpi-cpufreq governor: performance
volts: 1.0 V ext-clock: 100 MHz cores: 1: 1100 2: 1100 3: 1100 4: 1100
bogomips: 15171
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Kaveri [Radeon R6 Graphics] vendor: Hewlett-Packard
driver: radeon v: kernel alternate: amdgpu ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:01.0 chip-ID: 1002:130a class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) Webcam type: USB
driver: uvcvideo bus-ID: 2-4:2 chip-ID: 05c8:036e class-ID: 0e02
Display: server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa gpu: radeon
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
OpenGL: renderer: AMD KAVERI (DRM 2.50.0 5.16.14-zen1-1-zen LLVM 13.0.1)
v: 4.5 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Kaveri HDMI/DP Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308
class-ID: 0403
Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 193.46 GiB (20.8%)
ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A9E680
family: Travelstar 5K1000 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: A710 temp: 41 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 93d 16h cycles: 2776
Old-Age: g-sense error rate: 2218
Partition:
ID-1: / raw-size: 480.6 GiB size: 480.6 GiB (100.00%)
used: 108.39 GiB (22.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 27.6 MiB (28.7%) fs: vfat block-size: 512 B dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 480.6 GiB size: 480.6 GiB (100.00%)
used: 108.39 GiB (22.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-4: /var/log raw-size: 480.6 GiB size: 480.6 GiB (100.00%)
used: 108.39 GiB (22.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-5: /var/tmp raw-size: 480.6 GiB size: 480.6 GiB (100.00%)
used: 108.39 GiB (22.6%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 6.79 GiB used: 77.5 MiB (1.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.4 C mobo: N/A gpu: radeon temp: 53.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 258 Uptime: 2h 7m wakeups: 10 Memory: 6.79 GiB
used: 3.17 GiB (46.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 2129 note: see --pkg apt: 1
pacman: 2128 lib: 539 Shell: fish (sudo) v: 3.3.1 running-in: konsole
inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-13
Last full system update: 2022-03-15 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

When I try to install I get a failure with snap-pac when it tries ro run snapper!

File "/usr/share/libalpm/scripts/snap-pac", line 40
f"--config {config} create",
^
SyntaxError: invalid syntax
Error: command failed to execute correctly
Error: Failed to commit transaction: failed to run transaction hooks

If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.

Did you check the git?

okay will do, check the git for what?

:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
File "/usr/share/libalpm/scripts/snap-pac", line 40
f"--config {config} create",
^
SyntaxError: invalid syntax
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

Please edit your posts.

what do you want me to do to them?

I did 3 up and 3 down

Yeah, but on the wrong places.

Ok, I will fix it for you. Check what I change.

Any help with My problem?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.