Snapper cannot create new snapshot

hi everybody , how r u doing ,
after i deleted all snapshots i have , the snapper cannot create new snapshot , is there a solution for this problem ?
the attached image is from btrfs assistant , and when i install any app i get error saying
(8/9) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.

System:
  Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=628747ff-bed5-41a4-b877-703bb8c89356 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: MATE v: 1.26.0 info: mate-panel wm: marco v: 1.26.0 vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20351 v: Lenovo G50-70
    serial: <superuser required> Chassis: type: 10 v: Lenovo G50-70
    serial: <superuser required>
  Mobo: LENOVO model: Lancer 5A2 v: NANANANANO DPK
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: 9ACN32WW
    date: 07/20/2015
Battery:
  ID-1: BAT0 charge: 14.8 Wh (94.9%) condition: 15.6/31.7 Wh (49.3%)
    volts: 15.0 min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter>
    status: discharging
CPU:
  Info: model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1079 high: 1397 min/max: 800/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 918 3: 1397
    4: 1201 bogomips: 19155
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16 class-ID: 0300
  Device-2: AMD Sun LE [Radeon HD 8550M / R5 M230] vendor: Lenovo
    driver: radeon v: kernel alternate: amdgpu arch: GCN-1
    code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 2
    speed: 5 GT/s lanes: 4 link-max: lanes: 8 bus-ID: 03:00.0
    chip-ID: 1002:666f class-ID: 0380 temp: 39.0 C
  Device-3: IMC Networks Lenovo EasyCamera type: USB driver: uvcvideo
    bus-ID: 2-6:3 chip-ID: 13d3:5727 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: marco v: 1.26.0 driver:
    X: loaded: modesetting,radeon alternate: fbdev,intel,vesa
    dri: crocus,radeonsi gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x40ec built: 2013 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 5000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Lenovo Z50-75 driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek RTL8723B Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 2-7:4 chip-ID: 0bda:b728 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 28.7 GiB (6.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LVM1
    scheme: MBR
Partition:
  ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 28.7 GiB
    (6.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 28.7
    GiB (6.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 28.7
    GiB (6.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 28.7
    GiB (6.2%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.58 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: radeon temp: 39.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 213 Uptime: 11m wakeups: 1 Memory: 11.58 GiB used: 1.74 GiB
  (15.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1192 libs: 322
  tools: octopi,paru Shell: Bash v: 5.1.16 running-in: mate-terminal
  inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-09-25
  Last full system update: 2022-10-16
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:    

Please try

update remote reset-snapper

It looks like you deleted the /.snapshots subvolume. That will definitely break snapper.

i tried the previous command , nothing happened !!

so you think there is nothing i can do now??

What does sudo file /.snapshots return?

/.snapshots: cannot open `/.snapshots' (No such file or directory)

Try:

sudo btrfs subvolume create /.snapshots

Then see if you can take a snapshot.

5 Likes

this worked perfectly , thanks a lot dude , appreciated...

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.