Slow boot II

I am experiencing similar issues. NVIDIA GPU and Linux-Zen kernel here.

I tried an update without the kernel update, and I still have issues…

I also tried re-installing the NVIDIA drivers and problems persist. I think there is currently an issue with the NVIDIA driver and the latest kernel, but I can’t be sure. I see “flip event timeout on head0” errors relating to NVIDIA-DRM on startup and a bunch of bluetooth errors which look like red herrings.

The system still boots up eventually, but it takes ages.

RTX 2080
Ryzen 5800X

Once booted, everything appears to be fine, so far…but it takes ages to get there.

I updated my BIOS to see if that helps, but it doesn’t…same problem.

Problem for me is definitely either NVIDIA driver related or it’s the latest Linux-Zen kernel.

Welcome :slight_smile:

Please, open new help request and follow the template.

Check your kernel parameter nvidia-drm.modeset=1

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ nvidia-drm.modeset=1 "/g' -i /etc/default/grub && sudo update-grub

Hi there,

I am using X11 not Wayland…I do not have nvidia-drm.modeset=1 set as far as I can tell.

Are you suggesting that I should set it? I have opened a new thread.



1 Like

Yo, ran a system update and ran into the error above. System still boots, but takes ages…not sure what the issue might be.

  Kernel: 6.6.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=bd6e4338-b445-4699-9379-873ee16d03a3 rw rootflags=subvol=@
    root=/dev/mapper/luks-6ec89152-af0e-4ea0-9950-abd5cc2a2a1e quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: GNOME v: 45.2 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7C84 v: 1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.F0
    date: 10/12/2023
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA20102B
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4374 high: 4375 min/max: 2200/5584 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4375 2: 4375
    3: 4375 4: 4375 5: 4375 6: 4375 7: 4374 8: 4374 9: 4375 10: 4375 11: 4375
    12: 4375 13: 4375 14: 4373 15: 4370 16: 4375 bogomips: 139995
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: Micro-Star MSI
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: none off: DP-2,DP-3,HDMI-A-1
    empty: DP-1,Unknown-2 bus-ID: 2d:00.0 chip-ID: 10de:1e82 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 7280x3840 s-dpi: 96 s-size: 1926x1016mm (75.83x40.00")
    s-diag: 2178mm (85.73")
  Monitor-1: DP-2 note: disabled pos: top-left model: Samsung U28E590
    serial: <filter> built: 2015 res: 2160x3840 hz: 60 dpi: 159 gamma: 1.2
    size: 345x607mm (13.58x23.9") diag: 698mm (27.5") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  Monitor-2: DP-3 mapped: DP-4 note: disabled pos: primary,bottom-c
    model: Dell S2721DGF serial: <filter> built: 2021 res: 2560x1440 dpi: 109
    gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
    modes: max: 2560x1440 min: 640x480
  Monitor-3: HDMI-A-1 mapped: HDMI-0 note: disabled pos: bottom-r
    model: Samsung C27JG5x serial: <filter> built: 2019 res: 2560x1440 dpi: 109
    gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
    modes: max: 2560x1440 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2
    memory: 7.81 GiB
  API: Vulkan v: 1.3.269 layers: 6 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 2080 driver: nvidia v: 545.29.06
    device-ID: 10de:1e82 surfaces: xcb,xlib

I have tried updating everything except the kernel, I have tried reinstalling the NVIDIA driver.

There is nothing wrong with my drives, they are fairly new and reporting no errors…booting to another OS installed on the same drives shows no issues.

I updated my BIOS to the latest version available and it made no difference.

When I revert to the previous snapshot, everything is fine.

I have implemented the modeset change and I am about to reboot. Will report back shortly.

So we must know which apps are in the update.

1 Like

Modeset did nothing, if anything it’s worse.

Not all that much in the update really…

           alsa-card-profiles-1:1.0.0-2  android-udev-20231124-1  appstream-1.0.0-5
           archlinux-keyring-20231130-1  aspnet-runtime-8.0.0.sdk100-1  audacity-1:3.4.2-2
           avahi-1:0.8+r189+g35bb1ba-1  aws-cli-v2-2.14.5-1  blas-3.12.0-2  c-ares-1.23.0-1
           calibre-7.1.0-2  cblas-3.12.0-2  chromium-119.0.6045.199-1  cmake-3.27.9-1
           containerd-1.7.10-1  cython-3.0.6-1  discord-0.0.36-1  docker-compose-2.23.3-1
           dotnet-host-8.0.0.sdk100-1  dotnet-runtime-8.0.0.sdk100-1  dotnet-sdk-8.0.0.sdk100-1
           dotnet-targeting-pack-8.0.0.sdk100-1  edk2-aarch64-202311-1  edk2-arm-202311-1
           edk2-ovmf-202311-1  enchant-2.6.3-1  evolution-data-server-3.50.2-1  eza-0.16.2-1
           file-roller-43.1-1  firefox-120.0.1-1  firefox-developer-edition-121.0b6-1  fwupd-1.9.10-1
           fzf-0.44.1-1  garuda-nvidia-config-2:1.1.6-1  garuda-update-4.3.3-1  gjs-2:1.78.1-1
           gnome-bluetooth-3.0-42.7-2  gnome-disk-utility-45.1-1  gnome-settings-daemon-45.0-2
           gnome-shell-1:45.2-1  gnupg-2.4.3-2  gpgme-1.23.2-1  gst-plugin-pipewire-1:1.0.0-2
           insomnia-8.4.5-1  juno-theme-git-r215.aa3748e-1  lapack-3.12.0-2  lib32-gettext-0.22.4-1
           lib32-libdecor-0.2.1-1  lib32-libpipewire-1:1.0.0-1  lib32-libtiff-4.6.0-2
           lib32-libxml2-2.12.1-1  lib32-pipewire-1:1.0.0-1  lib32-pipewire-jack-1:1.0.0-1
           libadwaita-1:1.4.2-1  libcap-2.69-3  libcmis-0.6.2-1  libdecor-0.2.1-1  libibus-1.5.29-2
           liblangtag-0.6.7-1  libmirage-3.2.7-1  libnautilus-extension-45.2-1  libpamac-aur-11.6.2-2
           libpipewire-1:1.0.0-2  libpulse-16.1-7  libreoffice-fresh-7.6.3-3  libtiff-4.6.0-2
           liburing-2.5-1  libvirt-glib-5.0.0-1  libwacom-2.9.0-2  libwbclient-4.19.3-1
           libwireplumber-0.4.17-1  libxml2-2.12.1-1  libxnvctrl-545.29.06-1  lilv-0.24.22-1
           linux-zen-6.6.3.zen1-1  linux-zen-headers-6.6.3.zen1-1  lsof-4.99.0-1  mcfly-0.8.3-1
           mercurial-6.6-1  mhwd-db-garuda-2:1.1.6-1  mkinitcpio-37.1-1  mlt-7.22.0-1
           multipath-tools-0.9.7-4  mutter-45.2-1  nautilus-45.2-1
           netstandard-targeting-pack-8.0.0.sdk100-1  network-manager-sstp-1.3.2-1
           noto-fonts-1:23.12.1-1  noto-fonts-emoji-1:2.042-1  nvidia-settings-545.29.06-1
           onevpl-2023.4.0-1  opera-105.0.4970.29-1  opera-ffmpeg-codecs-119.0.6045.199-1
           orchis-theme-git-2023.10.20.r14.gc7743283-1  pamac-aur-11.6.0-4  pandoc-cli-
           papirus-icon-theme-20231201-1  paru-2.0.1-1  pcsclite-2.0.1-1  perl-5.38.1-1
           pipewire-1:1.0.0-2  pipewire-alsa-1:1.0.0-2  pipewire-audio-1:1.0.0-2  pipewire-jack-1:1.0.0-2
           pipewire-pulse-1:1.0.0-2  pipewire-v4l2-1:1.0.0-2  pipewire-x11-bell-1:1.0.0-2
           pipewire-zeroconf-1:1.0.0-2  pkgconf-2.0.3-1  plymouth-git-22.02.122.r232.g2c4578a1-1
           poppler-23.12.0-1  poppler-glib-23.12.0-1  pulsemixer-1.5.1-5  python-attrs-23.1.0-1
           python-awscrt-0.19.18-1  python-cheetah3-3.3.3-1  python-cryptography-41.0.7-1
           python-nspektr-0.5.0-1  python-prompt_toolkit-3.0.41-1  python-pydantic-2.5.2-1
           python-pydantic-core-1:2.14.5-1  python-pyqt6-6.6.0-3  python-setuptools-1:68.2.0-1
           python-trove-classifiers-2023.11.29-1  python-xxhash-3.2.0-2  qt5-base-5.15.11+kde+r147-1
           qt6-5compat-6.6.1-1  qt6-base-6.6.1-1  qt6-declarative-6.6.1-1  qt6-imageformats-6.6.1-1
           qt6-multimedia-6.6.1-1  qt6-multimedia-ffmpeg-6.6.1-1  qt6-positioning-6.6.1-1
           qt6-svg-6.6.1-1  qt6-translations-6.6.1-1  qt6-wayland-6.6.1-1  qt6-webchannel-6.6.1-1
           qt6-webengine-6.6.1-1  ripgrep-14.0.3-1  ruby-bundler-2.4.22-1  samba-4.19.3-1
           shaderc-2023.7-2  smbclient-4.19.3-1  solaar-1.1.10-2  sord-0.16.16-1  sqlite-3.44.2-2
           sratom-0.6.16-1  suil-0.10.20-1  teamviewer-15.48.4-1  telegram-desktop-4.12.2-1
           thunderbird-115.5.1-1  ttf-fantasque-nerd-3.1.1-1  ttf-firacode-nerd-3.1.1-1
           ttf-iosevka-nerd-3.1.1-1  ugrep-4.3.4-1  verdict-1.4.2-1  vim-9.0.2143-1
           vim-runtime-9.0.2143-1  vtk-9.3.0-7  wine-8.21-2  wireplumber-0.4.17-1  wireshark-cli-4.2.0-2
           wireshark-qt-4.2.0-2  wxwidgets-common-3.2.4-2  wxwidgets-gtk3-3.2.4-2
           xdg-desktop-portal-gnome-45.1-1  yay-12.2.0-1

If anything the problem seems to be related to this:

But I don’t seem to have fbdev=1 enabled as far as I can tell.

I should point out that the DRM errors I see happen before any desktop environment is loaded. It just sits there for ages spitting out the same error until eventually I get a login screen. Then everything seems to be fine…occasionally, it’ll just hang there indefinitely.

I’m almost 100% sure it’s an NVIDIA driver bug with the latest kernel.

I can see 6.6.4 kernel was pushed upstream 11 hours ago…should I wait for that to land?

mhwd-kernel -li
Currently running: 6.6.4-AMD-znver3 (linux-amd-znver3)
The following kernels are installed in your system:
local/linux-zen 6.6.3.zen1-1
local/linux-amd-znver3 6.6.v.4-1

Please do not post here in the forum, like in chat forums like Telegram.
As long as no one has responded to your post, you can edit your post.

1 Like

Ok noted, but if you don’t post in a linear fashion, it’s hard for people to follow the timeline of the thread if they weren’t here when the thread was started. That’s why forums are threaded.

1 Like

i recommend using the (edit1, edit2, etc) style if that is your thought process. trying to read through this thread was rather confusing.

edit1: ah i see that this thread was “forked” out of the other thread, that explains part of the confusing aspect.

1 Like

Yeah jank forum modding. I originally participated in another thread.

I work in tech / dev and deal with threaded tickets all the time. Its way easier to assist someone if you have the thread organized in a linear fashion. Even if it makes the thread massive because you can read it top to bottom and not have to bounce back to the top to read edits…it also allows outsiders to bring themselves up to speed a lot quicker…more importantly you know not just what someone has tried you also know why and when and how they got there…way less ambiguous.

You branch out at junctures…say there are two options to try. That creates two new threads to follow. Eventually when a solution is reached you prune the dead branches and you have a single timeline that leads to the correct solution.

I’ve been working this way for 20 years and it has never steered me wrong.

With this setup, you can end up with loads of potential solutions that people will try in various different orders that may result in a solution, but you won’t know why.

Maybe a translation problem, I did not mean you must edit your first post.
These 4 posts can be one post.


I think you’re right. You think you’re right. Forum Mods think you’re wrong. Guess who wins the shoot-out?

That makes sense, and is what was originally meant.

This is very much an International Linux users forum. Many users need to resort to translation software–or what they learned in a language school–and it’s not uncommon for translations that include conceptual ideas, especially, to be mis-translated or difficult to grasp.


The other user that reported this issue tried the LTS kernel and reported no improvement, so another kernel such as the linux-hardened might be worth a try. If you feel your Nvidia driver could be a cause then perhaps you might want to test out the free Nvidia driver.


Ok fair enough. Point taken.

Thanks for the pointers. The open driver seems to work, but that just narrows the problem down to the NVIDIA driver. The open driver isn’t actually a fix.

I think either I have to wait for a newer kernel that handles the problem, or I need to wait for a newer NVIDIA driver. In the meantime, I’ll hold off updating those packages.