Sleep/suspend Issue/glitch on laptop

Hello guys,

I installed on my laptop garuda-dragonized. The issue is when it goes to sleep/suspend the graphics are totally messed up and I need to reboot the laptop to fix it.

I looked for some solutions found this on reddit but I’m getting following error when I run the sudo dracut --force command:

dracut[I]: Executing: /usr/bin/dracut --force
dracut[F]: Can't write to /boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen: Directory /boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen does not exist or is not accessible.
╰─λ garuda-inxi
Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: hpet avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=8201d9e1-7c33-41bf-bff1-3b9264795992 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: LENOVO product: 82JQ v: Legion 5 Pro 16ACH6H
serial: <superuser required> Chassis: type: 10 v: Legion 5 Pro 16ACH6H
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
part-nu: LENOVO_MT_82JQ_BU_idea_FM_Legion 5 Pro 16ACH6H
uuid: <superuser required> UEFI: LENOVO v: GKCN64WW date: 12/07/2023
ID-1: BAT0 charge: 71.9 Wh (98.1%) condition: 73.3/80.0 Wh (91.7%)
power: 8.3 W volts: 16.8 min: 15.4 model: Celxpert L20C4PC1 type: Li-poly
serial: <filter> status: charging cycles: 73
Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000C
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 469 high: 1510 min/max: 400/4463 scaling:
driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
4: 400 5: 400 6: 400 7: 400 8: 1510 9: 400 10: 400 11: 400 12: 400 13: 400
14: 400 15: 400 16: 400 bogomips: 102206
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
off: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:24dd
class-ID: 0300
Display: wayland server: v: with: Xwayland v: 23.2.6
compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: 0
Monitor-1: eDP-1 res: 2560x1600 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
x11: drv: zink inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070 Laptop
GPU/PCIe/SSE2 memory: 7.81 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 3070 Laptop GPU driver: nvidia v: 550.78 device-ID: 10de:24dd
surfaces: xcb,xlib,wayland
Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel v: kernel
pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt, snd_sof_amd_vangogh, snd_sof_amd_acp63 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4:3 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
Local Storage: total: 953.87 GiB used: 27.46 GiB (2.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB1T0HBLR-000L2 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 3L1QEXF7 temp: 44.9 C scheme: GPT
ID-1: / raw-size: 660.9 GiB size: 660.9 GiB (100.00%) used: 27.44 GiB (4.2%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.6 MiB (26.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 660.9 GiB size: 660.9 GiB (100.00%)
used: 27.44 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 660.9 GiB size: 660.9 GiB (100.00%)
used: 27.44 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 660.9 GiB size: 660.9 GiB (100.00%)
used: 27.44 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 57.9 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.47 GiB used: 2.67 GiB (17.3%)
Processes: 360 Power: uptime: 7m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.15 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1992 libs: 551 tools: octopi,pamac,paru
Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish
v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-30
Last full system update: 2024-05-15
Is partially upgraded:   No
Relevant software:       snapper(custom) NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Any suggestions on how to fix this please?

Can't write to /boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen: Directory /boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen does not exist or is not accessible.

Yes because while what the Message said it isnt exist.

All what you do on your own Risk!!!
Work Steps

1.Open Dolphin
2.Right Click bellow the Harddrive choose NEW ENTRY a new window pop up then labeling EFI and bellow adress /boot/ and click OK.
3.Now a new blue Folder will appear with your Label EFI open it and now you see another efi Folder and go into it. Right Click again Administrator Actions → Open in File Manager.
4. Create a New Folder with your Device ID →
and open it again.
5. Create a new Folder again an name it as your Kernel
5.In Dolphin Right Click on your created EFI Folder and Remove from storage locations.
6. Open you Terminal and type “sudo dracut --force” .
7. Now it will work hopefully!

I dont have a Nvidia Card installed but i also have a issue when i want send my Computer to Sleep it is going power off and start back to Login Screen. But im fine i Shutdown completely if im finish and dont care about =)

Might want to try this as its a known nvidia issue.


That command isn’t going to work unless you add more specific arguments to it. There is a custom dracut wrapper that takes care of all of this for you though:

sudo dracut-rebuild

i tested my steps and sudo dracut --force worked here without problems . I got the init file written but i dont need it and delete all the stuff in the end =) but good to know your rebuild =)

The steps you described are not going to work because it is going to add the initramfs image in the wrong directory and give it the wrong name. You would not be able to boot your system with an initramfs which was generated according to those instructions.


yes that can be possible that the rebuild do the trick for boot it up. I checked the writing is correct in the directory. But the booting i dont know because no Nvidia card .

dracut[I]: *** Creating image file '/boot/efi/bb7df5a4d3b4431485947b0cc931e8e8/6.8.9-zen1-2-zen/initrd' ***
dracut[I]: *** Creating initramfs image file '/boot/efi/bb7df5a4d3b4431485947b0cc931e8e8/6.8.9-zen1-2-zen/initrd' done ***

Good to know it=) always learning new stuff. Good Forum here =)

The problem here is this is literally the name of the file:

Even if that was a good image, your bootloader is never going to find that. You would have to configure a custom boot entry to use that image.

With a default Grub setup, the kernels and images should be together in /boot with kernels named vmlinuz-[name of kernel] and images named initramfs-[name of kernel].img, like this:

❯ eza -f1 /boot

With dracut, you can specify where the image should go, what it should be named, and so on but you have to build those options into the command when you run it. The dracut-rebuild script takes care of all that for you, and also does a bunch of other stuff too so it’s pretty handy.

Glad to hear it! :smiley:


yes thats a better way. i did the steps again and it say CPIO Archiv File.

Yeah im wondering how this work on the reddit post but your way makes more sense to me =)

 Would fix the graphic glitch issue but would not bring back the graphic driver itself, until reboot..The issue was that the proprietary drivers on nvidia don't save the vram before suspend. Had similar issues with manjaro and could fix it through this blog post: After a whole day of figuring out how to do it on EOS here is the fix: run following three commands in your terminal:

sudo systemctl enable nvidia-suspend.service

sudo systemctl enable nvidia-hibernate.service

sudo systemctl enable nvidia-resume.service

then: cd /lib/modeprobe.d

sudo nano systemd.conf

Add following line at the end of the file:

options nvidia NVreg_PreserveVideoMemoryAllocations=1

CTRL-X and save file out.

Then run:

sudo dracut --force

reboot for good measure. Voila your PC with EOS can now go to sleep and wake up properly without crashing graphic drives.. Tested with KDE-Plasma with Wayland and 2080ti. Should also work for Xorg X11 (with manjaro I had X11). 

EOS not Garuda but both Arch based Distros.

Thanks guys to sum up:

I tried the solution Duke187 provided with creating EFI directory so that the ‘sudo dracut --force’ would work.

I got this output:

dracut[I]: Executing: /usr/bin/dracut --force
dracut[I]: memstrack is not available
dracut[I]: If you need to use rd.memdebug>=4, please install memstrack and procps-ng
dracut[I]: memstrack is not available
dracut[I]: If you need to use rd.memdebug>=4, please install memstrack and procps-ng
dracut[I]: *** Including module: systemd ***
dracut[I]: *** Including module: systemd-initrd ***
dracut[I]: *** Including module: i18n ***
dracut[I]: *** Including module: btrfs ***
dracut[I]: *** Including module: kernel-modules ***
dracut[I]: *** Including module: kernel-modules-extra ***
dracut[I]: *** Including module: btrfs-snapshot-overlay ***
dracut[I]: *** Including module: rootfs-block ***
dracut[I]: *** Including module: terminfo ***
dracut[I]: *** Including module: udev-rules ***
dracut[I]: *** Including module: dracut-systemd ***
dracut[I]: *** Including module: usrmount ***
dracut[I]: *** Including module: base ***
dracut[I]: *** Including module: fs-lib ***
dracut[I]: *** Including module: shutdown ***
dracut[I]: *** Including modules done ***
dracut[I]: *** Installing kernel module dependencies ***
dracut[I]: *** Installing kernel module dependencies done ***
dracut[I]: *** Resolving executable dependencies ***
dracut[I]: *** Resolving executable dependencies done ***
dracut[I]: *** Hardlinking files ***
dracut[I]: *** Hardlinking files done ***
dracut[I]: *** Generating early-microcode cpio image ***
dracut[I]: *** Constructing AuthenticAMD.bin ***
dracut[I]: *** Store current command line parameters ***
dracut[I]: *** Stripping files ***
dracut[I]: *** Stripping files done ***
dracut[I]: *** Creating image file '/boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen/initrd' ***
cp: error writing '/boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen/initrd': No space left on device
dracut[F]: Creation of /boot/efi/6dfdc55b60b34ddea226e7822d2ec527/6.8.9-zen1-2-zen/initrd failed

After that the sleep issue was still persisted.

Then I tried to do as BluishHumility suggested

sudo dracut-rebuild

I rebooted and tried to put laptop into sleep 2 times and so far it recovered without issue.

1 Like

We always mark here the solution and not the implementation. :slight_smile:


ah sorry, thanks for fixing that :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.