Since yesterday mpv stutters in fullscreen with

Since yesterday mpv stutters in fullscreen with

kwin_wayland_drm: Presentation failed! Invalid argument

Rolling back kwin to r96 fixes it. Anybody else seeing this issue (Intel Arc)?

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


Feel free to delete the thread. I’m not looking for support. It was just an informal question for another datapoint before potentially filing a formal bug report upstream. I thought the KDE 6 testing thread was the right place for that.

strange, I just tested it and it worked fine.

Tested with mpv on a 8K video, smooth and didn’t saw that error line.

Can you try latest version and see if its OK?

Thanks for the testing. Yes, the issue is present with everything latest (esp. kwin 5.92.0.r121).

Also I wasn’t precise: The whole UI (including mpv) stutters along with 1 fps while mpv is play playing in fullscreen mode (screen recording).

  Device-1: Intel DG2 [Arc A750] driver: i915 v: kernel arch: Gen-12.7
    code: Alchemist process: TSMC n6 (7nm) built: 2022+ pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 ports: active: DP-1,DP-2,HDMI-A-2 empty: DP-3,
    DP-4, HDMI-A-1, HDMI-A-3 bus-ID: 03:00.0 chip-ID: 8086:56a1 class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 d-rect: 5394x3338
    display-ID: 0
  Monitor-1: DP-1 pos: top-right res: 1280x1024 size: N/A modes: N/A
  Monitor-2: DP-2 pos: middle-l res: 2194x1234 size: N/A modes: N/A
  Monitor-3: HDMI-A-2 pos: bottom-c res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.4-arch1.2.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Arc A750 Graphics (DG2)
    device-ID: 8086:56a1 memory: 7.75 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.276 layers: 8 device: 0 type: discrete-gpu name: Intel
    Arc A750 Graphics (DG2) driver: mesa intel v: 23.3.4-arch1.2.1
    device-ID: 8086:56a1 surfaces: xcb,xlib,wayland

Can you give me full version name of the kwin package that still works?
I can try to do a “kwin_schlaefer” specific, build with everything latest, but hardcoded to that commit (if it builds).
EDIT: Or you can use this folder PKGBUILD to build a custom version.: just replace #branch=Plasma/6.0 to #commit=tralalalala in the source= line! :

If it works properly, than filing a bug report on kde/kwin would be the way to go.


Thanks for the instructions, that was very helpful.

Going back in the Plasma/6.0 branch the commit 2d085935 is the first breaking it.

I shot a report over at bugs.kde.

Currently I’m fine pinning the version before the offending commit. Thanks again. :+1:

1 Like

And already fixed! great stuff!

1 Like

Fix is merged. :clap:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.