Severe install issues

Hello!

So i am currently running Manjaro, but i feel the itch to move towards pure arch, but don't want literally pure arch. So i came across Garuda and i'm interested in it.

Now i have extreme installation issues. Let me elaborate.

I tried 4 different USB-Sticks, 3 different USB-Ports. I have disabled secure boot, i did check the SHA256 checksum of my download, i use balena etcher, even tried 2 different versions of that (AppImage and regular package).

When i first tried to boot garuda it was stuck on the MHWD driver installation. It said be patient. But after 2,5h i wasn't patient anymore. I tried to reboot that process. Now whenever i try it, no matter what. It will spit out the error that it couldn't create the initramfs directory, starts to start up all the different services, then manages to get up to 25 seconds on the MHWD installation and then goes directly into kernel panic for a fraction of a second without giving me time to see what happens there and just shuts down.

I need some advice here...

CPU: Ryzen 5 2600X
GPU: NVidia RTX3070
Mainboard: ASUS Rog B450-F
RAM: 2x8 GB G-SKILL RIPJAWS 3200 CLI

Hi there, welcome!
Have you tried also booting with the open source drivers option?
In addition to that, you may also give a chance to Ventoy in place of etcher.

2 Likes

I haven't tried to boot with open source- but i'll try.

I had some bad experiences with ventoy in the past so i completely erased it from my memory :smiley:

But if open-source drivers fail me i might try that...

Alright, so ventoy and open-source didn't change anything.

I will try to use the regular dragonized edition now. I tried all of that with the gaming edition.

Btw. due to some 480fps slow motion magic on my phone, i was able to snatch a picture of the kernel panic screen.
https://i.imgur.com/eNSVXF2.jpg (can't upload pictures yet)

After trying the regular dragonized version via ventoy i got this error:

No kernel panic obvs. but it didn't start any service, it immediately went to this.

Check for a BIOS/UEFI update, then try a different installer image that has the LTS kernel (I believe both Xfce and KDE Lite have).

1 Like

I'm already on the newest BIOS version for my board.

I now remember that i had kernel panic issues when i tried to install the ZEN kernel on my manjaro setup...

maybe something on my system is inherently incompatible with the zen kernel...

EDIT: found out that i'm NOT on the newest bios firmware...i will update that.
But before i do that, is it possible my current system simply is incompatible with the ZEN kernel?

1 Like

Fastboot too?

1 Like

yup, fastboot aswell.

However i had some issues with disabling secure boot on my mainboard. It was greyed out.

I found a post where they had to delete the saved keys inside that to disable it.

I deleted the keys but now for "secureboot status" it says "setup" instead of disabled.

To disable secure boot using a live USB you could give a look at this thread

In addition to that, have you tried also to boot setting the BIOS in CSM mode?
See e g. this arch thread
https://bbs.archlinux.org/viewtopic.php?id=241131

1 Like

Alright - So i haven't tried what you just posted, because luckily i didn't have to!

Updating the BIOS Firmware did the trick!

Now i have another problem though :smiley: Live USB and install worked perfectly fine! But when i reboot after install and try to login, it simply freezes there....nothing happens.

But i'm too tired for that for today...i'll take a look at it tomorrow.

But thanks already!

1 Like

Yes, but updating firmware is generally a good idea if things don't work for no apparent reason.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.