Setup for my Canon Pixma MG3650

I am new to this build and need some assistance setting up my printer.

I have it plugged in via usb and it is not recognizing the driver automatically. I have downloaded the driver from the canon website but am so lost trying to install the package.

can someone walk me through the process by chance?

Welcome to the forum
can you provide your


as per the forum template
It will help us to help you :smiley:


In terminal

paru canon-pixma-mg3000-complete

q + Enter + y + Enter

Only as last way, first check the Chaotic-AUR, AUR.


it is asking which package to install
1 aur/canon-pixma-mg3000-complete 5.40-1 [+0 ~0.00]
Complete stand alone driver set (printing and scanning) for Canon Pixma MG3000 series
:: Packages to install (eg: 1 2 3, 1-3):


1 Like

Do i type 1? i am lost ahhh

Yes or enter.

Kernel: 6.5.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d4c0dcbf-2998-4eaf-998e-6368eac8d636 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X515EAU_R565EA
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: X515EAU v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: X515EAU.302 date: 08/13/2021
ID-1: BAT0 charge: 31.1 Wh (100.0%) condition: 31.1/37.1 Wh (83.9%)
volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 176
Info: model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xAC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 2.5 MiB desc: 2x1.2 MiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1050 high: 1143 min/max: 400/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 1047 2: 1124 3: 889
4: 1143 bogomips: 23961
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:9a78 class-ID: 0300
Device-2: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 13d3:5a11
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0946 built: 2020 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel UHD Graphics
(TGL GT2) direct-render: Yes
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
API: ALSA v: k6.5.3-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 3000
bus-ID: 0000:02:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:6 chip-ID: 13d3:3557
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Local Storage: total: 119.24 GiB used: 9.65 GiB (8.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Foresee model: P900F128GH
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
lanes: 2 tech: SSD serial: <filter> fw-rev: V2.7.11H temp: 38.9 C
scheme: GPT
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 9.65 GiB (8.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 9.65 GiB (8.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 9.65 GiB (8.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 9.65 GiB (8.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.46 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (rpm): cpu: 2400
Processes: 204 Uptime: 3h 17m wakeups: 2798 Memory: total: 8 GiB note: est.
available: 7.46 GiB used: 2.96 GiB (39.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1243 libs: 337 tools: octopi,paru pm: rpm pkgs: 0
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-09-19
Last full system update: 2023-09-21 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:
1 Like
paru canon-pixma-mg3000-complete

it gave me this response but it is still not showing the printer. when i go to printers under settings it says printer service unavailable / bad file descriptor

paru canon-pixma-mg3000-complete

it gave me this response but it is still not showing the printer. when i go to printers under settings it says printer service unavailable / bad file descriptor

Repo (2) libpng12-1.2.59-2  gtk2-2.24.33-3
Aur (2) deb2targz-0.1-7  canon-pixma-mg3000-complete-5.40-1

:: Proceed to review? [Y/n]: y

:: Downloading PKGBUILDs...
PKGBUILDs up to date
# Maintainer: Joeran "chepaz" <mx-bounce at gmx dot de>
# Contributor: Michael "mbostwick" <mbostwick89 at gmail dot com>
# Contributor: Vasil Yonkov <bustervill at gmail dot com>

pkgdesc="convert a Debian Linux .deb file to a .tar.gz"
source=('' 'deb2targz-any-data.patch')


build() {
patch --follow-symlinks -i $srcdir/deb2targz-any-data.patch $srcdir/deb2targz

package() {
install -Dm755 deb2targz  $pkgdir/usr/bin/deb2targz

# vim:set ts=2 sw=2 et:


q + Enter + y + Enter

Press Q to exit the PKGBUILD

Sorry, I don’t follow what you’re doing etc…
Have you tried a reboot?
Do you need to start a service with systemctl?
Have you searched for the problem on the internet?

Post as text between three ~ in first and last line, output from

1 Like

@DarkStar89 , this is a requirement. Please adhere.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.