Setup-Assistant & Pacman-Su failure

Hello, I am brand new to Garuda. The install worked fine on my VMware but when I installed in as my OS in my Desktop the Setup-Assistant at the very end will say "Do you want to delete" and then just close; while on my VM it would open a Konsole and complete. If i run a
sudo pacman -Sy
everything says it's good, but when I run
sudo pacman -Su
after installing I get this error
otal Installed Size: 4201.57 MiB
Net Upgrade Size: 59.51 MiB

:: Proceed with installation? [Y/n] Y
Y(120/413) checking keys in keyring [----------c o o o o o o o o ] 29
(413/413) checking keys in keyring [------------------------------------] 100%
downloading required keys...
:: Import PGP key A85E811EB4CA2E08, "Caleb Maclennan [email protected]"? [Y/n] Y
(413/413) checking package integrity [------------------------------------] 100%
error: spdlog: signature from "Brett Cornwall [email protected]" is unknown trust
:: File /var/cache/pacman/pkg/spdlog-1.9.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PG
P signature)).
Do you want to delete it? [Y/n]

I have tried completely wiping the partition and reinstalling and some other fixes i found on the web that included
sudo pacman -S appmenu-gtk-module
to no avail

or just


in terminal/konsole IIRC.


that happens sometimes, it does not have to be the fault of your os, pc or even your network, try sudo pacman -Scc to clear the cache and then try to update it again with sudo pacman -Syu also if you're brand new i really recommend taking a look into timeshift (backup program) which is a really really useful program which saved me lots of time

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.