Setup assistant not working

Hey there.

I'm trying to move everything to linux now that I got a new GPU and Garuda seemed awesome for me, cause i'm kinda of a noob and it would help me install things I had difficult doing in manjaro.

To my dismay, the setup assistant seems to not be working. It starts correctly, but in the end asks if i want to remove the setup assistant and closes itself. I ran it through terminal and the only thing that I got was:

Gtk-Message: 14:00:10.123: Failed to load module "appmenu-gtk-module"

Kept going, checked the apps listed bellow, chose the dependencies and then nothing happened. I'm installing some of the desired apps now through Garuda Gamer, and it seems to be working tho. Still, think it would be cool to solve the problem.

Ah, I did update and reboot a few times

"App" list:
Asian fonts suport
fctix5-m17n
fctix5-mozc
Onlyoffice
Firefox
Brave
Thunderbird
Discord
Zoom
Skype
MS Teams
Qbittorrent
Olivia
Audacity
Musescore
Kdenlive
Openshot
VLC
Gimp
Inkscape
Hypnotix
Handbrake
Stremio
Virtualbox
Guiscrcpy
Droidcam

Tried no optional dependencies and all optional as well

inxi -Faz:

inxi -Faz

System:    Kernel: 5.14.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d6b9c95b-235d-4534-a87b-43851463c72b  
rw [email protected] splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 quiet
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: ASRock model: H310CM-HG4 serial: <filter> UEFI: American Megatrends  
v: P4.10 date: 04/09/2019  
Battery:   ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 3.8 min: N/A  
model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A serial: <filter>  
status: Discharging  
CPU:       Info: 6-Core model: Intel Core i5-9400F bits: 64 type: MCP arch: Kaby Lake note: check  
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 9 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 34798  
Speed: 3960 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3960 2: 4081 3: 4002 4: 4079  
5: 4002 6: 3998  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled  
Type: mds mitigation: Clear CPU buffers; SMT disabled  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA vendor: ZOTAC driver: nvidia v: 470.74 alternate: nouveau,nvidia_drm  
bus-ID: 01:00.0 chip-ID: 10de:2488 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0  
screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 93 s-size: 524x292mm (20.6x11.5") s-diag: 600mm (23.6")  
Monitor-1: DP-0 res: 1920x1080 dpi: 82 size: 597x336mm (23.5x13.2") diag: 685mm (27")  
OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes  
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel  
bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403  
Device-2: NVIDIA GA104 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel  
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403  
Device-3: Kingston HyperX Cloud Alpha S type: USB driver: hid-generic,snd-usb-audio,usbhid  
bus-ID: 1-10:4 chip-ID: 0951:16ed class-ID: 0300 serial: <filter>  
Sound Server-1: ALSA v: k5.14.6-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.35 running: yes  
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k v: kernel port: e000  
bus-ID: 02:00.0 chip-ID: 168c:0032 class-ID: 0280  
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169
v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 13.01 GiB (1.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 032 scheme: GPT
Partition: ID-1: / raw-size: 442.6 GiB size: 442.6 GiB (100.00%) used: 12.94 GiB (2.9%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-2: /boot/efi raw-size: 650 MiB size: 646 MiB (99.38%) used: 77.3 MiB (12.0%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 442.6 GiB size: 442.6 GiB (100.00%) used: 12.94 GiB (2.9%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-4: /var/log raw-size: 442.6 GiB size: 442.6 GiB (100.00%) used: 12.94 GiB (2.9%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
ID-5: /var/tmp raw-size: 442.6 GiB size: 442.6 GiB (100.00%) used: 12.94 GiB (2.9%) fs: btrfs
dev: /dev/sda6 maj-min: 8:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:      Processes: 242 Uptime: 38m wakeups: 2 Memory: 15.56 GiB used: 3.59 GiB (23.1%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1138 lib: 278 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Yeah I had the same issue. Just `sudo pacman -S appmenu-gtk-module' and run the setup-assistant again. It should work fine once that is installed. I think this package might have been missed as a base package in the last ISO.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.