Setting up mouse acceleration in KDE Plasma 6 on Wayland

Hello, I am using Garuda Linux KDE Dr460nized (KDE Plasma 6 on Wayland).
I ran into a problem that I don’t know how to adjust the acceleration of the mouse.

I use the Razer DeathAdder V3 Pro mouse with the Razer HyperPolling Wireless Dongle adapter. The RazerGenie program sees the adapter, at least I can adjust the DPI through it.

Since I sometimes use Windows, I also have a desire to configure the mouse the same way in both places. Currently I’m facing a problem that in the KDE (System Options - Mouse) I can change two parameters: cursor speed (changes from -1 to 1) and cursor acceleration (i can choose either “not use” or “normal”). The same parameters are saved in the file


What am I missing? For the same DPI that I use in Windows, with the minimum mouse sensitivity setting of -1, the pointer moves too quickly. I have to change the mouse DPI every time i boot Linux after Windows. It would be great to know some way to slow down the cursor speed further.
But the main problem is that the acceleration is too weak, I would like to be able to somehow adjust it to increase it.
Ideally, I would like this setting to be available only for this mouse.

What have I tried.

I don’t understand what the mouse works through now, I thought it was using libinput.
I tried setting variables


When I installed them in
udevadm info /dev/input/event9
it is clear that they are there. When executing the command
sudo libinput debug-gui --device=/dev/input/event9 &
there is an effect, in the test window the acceleration changes. But in KDE Plasma itself this has no effect.

I tried installing the custom LEETMOUSE driver from

There is an effect on my second mouse, but it does not work at all with the Razer HyperPolling Wireless Dongle.

Is there any way to more deeply customize cursor speed and mouse acceleration in KDE Plasma 6 on Wayland?

garuda-inxi System: Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1 clocksource: tsc avail: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=033bf1ab-0056-4a0a-9287-d1b6cf33cb90 rw rootflags=subvol=@ quiet resume=UUID=d73ce4a2-e013-41a0-a7e9-eafe6a091db4 loglevel=3 ibt=off Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux Machine: Type: Desktop System: ASUS product: N/A v: N/A serial: Mobo: ASUSTeK model: ROG STRIX Z690-F GAMING WIFI v: Rev 1.xx serial: part-nu: SKU uuid: UEFI: American Megatrends v: 2204 date: 11/30/2022 CPU: Info: model: 13th Gen Intel Core i7-13700K bits: 64 type: MST AMCP arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+ process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1 microcode: 0x123 Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB L2: 24 MiB desc: 8x2 MiB, 2x4 MiB L3: 30 MiB desc: 1x30 MiB Speed (MHz): avg: 862 high: 1100 min/max: 800/5300:5400:4200 scaling: driver: intel_pstate governor: powersave cores: 1: 1100 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 1100 10: 1100 11: 1100 12: 800 13: 1100 14: 800 15: 800 16: 800 17: 800 18: 800 19: 800 20: 800 21: 800 22: 800 23: 800 24: 800 bogomips: 164044 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx Vulnerabilities: Graphics: Device-1: NVIDIA GA102 [GeForce RTX 3080 Lite Hash Rate] vendor: Palit Microsystems driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none off: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2216 class-ID: 0300 Display: wayland server: v: with: Xwayland v: 23.2.7 compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia display-ID: 0 Monitor-1: DP-3 res: 1920x1200 size: N/A modes: N/A API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2 drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink inactive: device-1 API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2 memory: 9.77 GiB display-ID: :1.0 API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 3080 driver: nvidia v: 550.78 device-ID: 10de:2216 surfaces: xcb,xlib,wayland device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland Audio: Device-1: Intel Alder Lake-S HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403 Device-2: NVIDIA GA102 High Definition Audio vendor: Palit Microsystems driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403 Device-3: ASUSTek USB Audio driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:2 chip-ID: 0b05:1996 class-ID: 0300 API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api with: aoss type: oss-emulator tools: N/A Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl Server-2: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl Network: Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280 IF: wlo1 state: down mac: Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3 class-ID: 0200 IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant Bluetooth: Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:10 chip-ID: 8087:0033 class-ID: e001 Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: no address: bt-v: 5.3 lmp-v: 12 status: discoverable: no pairing: no RAID: Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel driver: vmd v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:a77f rev: class-ID: 0104 Drives: Local Storage: total: 24.11 TiB used: 8.07 TiB (33.5%) SMART Message: Unable to run smartctl. Root privileges required. ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Kingston model: SFYRD2000G size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: fw-rev: EIFK31.6 temp: 33.9 C scheme: GPT ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Seagate model: XPG GAMMIX S70 BLADE size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: fw-rev: 3.2.F.66 temp: 44.9 C scheme: GPT ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD60EFRX-68L0BN1 size: 5.46 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5700 serial: fw-rev: 0A82 scheme: GPT ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MG09ACA18TE size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: fw-rev: 4301 scheme: GPT Partition: ID-1: / raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 45.84 GiB (31.3%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:3 ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 588 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1 ID-3: /home raw-size: 297.74 GiB size: 297.74 GiB (100.00%) used: 71.5 GiB (24.0%) fs: btrfs dev: /dev/nvme1n1p4 maj-min: 259:4 ID-4: /var/log raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 45.84 GiB (31.3%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:3 ID-5: /var/tmp raw-size: 146.49 GiB size: 146.49 GiB (100.00%) used: 45.84 GiB (31.3%) fs: btrfs dev: /dev/nvme1n1p3 maj-min: 259:3 Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no ID-1: swap-1 type: zram size: 31.08 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0 ID-2: swap-2 type: partition size: 32.23 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme1n1p2 maj-min: 259:2 Sensors: System Temperatures: cpu: 34.0 C mobo: N/A Fan Speeds (rpm): N/A Info: Memory: total: 32 GiB note: est. available: 31.08 GiB used: 6.59 GiB (21.2%) Processes: 520 Power: uptime: 1h 46m states: freeze,mem,disk suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.39 GiB services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical tool: systemctl Packages: pm: pacman pkgs: 2646 libs: 642 tools: octopi,pacseek,paru pm: flatpak pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34 Garuda (2.6.26-1): System install date: 2024-02-26 Last full system update: 2024-05-21 Is partially upgraded: No Relevant software: snapper NetworkManager dracut nvidia-dkms Windows dual boot: Probably (Run as root to verify) Failed units:

From garuda gamer try piper

Isn’t piper an application for setting up the mouse itself as a device? Thoseб in my case, why do I need a piper if a similar RazerGenie utility works?
My problem is not in setting up the mouse, but in setting the speed and sensitivity of the mouse in KDE Plasma.

It will at least let you tweak dpi an it should retain it over reboots but but if you have something else use that.

Try mouse acceleration in kde settings ?

Yes, as I wrote, I can change the sensitivity of the Razer DeathAdder V3 Pro mouse through the RazerGenie application. The problem is that this does not change the acceleration, so the experience of using a mouse in Windows and Linux is still very different.
And switching DPI every time is simply inconvenient.

Yes, that’s exactly what I wrote about. There is no fine-tuning of mouse acceleration. It can only be turned on or off.

Thank you, I tried it (and described what I tried in the first message).
When adjusting through System Settings, i cannot adjust the cursor acceleration parameter, only its sensitivity. Acceleration can only be turned on or off.
I need to make the acceleration more, the standard value is too small.
And I would like to slow down the cursor speed more than what KDE gives, I don’t have enough range of adjustments (i can change the value in the range from -1 to 1, with the same DPI of the mouse that is installed in my Windows the cursor in Linux moves too fast).

Its the stuff from Wayland it handle it others not like Xorg or each DE. Its like my Gaming keyboard it work on Xorg to put the light on with xset led 3 but under Wayland didint work.

maybe this links help you =)


hope you get it figured out, my mouse is fine =)

Thanks for the links. Yes, I saw them and they didn’t help me.
If we talk about the first link, as I wrote in the first message, I tried to configure mouse acceleration via libinput, in the testing application the settings change, in KDE they do not. The rest is written there either about Xorg or about Gnome.
According to the second link, they configure everything in Xorg via xinput or again write about libinput.
The third link is about libinput.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.