Setting up Hp Laser-jet Professional p1102w

System:
  Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c880b797-5f3c-4d1d-bda8-80ce11228d59 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=425e77c1-16a6-4525-99aa-76416df146ff loglevel=3
    amdgpu.ppfeaturemask=0xffffffff
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AB350-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AB350-Gaming 3-CF serial: <superuser required>
    UEFI: American Megatrends LLC. v: F52e date: 12/14/2021
Battery:
  Device-1: sony_controller_battery_06:ed:69:89:63:25 model: N/A serial: N/A
    charge: N/A status: full
CPU:
  Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
    built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
    microcode: 0x8001138
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3186 high: 3417 min/max: 1550/3600 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3122 2: 3156
    3: 3417 4: 3068 5: 3203 6: 3216 7: 3086 8: 3350 9: 3079 10: 3173 11: 3317
    12: 3047 bogomips: 86238
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN 4 process: GF 14nm
    built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: DP-1,DVI-D-1,HDMI-A-1 empty: DP-2,DP-3 bus-ID: 07:00.0
    chip-ID: 1002:67df class-ID: 0300
  Device-2: ARC Camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-1:2 chip-ID: 05a3:9331 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5760x1080 s-dpi: 96 s-size: 1524x285mm (60.00x11.22")
    s-diag: 1550mm (61.04")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: primary,left model: Acer S231HL
    serial: <filter> built: 2013 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 510x287mm (20.08x11.3") diag: 585mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,center
    model: ViewSonic VX2458-mhd serial: <filter> built: 2019 res: 1920x1080
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-3: HDMI-A-1 mapped: HDMI-A-0 pos: right model: AOC 2370
    serial: <filter> built: 2014 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 590 Series (polaris10 LLVM 13.0.1 DRM
    3.46 5.18.3-zen1-1-zen)
    v: 4.6 Mesa 22.1.1 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 1-1:2
    chip-ID: 05a3:9331 pcie: class-ID: 0102 gen: 3 serial: <filter>
    speed: 8 GT/s lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: ARC Camera type: USB driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
    bus-ID: 1-7:72 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
  IF: wlp2s0f0u7 state: up mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-8:7 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 14.71 GiB (0.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS250G2X0C-00L350 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 101110WD temp: 52.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SBK2 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023
  ID-4: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023
Partition:
  ID-1: / raw-size: 200.38 GiB size: 200.38 GiB (100.00%)
    used: 14.18 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-3: /home raw-size: 465.76 GiB size: 931.52 GiB (200.00%)
    used: 534.7 MiB (0.1%) fs: btrfs dev: /dev/sdb maj-min: 8:16
  ID-4: /var/log raw-size: 200.38 GiB size: 200.38 GiB (100.00%)
    used: 14.18 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-5: /var/tmp raw-size: 200.38 GiB size: 200.38 GiB (100.00%)
    used: 14.18 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 256 KiB (0.0%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
Sensors:
  System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 648
Info:
  Processes: 396 Uptime: 1h 4m wakeups: 1 Memory: 31.27 GiB
  used: 3.83 GiB (12.3%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1769
  lib: 510 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.17
e[1;34mGaruda (2.6.3-2):e[0m
e[1;34m  System install date:e[0m     2022-07-14
e[1;34m  Last full system update:e[0m 2022-07-14
e[1;34m  Is partially upgraded:  e[0m Yes
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m

This is my terminal output trying to set up the printer with hp-setup -i
It mysteriously fails.

hp-setup -i

HP Linux Imaging and Printing System (ver. 3.22.6)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

Num       Connection  Description
Type
--------  ----------  ----------------------------------------------------------
0*        usb         Universal Serial Bus (USB)
1         net         Network/Ethernet/Wireless (direct connection or JetDirect)
2         par         Parallel Port (LPT:)

Enter number 0...2 for connection type (q=quit, enter=usb*) ?

Using connection type: usb


Setting up device: hp:/usb/HP_LaserJet_Professional_P_1102w?serial=000000000W481VWXPR1a



---------------------
| PRINT QUEUE SETUP |
---------------------


Please enter a name for this print queue (m=use model name:'HP_LaserJet_Professional_P_1102w'*, q=quit) ?m
Using queue name: HP_LaserJet_Professional_P_1102w
Locating PPD file... Please wait.
error: No PPD found for model laserjet_professional_p_1102w using old algorithm.
error: Unable to find an appropriate PPD file.

Would you like to specify the path to the correct PPD file to use (y=yes, n=no*, q=quit) ? y

Please enter the full filesystem path to the PPD file to use (q=quit) :"/usr/share/ppd/HP/hp-laserjet_professional_p_1102w.ppd.gz"
error: File not found or not an appropriate (PPD) file.

Please enter the full filesystem path to the PPD file to use (q=quit) :/usr/share/ppd/HP/hp-laserjet_professional_p_1102w.ppd.gz
Traceback (most recent call last):
File "/usr/bin/hp-setup", line 560, in <module>
desc = nickname_pat.search(nickname).group(1)
TypeError: cannot use a string pattern on a bytes-like object

Try adding it with cups.

http://localhost:631

Doesn't connect to the localhost this way. It says ERR_CONNECTION_REFUSED

Do you have it enabled? sudo systemctl enable --now cups.socket

4 Likes

TY yes, I enabled cups and it was ez TY all <3 much luv

I enabled the service, does that do the socket?

2 Likes

You can do either.

I think if you enable the service it runs all the time and if you enable the socket it activates it when you try to use it.

1 Like

TY that's ok

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.