Set NVIDIA GPU as default with AMD hybrid setup

Hi Friends,

I have a similar issue.
On my AMD Rysen laptop, My CPU also has the Radeon Vega graphics processor built-in; and a separate Gforce GTX1650 chip. During the Garuda install, it capture the Vega graphics settings and set the system using the Vega graphics as the main GPU. I have downloaded the nVidia-470 file from the nVidia Web site, how do I force the system to re-install the graphics drive using the nVidia-470 driver instead ??? Please help......

I suspect you don't want to do that, unless you're saying that you want to use the Nvidia GPU as the default (and only) output?

Otherwise, MHWD has a hybrid driver profile for AMD+Nvidia that will support the iGPU as the default and dGPU for render offload, so that will be worth looking at.

2 Likes

Hello Jonathon,

Thank you for your reply. Yes, i would like to have my system to use the nVidia GTX160 graphics as the default GPU settings. Sorry about that, further investigating my system's graphics thru command, I found out the system DOES have the nVidia driver installed. However, the OpenGL rendering setting is currently set on the Radeon Graphics. I think my original request is meant to re-configure the system to use the nVidia GTX160 graphics as the default, including the OpenGL rendering.
I have already downloaded the nVidia graphics driver (.run file) from teh nVidia web site, how do I reset the graphics settings and re-install the nVidia official driver file into the system?? Please help. Many thanks.

  1. No. Nobody here is going to help you with installing the driver from nvidia's website. This isn't Microsoft Windows.
  2. Why do you want to use the Nvidia GPU as your default? Not even Windows does that. Just use it in hybrid mode.
    Here's how you use prime-run: PRIME - ArchWiki
    If you INSIST on setting it as the default, you can do so from optimus-manager.
3 Likes

In addition to the above, does your BIOS allow you to set the primary GPU? That would be the best approach if you want to use only the NVIDIA GPU.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.