Serious printer driver issue - Canon pixma MP240


after latest update command, it could last a few days or more than a week ago, I actually ran into serious printer issues with my Cannon Pixma MP240 multifunctional printer. Any print job only shows up in the print-list, but isn’t processed. Direct hardware scan-print worked, so the printer is fine.

The MP240 was already installed using the AUR canon-pixma-mp240-complete.git driver. Printing text, pdf or other sources without any issue, also scanning worked for years with Garuda Cinnamon.

Checked the wires (3xusb-wire in a row), checked the driver, even tried to setup a new printer on a second computer with the above mentioned driver. Unfortunately the driver seems to be outdated, as installation ran into an issue regarding missing driver file MP240_debian_driver.tar from bound-in Canon website. Checking the website brings note about ‘Unfortunately your device is no longer supported under the selected operating system.’, so the base of the AUR driver package is broken/deleted.

Checking the MP240 with other distribution, Linux Mint 2.1.2, on USB stick showed a fully working printer (tested) from sratch. Probably their stable version still holds the needed driver, but then it will still get broken with next version I guess.

So, why does a fully working MP240 get broken on Garuda Cinnamon without me replacing or updating my driver? I do not really get how this worked out and I do not have any clue how to fix that. Any help would be appreciated.


Here is the ‘garuda-inxi’ output. If you explain, I surely will provide other informations as needed.

  Kernel: 6.5.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=ba4d191b-711a-44a7-bf2c-90744ec25f0d rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Cinnamon v: 5.8.4 tk: GTK v: 3.24.38 info: plank wm: muffin vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: X570S UD serial: <superuser required>
    UEFI: American Megatrends LLC. v: F4d date: 07/20/2022
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2313 high: 3800 min/max: 2200/4850 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3800 2: 2200
    3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200
    12: 2200 13: 2200 14: 2422 15: 2200 16: 2200 bogomips: 121607
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: ASRock
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,DP-3,HDMI-A-1 bus-ID: 0c:00.0 chip-ID: 1002:73bf
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.83x15.00")
    s-diag: 987mm (38.84")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: AOC U34G3XM serial: <filter>
    built: 2023 res: 3440x1440 dpi: 110 gamma: 1.2
    size: 797x334mm (31.38x13.15") diag: 864mm (34") modes: max: 3440x1440
    min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6800 XT (navi21 LLVM
    16.0.6 DRM 3.54 6.5.7-zen1-1-zen) device-ID: 1002:73bf memory: 15.62 GiB
    unified: no
  API: Vulkan v: 1.3.264 layers: 7 device: 0 type: discrete-gpu name: AMD
    Radeon RX 6800 XT (RADV NAVI21) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:73bf surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK Virtuoso 200
    driver: snd_virtuoso v: kernel bus-ID: 06:04.0 chip-ID: 13f6:8788
    class-ID: 0401
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.5.7-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 6.13 TiB used: 2.07 TiB (33.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBI02102 temp: 50.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DX001-1CM162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC44 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 240GB
    size: 223.58 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 00RL scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EARS-00MVWB0 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s tech: N/A serial: <filter> fw-rev: AB51
    scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Toshiba model: DT01ACA300
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: ABB0 scheme: GPT
  ID-1: / raw-size: 182.79 GiB size: 182.79 GiB (100.00%)
    used: 33.11 GiB (18.1%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
  ID-2: /boot/efi raw-size: 1.25 GiB size: 1.25 GiB (99.80%)
    used: 576 KiB (0.0%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 300 GiB size: 300 GiB (100.00%)
    used: 45.01 GiB (15.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/log raw-size: 182.79 GiB size: 182.79 GiB (100.00%)
    used: 33.11 GiB (18.1%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
  ID-5: /var/tmp raw-size: 182.79 GiB size: 182.79 GiB (100.00%)
    used: 33.11 GiB (18.1%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.24 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 39.53 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb2 maj-min: 8:18
  System Temperatures: cpu: 46.5 C mobo: 34.0 C gpu: amdgpu temp: 48.0 C
    mem: 42.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
  Processes: 471 Uptime: 19m wakeups: 0 Memory: total: 32 GiB
  available: 31.24 GiB used: 5.86 GiB (18.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1944 libs: 556
  tools: octopi,pacaur,pamac,paru,trizen,yay pm: flatpak pkgs: 0 Shell: fish
  v: 3.6.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-07-30
  Last full system update: 2023-10-12
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

The first reason that comes to my mind is that we are a rolling release, while Mint is not, so they are “behind” in releases.
At this point, the first thing I would do is install the linux-lts kernel, in the hope that it is the current (a recent) kernel that is incompatible with that old driver.


Thx for the hint. Good idea, but I’d like to keep the Zen kernel for gaming. If necessary I can print with my USB instead switching kernel every time.

Just a heads-up:

Managed to install the printer over my router with CUPS.
Printing worked, but scanning isn’t supported over LAN.

Checked the printer status and found 2 printer entries.
The old ‘MP240-series’ and the new network-printer.
Then I checked the status and found the ‘MP240-series’ to be inactive.
No one switched that off, so I turned it on again. Switched back to direct USB connection and the printer is working as before.

Cheese…one of the latest Garuda updates has simply switched the printer to inactive. How is that possible?

I’d like to address a note toward Garuda admins to have a look on such avoidable issues.

Nevertheless, the printer is back, scanning is working. Issue solved.

Thx for looking into it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.