Selected boot device disabled in Bios

Good Day

My first experience with Linux 'yippee!' (don't know if its a linux issue though)

I am running an old Acer Veriton M2640G.
I've got windows installed, then I partitioned 40gb and installed Garuda via USB (used the rufus imager)
I had to disable secure boot in bios to get there.

The install runs as per tutorials on YouTube. I then select the restart. But no I find that unlike on the videos, I don't go to select the OS to boot from. I go straight to Windows.

After a restart and f12 - I see the only boot option is the windows boot manager. I then go into advance startup for windows, and let it restart there - I see the Garuda Linux partition and select it (still in windows environment) but when it boots, I get a message that says "Selected boot device disabled in Bios"

So travel to bios, disable fast start up, disable CSM to go to legacy. Now I see that the boot option is no longer 'Windows boot manager' but The whole hard drive (excluding partitions) I select it and get the message to restart and select the correct boot device.

I am out of ideas, please help.

Sincerely
I tried, really
McGill

Do you have AHCI enabled in BIOS?

2 Likes

and
:slight_smile:

1 Like

You have to know if you installed Garuda in Legacy, or UEFI.
If you installed in UEFI, you can't boot in Legacy, for many reasons.
If you installed in UEFI, you need to create a new menu option for Garuda in BIOS.

Read BIOS user manual for available options.

You may boot to the installer and use efibootmgr to check for options.

5 Likes

I did not see that option I the bios, is there perhaps another name for it? What us AHCI. Sorry, I'm super new to these things.

I see,

So if I boot to the installer, I can just open the terminal from there? And then go to efibootmgr from there?

Yes.
Get info from your system so you know what's going on.
Read about UEFI and Grub on UEFI at Archwiki.

2 Likes