Secondary monitor breaks kwin(or something) after update

1. Issue

I have been using dual monitors well for a long time, but after a recent update, I could only see black screen with cursor after logging in. After several updates and tries and reboots, I found everything is fine with single monitor, but once I plug/enable the second screen, the second monitor displays as is. But the window decoration disappears, as shown below.


Then I run kstart kwin-x11, and nothing happened. But if I unplug/disable the second monitor and then run kstart kwin-x11, the window decoration would be back.

And that’s on X11. On Wayland with single monitor, if I close a window, it seems the whole plasma restart. And if with two monitors, it only shows black screen and cursor, and I could press ctrl + alt + t to call Fish. At first I could timeshift to a snapshot which everything was fine, but now I lost the snapshot.

2. Attempts to solve it

  • delete ~/.local/share/kscreen
  • create a new user and log in, still the same
  • reinstall all packages

3. System information

Output of garuda-inxi

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US",
LC_ALL = (unset),
LC_MONETARY = "Default.UTF-8",
LC_MEASUREMENT = "Default.UTF-8",
LC_TIME = "osa_US.UTF-8",
LC_NUMERIC = "Default.UTF-8",
LANG = "zh_HK.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("zh_HK.UTF-8").
System:
Kernel: 6.7.3-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: hpet available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=280d0757-24a8-41c0-92d9-a806db4d0209 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: latte-dock
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81YN v: Lenovo XiaoXinAir-14ARE 2020
serial: <superuser required> Chassis: type: 10 v: Lenovo XiaoXinAir-14ARE
2020 serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0L77769 WIN
serial: <superuser required> UEFI: LENOVO v: DTCN23WW(V1.09)
date: 10/26/2020
Battery:
ID-1: BAT1 charge: 49.0 Wh (100.0%) condition: 49.0/56.5 Wh (86.7%)
volts: 12.9 min: 11.6 model: 0x43 0x65 0x6C 0x78 0x70 0x72 0x74 0x00 0x32
0x30 0x31 0x4C 0x31 0x39 0x43 0x33 0x50 0x46 type: Li-ion serial: <filter>
status: full cycles: 62
CPU:
Info: model: AMD Ryzen 5 4600U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 1398 high: 1400 min/max: 1400/2100 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1396 2: 1400
3: 1400 4: 1400 5: 1400 6: 1400 7: 1397 8: 1400 9: 1397 10: 1397 11: 1400
12: 1400 bogomips: 50306
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Renoir [Radeon RX Vega 6 ] vendor: Lenovo driver: amdgpu
v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 42.0 C
Device-2: Syntek Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:5 chip-ID: 174f:244c
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
s-diag: 581mm (22.86")
Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x683d built: 2019
res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 16.0.6 DRM 3.57 6.7.3-zen1-2-zen) device-ID: 1002:1636
memory: 500 MiB unified: no
API: Vulkan v: 1.3.276 layers: 8 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.3.5-arch1.1
device-ID: 1002:1636 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.3-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:c822
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: ASIX AX88179 Gigabit Ethernet driver: cdc_ncm type: USB rev: 3.2
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.2:3 chip-ID: 0b95:1790
class-ID: 0a00 serial: <filter>
IF: enp5s0f3u1u2c2 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: CloudflareWARP state: unknown speed: 10000 Mbps duplex: full
mac: N/A
Bluetooth:
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4:3 chip-ID: 0bda:c123
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
Drives:
Local Storage: total: 1.4 TiB used: 214.39 GiB (15.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDHBA512TDV
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 3011P4LN temp: 37.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: Samsung
model: MZAL41T0HBLB-00BL1 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: CL2QHXC7 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 340.03 GiB size: 340.03 GiB (100.00%)
used: 214.37 GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 29 MiB (11.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 340.03 GiB size: 340.03 GiB (100.00%)
used: 214.37 GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 340.03 GiB size: 340.03 GiB (100.00%)
used: 214.37 GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 340.03 GiB size: 340.03 GiB (100.00%)
used: 214.37 GiB (63.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15 GiB used: 1.8 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 49.6 C mobo: N/A gpu: amdgpu temp: 42.0 C
Fan Speeds (rpm): N/A
Info:
Processes: 343 Uptime: 2h 4m wakeups: 0 Memory: total: 16 GiB note: est.
available: 15 GiB used: 5.4 GiB (36.0%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 11/12
clang: 16.0.6 Packages: pm: pacman pkgs: 1857 libs: 543 tools: pamac,paru
pm: flatpak pkgs: 0 Shell: fish v: 3.7.0 running-in: konsole inxi: 3.3.31
Garuda (2.6.23-1):
System install date:     2022-12-07
Last full system update: 2024-02-05
Is partially upgraded:   No
Relevant software:       timeshift NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            anbox-container-manager.service systemd-networkd-wait-online.service

Output after restart kwin-x11

Module 'org.kde.kwin.decoration' does not contain a module identifier directive - it cannot be protected from external registrations.
OpenGL vendor string:                   AMD
OpenGL renderer string:                 AMD Radeon Graphics (radeonsi, renoir, LLVM 16.0.6, DRM 3.57, 6.7.3-zen1-2-zen)
OpenGL version string:                  4.6 (Compatibility Profile) Mesa 23.3.5-arch1.1
OpenGL shading language version string: 4.60
Driver:                                 Unknown
GPU class:                              Unknown
OpenGL version:                         4.6
GLSL version:                           4.60
Mesa version:                           23.3.5
X server version:                       1.21.1
Linux kernel version:                   6.7.3
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
ShapeCorners: shaders loaded.

And something just pops up in my terminal:

file:///usr/share/kwin/effects/windowview/qml/main.qml: Writing to "client" broke the binding to the underlying model

kwin_core: XCB error: 152 (BadDamage), sequence: 43188, resource id: 73485912, major code: 143 (DAMAGE), minor code: 3 (Subtract)
kwin_core: XCB error: 152 (BadDamage), sequence: 2929, resource id: 73489416, major code: 143 (DAMAGE), minor code: 3 (Subtract)

Not sure if this is related to your issue…

Sometimes on reboot into KDE Plasma, my primary monitor comes up black with no desktop/wallpaper.

WindowsKey + P offers a quick way to change the monitors layout which fixes the issue.

I’d like to know what the issue behind this is so can avoid this step.

What is this about?

1 Like

I don’t know. What’s wrong?

That’s what I’m asking.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.