Second monitor stops working after the screen locks up [NVIDIA]

Hi all,

This problem is something that has been happening for about 5 to 6 months. A couple of months ago I did a fresh installation of Garuda and it is still the same.
I am on a laptop and I have a second monitor with 3440x1440 resolution, so it is problematic to use nvidia-off-loading, since there are lags and jumps between windows movements or switching between them. So I have installed optimus-manager to switch completely to nvidia.

Everything goes perfect, except when I have to pause, the screen goes into lock and then the second monitor just won't turn on. There are times when the laptop screen also goes completely black. To try to fix this without forcing the shutdown I have tried:

  1. switching to tty2 (control + alt + F2) and back to tty1, but sometimes this doesn't work either.
  2. Disconnecting the hdmi cable, so that it reloads the lock screen. Sometimes combining with going to tty2.

In any of the situations, in case you manage to enter again to the active session, the secondary display is still disconnected, you have to go to the nvidia utility, to the 'X Server Display Configuration' section, and change in "Resolution" from Auto to the correct resolution, in 2 attempts. This makes the monitor active again, although in "Unify Outputs" mode, so you need to go to System Preferences --> Display, to again change the way you want to use the monitor. This makes using the system really annoying, and I'm not sure how to fix it.

Attached is the result of garuda-inxi.

╭─[email protected] in ~ via 📐 v4.2.2 as 🧙 took 3s
╰─λ garuda-inxi -t

System:
Kernel: 6.1.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e8d1681e-e709-4f84-9299-11d7b9a7f289 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: G5 5587 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 03PVDF v: A00 serial: <superuser required> UEFI: Dell
v: 1.21.0 date: 04/15/2022
Battery:
ID-1: BAT0 charge: 3.9 Wh (19.2%) condition: 20.3/56.0 Wh (36.3%)
volts: 15.8 min: 15.2 model: BYD DELL 7FHHV87 type: Li-ion serial: <filter>
status: charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 3758 high: 3902 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 3900 2: 3900 3: 3900
4: 3900 5: 3900 6: 2200 7: 3900 8: 3900 9: 3900 10: 3900 11: 3900 12: 3902
bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell
driver: nvidia v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none off: HDMI-A-4 empty: none bus-ID: 01:00.0
chip-ID: 10de:1c8c class-ID: 0302
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 5360x1440 s-dpi: 110 s-size: 1239x333mm (48.78x13.11")
s-diag: 1283mm (50.51")
Monitor-1: HDMI-A-4 mapped: HDMI-0 note: disabled pos: primary,left
model: TE-7250N built: 2021 res: 3440x1440 hz: 60 dpi: 110 gamma: 1.2
size: 797x334mm (31.38x13.15") diag: 864mm (34") modes: max: 3440x1440
min: 640x480
Monitor-2: eDP-1 mapped: eDP-1-1 pos: right model: LG Display 0x05d0
built: 2018 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
modes: 1920x1080
API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce GTX 1050
Ti/PCIe/SSE2 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 3-1.4:5 chip-ID: 0bda:4937
alternate: snd_soc_skl,snd_sof_pci_intel_cnl class-ID: 0300
bus-ID: 00:1f.3 chip-ID: 8086:a348 serial: <filter> class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0fb9 class-ID: 0403
Device-3: Realtek USB2.0 Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell
driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 3c:00.0 chip-ID: 1969:e0a1 class-ID: 0200
IF: enp60s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 813.29 GiB (43.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 55.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: SDM3 scheme: GPT
Partition:
ID-1: / raw-size: 120 GiB size: 120 GiB (100.00%) used: 71.33 GiB (59.4%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 612 MiB size: 610.8 MiB (99.80%)
used: 52.9 MiB (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 661.51 GiB size: 650.06 GiB (98.27%)
used: 460.68 GiB (70.9%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /opt raw-size: 40.04 GiB size: 40.04 GiB (100.00%)
used: 7.82 GiB (19.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-5: /var/log raw-size: 120 GiB size: 120 GiB (100.00%)
used: 71.33 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-6: /var/tmp raw-size: 120 GiB size: 120 GiB (100.00%)
used: 71.33 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.04 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 30 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p6 maj-min: 259:6
Sensors:
System Temperatures: cpu: 87.0 C pch: 72.0 C mobo: N/A gpu: nvidia
temp: 61 C
Fan Speeds (RPM): N/A
Info:
Processes: 355 Uptime: 14m wakeups: 5 Memory: 31.04 GiB
used: 8.88 GiB (28.6%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: 2703
pm: dpkg pkgs: 0 pm: pacman pkgs: 2693 libs: 539 tools: octopi,pamac,paru
pm: flatpak pkgs: 10 Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.24
Garuda (2.6.13-1):
System install date:     2022-10-22
Last full system update: 2023-01-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Is this similar behavior to this post? After login, monitor still acts funky - #13 by justmere

2 Likes

It seems similar. It seems to me that the problem is associated with kwin, because with this also there are crashes.

Anyway, I tried to install the wayland package, enter there, but it didn't work. Wayland crashes if I do a lot of mouse movements.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.