Second monitor borked shortly after installing

garuda-inxi:

System:
Kernel: 6.0.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3419cad2-d79e-432c-a090-687e8849465f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 amdgpu.ppfeaturemask=0xffffffff
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_wayland dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B550M DS3H v: x.x serial: N/A
UEFI: American Megatrends v: F12 date: 01/18/2021
CPU:
Info: model: AMD Ryzen 5 5600X socket: AM4 bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22 process: TSMC n7
(7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
microcode: 0xA201009
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3700 min/max: 2200/4650 boost: enabled
base/boost: 3700/4650 scaling: driver: acpi-cpufreq governor: performance
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
5: 3700 6: 3700 7: 3700 8: 3700 9: 3700 10: 3700 11: 3700 12: 3700
bogomips: 88636
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 23 [Radeon RX 6650 XT] vendor: Gigabyte driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1
off: HDMI-A-2 empty: DP-1,DP-2 bus-ID: 0c:00.0 chip-ID: 1002:73ef
class-ID: 0300
Display: server: X.Org v: 22.1.4 with: Xwayland v: 22.1.4
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: XWAYLAND1 res: 1920x1080 hz: 144 dpi: 92
size: 530x300mm (20.87x11.81") diag: 609mm (23.98") modes: N/A
OpenGL: renderer: AMD Radeon RX 6650 XT (navi23 LLVM 14.0.6 DRM 3.48
6.0.6-zen1-1-zen) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 1-2:4 pcie: chip-ID: 2972:0047 gen: 4 speed: 16 GT/s class-ID: fe01
lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: FiiO BTR5 type: USB driver: snd-usb-audio
Device-4: Medeli heyday Microphone 01 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:5 chip-ID: 0a67:0002
class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.0.6-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: down mac: <filter>
Device-2: NetGear A6210 type: USB driver: mt76x2u bus-ID: 2-3:2
chip-ID: 0846:9053 class-ID: 0000 serial: <filter>
IF: wlp2s0f0u3 state: up mac: <filter>
Drives:
Local Storage: total: 4.63 TiB used: 134.3 GiB (2.8%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: TeamGroup model: TM8FP6001T
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: VC0S036B
temp: 54.9 C scheme: GPT
SMART: yes health: PASSED on: 6d 18h cycles: 162 read-units: 16,524,150
[8.46 TB] written-units: 14,090,254 [7.21 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD1003FZEX-00MK2A0 family: Black size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: 1A01 temp: 41 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 2y 247d 1h cycles: 2374
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EZAZ-00GGJB0 family: Blue (SMR) size: 1.82 TiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 5400 serial: <filter> rev: 0A80 temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 133d 20h cycles: 264
ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EADS-65M2B1 family: Caviar Green size: 931.51 GiB block-size:
physical: 512 B logical: 512 B sata: 2.6 speed: 3.0 Gb/s type: N/A
serial: <filter> rev: 0A01 temp: 45 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 2y 156d 10h cycles: 5201
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 741.14 GiB size: 741.14 GiB (100.00%) used: 134.26 GiB
(18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 38.9 MiB
(13.0%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 741.14 GiB size: 741.14 GiB (100.00%) used: 134.26
GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-4: /var/log raw-size: 741.14 GiB size: 741.14 GiB (100.00%) used: 134.26
GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-5: /var/tmp raw-size: 741.14 GiB size: 741.14 GiB (100.00%) used: 134.26
GiB (18.1%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.13 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
Sensors:
System Temperatures: cpu: 45.1 C mobo: 36.0 C gpu: amdgpu temp: 58.0 C
mem: 60.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 333 Uptime: 22m wakeups: 0 Memory: 15.56 GiB used: 3.47 GiB
(22.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1841
libs: 514 tools: octopi,paru Shell: garuda-inxi (sudo) default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-11-01
Last full system update: 2022-11-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

i installed garuda on my machine just today. It was working fine for a little bit, but then i left the computer for a few minutes and came back to see that one of my monitors wasn't working. I tried logging out and logging in to an X11 session, no dice. I checked on my windows partition to confirm that my monitor hadn't died or something, but it worked fine. So probably not a hardware issue. I tried unplugging both of my monitors and plugging them back in, trying different display ports on the gpu, nothing. When i go to my display settings it keeps refreshing and saying on output has been removed and added, but it never detects the second monitor.

According to xrandr theres only one monitor connected:

Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
XWAYLAND1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
1920x1080    143.88*+
1440x1080    143.90
1400x1050    143.89
1280x1024    143.92
1280x960     143.86
1152x864     143.92
1024x768     143.87
800x600      143.83
640x480      143.85
320x240      142.05
1680x1050    143.88
1440x900     143.86
1280x800     143.84
720x480      143.85
640x400      143.37
320x200      141.40
1600x900     143.93
1368x768     143.77
1280x720     143.85
1024x576     143.91
864x486      143.63
720x400      143.88
640x350      143.57

having looked through the forums it seems that multiple other users have had a very similar issue occur recently, but no solutions yet.

edit: i forgot to mention, but the second monitor turns on and works on the login manager, but as soon as i log in with either X11 or Wayland it shuts back off

Ok, I feel a little bit silly right now, but I figured out what happened.

somehow, the second monitor got disabled in the settings, and i just had to click the "device" drop down in display settings, click my second monitor, and re-enable it. I still have no idea how the monitor got disabled in the first place since I literally wasn't using the computer when it happened, but it seems fine now. Hopefully.

I was hoping selfishly that this was the same issue I've been experiencing. It's definitely not... Glad you got it solved!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.