Sea of Thieves slow startup, game freezes at sign-in

garuda-inxi output:

  Kernel: 6.8.7-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
    root=UUID=0c56ec49-20ad-4aa0-a88b-55b47e733bc9 rw rootflags=subvol=@
    quiet rd.luks.uuid=d79b9435-2941-4ab1-b7b1-6436232809f7
    resume=/dev/mapper/luks-49c27010-0fe7-452f-b43e-2b305ff69240 loglevel=3
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: ASRock model: 970M Pro3 serial: <superuser required>
    uuid: <superuser required> UEFI-[Legacy]: American Megatrends v: P1.60
    date: 06/17/2016
  Info: model: AMD FX-8350 bits: 64 type: MT MCP arch: Piledriver level: v2
    built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
    microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
    desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 4045 high: 4091 min/max: 1400/4000 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4091 2: 4000
    3: 4090 4: 4000 5: 4000 6: 4091 7: 4091 8: 4000 bogomips: 63880
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro
    450/455/460/555/555X/560/560X] vendor: Tul / PowerColor driver: amdgpu
    v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20
    pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s ports:
    active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67ef
    class-ID: 0300 temp: 43.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 560 Series (radeonsi
    polaris11 LLVM 17.0.6 DRM 3.57 6.8.7-arch1-1) device-ID: 1002:67ef
    memory: 3.91 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 13 device: 0 type: discrete-gpu name: AMD
    Radeon RX 560 Series (RADV POLARIS11) driver: mesa radv v: 24.0.5-arch1.1
    device-ID: 1002:67ef surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  Device-1: AMD SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    vendor: Tul / PowerColor driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 1002:aae0 class-ID: 0403
  API: ALSA v: k6.8.7-arch1-1 status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:3 chip-ID: 2357:0604
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
    status: discoverable: no pairing: no
  Local Storage: total: 931.51 GiB used: 643.58 GiB (69.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: MBR
  ID-1: / raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
    used: 643.58 GiB (69.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
  ID-2: /home raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
    used: 643.58 GiB (69.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
  ID-3: /var/log raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
    used: 643.58 GiB (69.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
  ID-4: /var/tmp raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
    used: 643.58 GiB (69.7%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-49c27010-0fe7-452f-b43e-2b305ff69240
  ID-2: swap-2 type: zram size: 7.73 GiB used: 125.8 MiB (1.6%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
    dev: /dev/zram0
  System Temperatures: cpu: 35.9 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1130
  Memory: total: 8 GiB available: 7.73 GiB used: 2.67 GiB (34.6%)
  Processes: 294 Power: uptime: 1m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 3.08 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 2088 libs: 536 tools: octopi,paru,yay
    pm: flatpak pkgs: 0 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi
    default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2023-11-27
  Last full system update: 2024-04-23
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:

Hello, a week and change ago, I decided to play some Sea of Thieves shortly before the start of Season 12. I had to install the glibc-eac and lib32-glibc-eac packages and delete then reinstall the Proton EasyAntiCheat Runtime folder to get the game to work, but eventually I succeeded.

A few days later when season 12 comes out, I play around a bit in the game and notice some odd visual flashes as I’m playing. In an attempt to remedy this, I try running the game with “PROTON_USE_WINED3D=1 %command%” set for the launch options. After doing this, the game no longer seems to work at all, even after reverting this option.

I have even tried reverting my system to a previous snapshot to fix the problem, but oddly even that hasn’t seemed to work. I have noticed from checking ProtonDB that a lot of people seem to be having issues with the game of late so that also might have something to do with it. Any help or insights would be appreciated, thanks.

are u playing with the current proton 9 version?

beside some new hot features it seems that sea of thieves running better on that version

wasnt able to get sea of thieves work on proton 8 anymore


seems borked for a lot of people atm :confused:

1 Like

Garuda is a “rolling release.”

Please update it prior to making help requests.

1 Like

Sorry, I’m pretty sure that I had updated since then. It’s just that I had attempted to fix the issue through a snapper rollback prior to making the post. I’ve just done a system update and the game did gave me this error dialog when attempting to do a file integrity check.
Additionally, I got the same error as previous when saying to the file integrity check in addition to this new one:

After the most recent update, the game seems to be closer to working properly. I can now start up the game and start a session, although the game still crashes a few seconds after the session begins and gives the same error as before.

That Wine error has to do with an issue with recent kernel versions. In your BIOS, enable Resizable BAR and any 4g related options (or wait for a fix that should be out soon that doesn’t require those settings to be on as a work-around)


Shortly after making my last post I actually discovered that the issue goes away if I close all my other applications before starting the game. The issue may have been due to the game not having enough memory. I’m pretty sure that my system is too old to support resizable bar and I’m not sure if it has any option for “above 4g decoding”. At any rate, the issue seems to be solved for me now. Sorry for not updating sooner.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.