SDDM login page error

Kernel: 6.7.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: hpet avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c877fe9c-cef9-4c56-9812-62dcfec9364d rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Garuda
base: Arch Linux
Type: Laptop System: LENOVO product: 21JRS00U00 v: ThinkPad E14 Gen 5
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 21JRS00U00 v: ThinkPad serial: <superuser required>
part-nu: LENOVO_MT_21JR_BU_Think_FM_ThinkPad E14 Gen 5
uuid: <superuser required> UEFI: LENOVO v: R2CET32W (1.14)
date: 11/27/2023
ID-1: BAT0 charge: 36.9 Wh (78.2%) condition: 47.2/47.0 Wh (100.5%)
power: 25.8 W volts: 12.7 min: 11.3 model: Sunwoda L22D3PG4 type: Li-poly
serial: <filter> status: charging cycles: 71
Info: model: AMD Ryzen 5 7530U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2292 high: 4541 min/max: 400/4546 scaling:
driver: amd-pstate-epp governor: performance cores: 1: 2395 2: 2841 3: 2396
4: 2972 5: 400 6: 2926 7: 400 8: 3925 9: 2395 10: 4541 11: 1914 12: 400
bogomips: 47909
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Barcelo vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5
code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1
empty: DP-1,DP-2,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15e7
class-ID: 0300 temp: 54.0 C
Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 04f2:b7ba
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
Monitor-1: eDP-1 res: 1536x960 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 16.0.6 DRM 3.57 6.7.8-zen1-1-zen) device-ID: 1002:15e7
memory: 1000 MiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.0.2-arch1.1
device-ID: 1002:15e7 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.2-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.8-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Lenovo RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network vendor: Lenovo
driver: rtw89_8852be v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:b852 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4:3 chip-ID: 0bda:4853
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
Local Storage: total: 476.94 GiB used: 59.05 GiB (12.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN740 SDDQMQD-512G-1201 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 73116101 temp: 36.9 C scheme: GPT
ID-1: / raw-size: 244.33 GiB size: 244.33 GiB (100.00%)
used: 59.01 GiB (24.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 33.4 MiB (13.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 244.33 GiB size: 244.33 GiB (100.00%)
used: 59.01 GiB (24.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 244.33 GiB size: 244.33 GiB (100.00%)
used: 59.01 GiB (24.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 244.33 GiB size: 244.33 GiB (100.00%)
used: 59.01 GiB (24.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.46 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 63.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
Fan Speeds (rpm): fan-1: 2200 fan-2: 2200
Memory: total: 16 GiB note: est. available: 14.46 GiB used: 4.16 GiB (28.8%)
Processes: 319 Power: uptime: 7m states: freeze,mem,disk suspend: s2idle
wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
image: 5.77 GiB services: org_kde_powerdevil, power-profiles-daemon,
upowerd Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1488 libs: 422 tools: octopi,paru,yay
Compilers: gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-01-06
Last full system update: 2024-03-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hello there!
This suddenly appeared on my login page a few days ago. I changed the theme and it got resolved. But it showed up again after I tried to use a different image for Dragonized sugar Candy.
What do I do?

The error says it’s missing modules have you tried to install the module then?

1 Like

I just did and restarted. There’s a new error now:

Looks like you installed grub-theme-garuda.

Restore a working snapshot and use garuda-update in terminal.


I’ve never had to use snapshots before as I never tinkered with sensitive things. I hadn’t got the point of learning the use of snapshots, so I didn’t set it up. I don’t have a snapshot of the working system.
Is there any other way I can fix this issue?

Snapshots are generated automatically by default, before and after each installation/update/removal, so you should have them.

If you don’t see them in the GRUB menu, you could even try restoring a snapshot from a live USB (but the system partition should be mounted before trying with the BTRFS assistant), but starting from the GRUB is always preferrable, because you boot to a certain snapshot and if it is the good one you restore it.


Btrfs Assistant has snapshots till yesterday. This problem occurred on 13th.

You can try to remove

sudo pacman -R grub-theme-garuda




sudo pacman -S grub-theme-garuda-dr460nized

The issue occurred after I tried to put another image in place of the dragon. I didn’t change that till now. Now that I cleared that image, now it’s working. It’s back to the casually beautiful Garuda login page.
@SGS @filo Thank you so much

The errors that were displayed tell a different story.
Where did you delete or insert the image?


This has nothing to do with grub theme. The SDDM login screen Dr460nized Sugar Candy requires qt5-quickcontrols and qt5-quickcontrols2.

Install with

sudo pacman -S qt5-quickcontrols qt5-quickcontrols2

and reboot your Garuda.

@dr460nf1r3 The two packages are also missing from the current dr460nized-builds.


I didn’t have a chance to check this issue in detail and don’t have access to my PC at the moment, but wasn’t the Sugar Candy theme supposed to be removed as part of the KDE6 migration in the first place (substituted by a breeeze-based theme)?

You mean the Dr460nized SDDM theme. The Dr460nized Sugar Candy theme is still there and was set as default in one of the last iso builds (garuda-dr460nized-linux-zen-240310.iso) - and produces exactly this error.

What I meant is that the SDDM theme should be Dr460nized and not Dr460nized-Sugar-Candy, also according to this:

So if the theme of the OP is still Dr460nized-Sugar-Candy, something went wrong with the migration.

1 Like

Who talk about the grub theme?
Changing a picture will not destroy SDDM, right?

Just wait for the answer from PO.

You? 2 times…

Just install grub-theme-garuda 3.3-1, and you will see what I mean. It change the login screen.

Last but not least, we don’t know what the OP has done with his system anyway.

I can say that I have a similar issue with on my machine after the kde6 migration.

I’m running sddm and kde session in wayland, so i just get a black screen when the greeter fails, but besides that, it was pretty much a standard install. After the kde6 update, I applied the theme migration and got switched to the base “Dr460nized” sddm theme. Trying to switch back to the sugar candy version causes the crash.

The update didnt uninstall the sugar candy theme, so I suspect the user tried to change the whole theme, and not just the wallpaper.

@nepti @SGS
I don’t know what exactly caused this, but here’s what happened before.
I was trying to install and use tomcat10 on my system. That was another issue I was trying to navigate. After a struggle, I decided that it was not worth the time and effort. I tried to uninstall it. There were issues with some programming still running, unable to uninstall, and “Failed units” under garuda-inxi had tomcat10 in it. There were multiple issues that came up, and I had to resolve them. Once I restarted my system, the failed units entry was empty.
I believe it was the next day that I tried to use a different image on the Dragonized Sugar Candy theme for the SDDM. The moment I did that and restarted the system, the error showed up. I was concerned it was a deeper issue than just the theme or image change. And then the new KDE update dropped.

I’m not sure what exactly was the problem, but once I cleared the image in the themes options and chose another image(Garuda’s pre-existing wallpaper images), it showed the image I wanted to use before. Now it’s working alright with no issues. I guess it was a bug or some conflict btw versions?

Well, if not all details are mentioned in the first post, we can guess for a long time what caused what.
An exact explanation of how the login image was changed is still missing. There is the possibility to do this through a user theme or a direct exchange, but this must then adhere to the specifications (name, png/jpg).

The error messages indicate a missing module (etc.).

So what, it’s solved.