SDDM Ant-Dark theme error

Hello!

This is something I have been able to deal with on my system, so I'm posting for anyone else potentially having the same problem. I'll post inxi -Faz just in case:

System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=6558651c-7144-44ff-967b-654d4452c85c rw [email protected] quiet
           splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1
           resume=UUID=0bfc74d3-f2c5-45d0-8770-62ac2711d354 loglevel=3
           Desktop: Qtile 0.18.1 wm: LG3D vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop System: Micro-Star product: MS-7A38 v: 1.0 serial: <filter>
           Mobo: Micro-Star model: B350M BAZOOKA (MS-7A38) v: 1.0 serial: <filter>
           UEFI: American Megatrends v: 1.E0 date: 04/24/2018
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
           serial: <filter> charge: 55% (should be ignored) rechargeable: yes
           status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 1600X bits: 64 type: MT MCP arch: Zen
           family: 17 (23) model-id: 1 stepping: 1 microcode: 8001137 cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
           bogomips: 95998
           Speed: 3292 MHz min/max: N/A Core speeds (MHz): 1: 3292 2: 4000 3: 4000 4: 4000
           5: 4000 6: 4000 7: 4000 8: 4000 9: 4000 10: 4000 11: 4000 12: 4000
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1
           mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI driver: nvidia
           v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 1f:00.0 chip-ID: 10de:1c81
           class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: picom v: git-60eb0 driver:
           loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 103 s-size: 473x261mm (18.6x10.3")
           s-diag: 540mm (21.3")
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6")
           diag: 546mm (21.5")
           OpenGL: renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74
           direct render: Yes
Audio:     Device-1: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
           driver: snd_hda_intel v: kernel bus-ID: 1f:00.1 chip-ID: 10de:0fb9
           class-ID: 0403
           Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
           v: kernel bus-ID: 21:00.3 chip-ID: 1022:1457 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 1b:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: enp27s0 state: down mac: <filter>
           Device-2: Ralink RT2501/RT2573 Wireless Adapter type: USB driver: rt73usb
           bus-ID: 1-8:3 chip-ID: 148f:2573 class-ID: 0000
           IF: wlp3s0f0u8 state: up mac: <filter>
Drives:    Local Storage: total: 1.44 TiB used: 538.79 GiB (36.6%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G size: 223.57 GiB
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 30RL scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS721010A9E630
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
           type: HDD rpm: 7200 serial: <filter> rev: A3T0 scheme: GPT
           ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD2500AAKX-08U6AA0
           size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
           type: HDD rpm: 7200 serial: <filter> rev: 1H19 scheme: MBR
           ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Corsair model: Corsair Force GT
           size: 83.85 GiB block-size: physical: 512 B logical: 512 B type: N/A
           serial: <filter> rev: 1.3. scheme: MBR
Partition: ID-1: / raw-size: 99.48 GiB size: 99.48 GiB (100.00%) used: 22.1 GiB (22.2%)
           fs: btrfs dev: /dev/sda3 maj-min: 8:3
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.5 MiB (26.6%)
           fs: vfat dev: /dev/sda4 maj-min: 8:4
           ID-3: /home raw-size: 99.48 GiB size: 99.48 GiB (100.00%) used: 22.1 GiB (22.2%)
           fs: btrfs dev: /dev/sda3 maj-min: 8:3
           ID-4: /var/log raw-size: 99.48 GiB size: 99.48 GiB (100.00%)
           used: 22.1 GiB (22.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
           ID-5: /var/tmp raw-size: 99.48 GiB size: 99.48 GiB (100.00%)
           used: 22.1 GiB (22.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 19.53 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/sda6 maj-min: 8:6
           ID-2: swap-2 type: zram size: 15.58 GiB used: 2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 39.5 C mobo: N/A gpu: nvidia temp: 37 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
Info:      Processes: 360 Uptime: 4h 58m wakeups: 6 Memory: 15.58 GiB
           used: 4.46 GiB (28.7%) Init: systemd v: 249 tool: systemctl Compilers:
           gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1384 lib: 351 Shell: fish v: 3.3.1
           running-in: alacritty inxi: 3.3.06

The SDDM Ant-Dark theme is using the plasma-framework which I didn't have installed on my machine, so I had to install it on my own using sudo paru -S plasma-framework.

I'm also going to inspect a freshly downloaded qtile ISO (mainly to install Garuda Linux on my laptop) to see if that has the plasma-framework installed, because I didn't notice the same problem on the ISO even though it is running the same theme.