Screen tearing with Nvidia driver

Hello hello, I recently installed Garuda Linux on my PC. I installed Nvidia's proprietary drivers for my RTX 2060. When I opened Minecraft it wasn't smooth as it was on Windows. Even after disabling Vsync from the menu, it was still bad. I have a dual monitor setup, one 60Hz and one 144Hz. It was like my 144Hz monitor was at 60 Hz. I tried to find info on the internet, but no luck. It's not only on Minecraft, when I drag windows on the screen it's laggy. When I disable my 60Hz monitor it gets smooth. Please help!

Hi there, welcome.
Please provide the output of inxi -Faz , as text, formatted with ~~~ before and after the text block, as per new topic template.

1 Like
System:
  Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c1bac160-e2f2-4680-8c38-85ce0ea98848 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: H310CM-HDV serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P4.20 date: 05/14/2019
CPU:
  Info: model: Intel Core i5-9400F bits: 64 type: MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 4044 high: 4099 min/max: 800/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4045 2: 4025 3: 4093
    4: 4001 5: 4002 6: 4099 bogomips: 34798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f08
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: gnome-shell driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 953x286mm (37.5x11.3")
    s-diag: 995mm (39.2")
  Monitor-1: HDMI-0 res: 1680x1050 hz: 60 dpi: 99
    size: 433x271mm (17.0x10.7") diag: 511mm (20.1")
  Monitor-2: DP-0 res: 1920x1080 dpi: 94 size: 521x293mm (20.5x11.5")
    diag: 598mm (23.5")
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-3: Razer USA Razer BlackShark V2 Pro type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 1532:0528
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel port: d000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.36 TiB used: 268.92 GiB (19.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: K1B3 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Gigabyte model: GP-GSTFS31512GNTD-V
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 00Z8 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
    model: WD5000BEVT-16ZAT0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1.75 scheme: MBR
Partition:
  ID-1: / raw-size: 476.93 GiB size: 476.93 GiB (100.00%)
    used: 17.99 GiB (3.8%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 476.93 GiB size: 476.93 GiB (100.00%)
    used: 17.99 GiB (3.8%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 476.93 GiB size: 476.93 GiB (100.00%)
    used: 17.99 GiB (3.8%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 476.93 GiB size: 476.93 GiB (100.00%)
    used: 17.99 GiB (3.8%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 94.2 MiB (0.6%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 44 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:
  Processes: 284 Uptime: 3h 4m wakeups: 0 Memory: 15.56 GiB
  used: 4.18 GiB (26.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 1299 pacman: 1292 lib: 404 flatpak: 7 Shell: fish
  v: 3.3.1 default: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.11
McFly: Importing shell history for the first time. This may take a minute or two...done.

You could try with xrandr like here, setting DP-0 to 144

Maybe check also the Arch wiki
https://wiki.archlinux.org/title/Multihead#Configuration_using_xrandr
https://wiki.archlinux.org/title/Xrandr

1 Like

Which part of this is to do with screen tearing?

Your issue is due to the compositor synchronising to the 60Hz display.

Check this wiki page section: https://wiki.archlinux.org/title/NVIDIA#Vertical_sync_using_TwinView

and this one: https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Multi-monitor

3 Likes

I did xrandr --output DP-0 --mode 1920x1080 --rate 144.00 but it got even worse. When dragging windows it feels like 30Hz xD

When I changed 0/XVideoSyncToDisplayID= to 0/XVideoSyncToDisplayID=DP-0 didn't change anything.