Screen Stuck at 640x480

I just installed Garuda, but the screen is stuck at 640x480.

Looking at my inxi, I assume it has something to do with the fact that the graphics driver shows “N/A”, but I don’t know what to do about it.

I already tried automatically installing the open source drivers in the Garuda Settings Manager and rebooting with no luck.


Kernel: 6.9.1-zen1-1-zen arch: x86_64 bits: 64
compiler: gcc v: 14.1.1 clocksource: tsc
avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7c65c613-e8d3-468e-a622-0c94aa6667fb rw
rootflags=subvol=@ quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A
info: frameworks v: 6.2.0 wm: kwin_x11 with: krunner vt: 2
dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop System: LENOVO product: IdeaCentre K300
v: Lenovo Product serial: <superuser required>
Mobo: LENOVO model: N/A serial: <superuser required>
uuid: <superuser required> BIOS: LENOVO v: 58KT36AUS
date: 20091014
Info: model: Pentium E5700 bits: 64 type: MCP arch: Penryn
level: v1 built: 2008 process: Intel 45nm family: 6
model-id: 0x17 (23) stepping: 0xA (10) microcode: 0xA0B
Topology: cpus: 1x cores: 2 smt: <unsupported> cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 2 MiB
desc: 1x2 MiB
Speed (MHz): avg: 2992 min/max: 1203/3003 scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 2992
2: 2992 bogomips: 11969
Flags: ht lm nx pae sse sse2 sse3 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GF119 [GeForce GT 610] vendor: ASUSTeK
driver: N/A alternate: nouveau, nvidia_drm, nvidia
non-free: series: 390.xx+
status: legacy (EOL~2022-11-22) last: release: 390.157
kernel: 6.0 xorg: 1.21 arch: Fermi code: GF1xx
process: 40/28nm built: 2010-2016 pcie: gen: 1
speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:104a class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland
v: 23.2.7 compositor: kwin_x11 driver: X:
loaded: modesetting,nouveau alternate: fbdev,nv,vesa
gpu: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 640x480 s-dpi: 96
s-size: 169x127mm (6.65x5.00") s-diag: 211mm (8.32")
Monitor-1: Unknown-1 mapped: None-1 res: 640x480 hz: 60
size: N/A modes: 640x480
API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm:
drv: kms_swrast surfaceless: drv: swrast x11: drv: swrast
inactive: wayland
API: OpenGL v: 4.5 vendor: mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: llvmpipe (LLVM
17.0.6 128 bits) device-ID: ffffffff:ffffffff
memory: 7.57 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: cpu
name: llvmpipe (LLVM 17.0.6 128 bits)
driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel 82801JI HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:3a3e class-ID: 0403
Device-2: NVIDIA GF119 HDMI Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e08 class-ID: 0403
API: ALSA v: k6.9.1-zen1-1-zen status: kernel-api
tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with:
1: pipewire-pulse status: active 2: wireplumber
status: active 3: pipewire-alsa type: plugin 4: pw-jack
type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e800 bus-ID: 03:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR5212/5213/2414 Wireless
Network Adapter vendor: D-Link System AirPlus DWL-G520
driver: ath5k v: kernel bus-ID: 04:0a.0
chip-ID: 168c:0013 class-ID: 0200
IF: wlp4s10 state: up mac: <filter>
Info: services: NetworkManager, smbd,
systemd-timesyncd, wpa_supplicant
Local Storage: total: 931.51 GiB used: 11.3 GiB (1.2%)
SMART Message: Unable to run smartctl. Root privileges
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
model: SSD 870 EVO 1TB size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: SSD
serial: <filter> fw-rev: 3B6Q scheme: MBR
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 11.3 GiB (1.2%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-2: /home raw-size: 931.51 GiB
size: 931.51 GiB (100.00%) used: 11.3 GiB (1.2%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 931.51 GiB
size: 931.51 GiB (100.00%) used: 11.3 GiB (1.2%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 931.51 GiB
size: 931.51 GiB (100.00%) used: 11.3 GiB (1.2%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60)
cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.75 GiB
used: 14 MiB (0.2%) priority: 100 comp: zstd
avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 2
dev: /dev/zram0
System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 8 GiB available: 7.75 GiB
used: 2.82 GiB (36.4%)
Processes: 204 Power: uptime: 7m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform
avail: shutdown, reboot, suspend, test_resume
image: 3.06 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255
default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1381 libs: 386
tools: octopi,pamac,paru Compilers: gcc: 14.1.1
Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-17
Last full system update: 2024-05-17
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:

Have you tried the proprietary drivers?

This is what you need and have, but it’s currently broken:
unless you can build it with the available patch.
Hopefully the maintainer will do that job soon.


Thank you @filo!

It appears this package broke with the new kernel, so I might try the LTS kernel to see if that helps.

1 Like

The patch is probably needed also for the LTS kernel according to the comment, but I haven’t read the details.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.