Screen sharing and recording bug

Hello Guys.

When I record with OBS or when I share screen with Discord I have a glitch on the recording.

You not see on the monitor the bugg but your friends or on the recording file is present the bug.

My system.

╭─umbreon@UmbreonDesk in ~ via  v3.11.5 as 🧙 took 2s
╰─λ garuda-inxi
Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1ea97a5b-603e-4bee-8049-77cf09df8da3 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: Z690 UD DDR4
serial: <superuser required> UEFI: American Megatrends LLC. v: F24
date: 06/06/2023
Info: model: 12th Gen Intel Core i5-12400 bits: 64 type: MT MCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 5
microcode: 0x2E
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
L3: 18 MiB desc: 1x18 MiB
Speed (MHz): avg: 800 min/max: 800/4400 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 59904
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-S GT1 [UHD Graphics 730] vendor: Gigabyte
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: none empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:4692 class-ID: 0300
Device-2: NVIDIA GA104 [GeForce RTX 3070] vendor: Micro-Star MSI
driver: nvidia v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2484 class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: nvidia gpu: i915,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
s-diag: 692mm (27.26")
Monitor-1: Unknown-1 mapped: DP-0 res: 2560x1440 hz: 144 dpi: 109
size: 597x336mm (23.5x13.23") modes: 2560x1440
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.02
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
memory: 7.81 GiB
API: Vulkan v: 1.3.269 layers: 14 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3070 driver: nvidia v: 545.29.02
device-ID: 10de:2484 surfaces: xcb,xlib device: 1 type: integrated-gpu
name: Intel UHD Graphics 730 (ADL-S GT1) driver: mesa intel
v: 23.2.1-arch1.2 device-ID: 8086:4692 surfaces: xcb,xlib device: 2
type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: Logitech PRO driver: hid-generic,snd-usb-audio,usbhid type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9.1:7
chip-ID: 046d:0aa7 class-ID: 0300 serial: <filter>
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 06:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9.3:10
chip-ID: 04ca:3015 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 3.3 TiB used: 1.27 TiB (38.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 233010WD temp: 37.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: KingSpec model: NE-1TB 2280
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V0926A0 temp: 41.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 model: SSD size: 953.87 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: 7A0 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD5000LPVX-08V0TT5 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 1A05 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Toshiba model: MK8052GSX
size: 74.53 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1.02 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 400.72 GiB (42.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:6
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 400.72 GiB (42.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 400.72 GiB (42.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 400.72 GiB (42.0%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.12 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 41.0 C mobo: 32.0 C gpu: nvidia temp: 49 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Processes: 327 Uptime: 30m wakeups: 0 Memory: total: 32 GiB note: est.
available: 31.12 GiB used: 4.12 GiB (13.2%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
Packages: 2001 pm: pacman pkgs: 1989 libs: 554
tools: gnome-software,octopi,pamac,paru pm: flatpak pkgs: 12 Shell: fish
v: 3.6.1 default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
System install date:     2023-10-20
Last full system update: 2023-11-05
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Video with the problem

Its a full desktop no a laptop. iGPU. I reinstall Garuda and do Nothing more than update them and the issue is happening.

My monitor is a Acer vg270up with freesync and HDR.

With Nobara 38 KDE i havent this issue. Maybe related with the iGPU, Maybe its a error on xorg, can be a problem with anything… Its so frustating when you try the smoothness of this distro for a couple of time and when you start to sharing them and you want to record with your computer find this issue.

Checking more i see on Nobara pre enabled adaptative sync. I really like the Garuda scheme bases on arch. And the rolling release but in my pc doesn’t work correctly. I spend 2 days searching on Internet. For Nothing.

Hi there, welcome to the forum.
Check if the problem occurs also with the compositor disabled. You can enable / disable the compositor on the fly with alt+shift+F12.


Check also this one:

And maybe also:


Without compositor the problems apears to be gone

╭─umbreon@UmbreonDesk in ~ via  v3.11.5 took 2s
╰─λ sudo pacman -R xf86-video-intel
[sudo] contraseña para umbreon:
error: no se ha encontrado el paquete: xf86-video-intel

No problem, it was an old topic.
Just disable the compositor in that case…


but on nobara compositor is on and dont apear the problem

And I have a Nvidia GPU. I try yesterday to totally remove nvidia drivers and install them for myself and the problem still there. Them I remove all again reinstall from Garuda auto assistant and continúe to apears.

Do you mean that the problem appeared after you reinstalled the Nvidia drivers? Or also with the Nvidia drivers automatically installed you had the problem?

1 Like

The problem still present after and before the driver reinstall. I uninstall all Nvidia. I reinstall them with the Garuda setup i try with the Nvidia open dkms i try a lot of things.

Have you tried the solution in the first topic I linked?

1 Like

Yes, but again my display os an Nvidia card. The iGPU IS not even used.

I try to install a new Garuda on a external SSD and the problem don’t apears on them. Maybe IS because a packet I remove or install le something. I installed my distro a couple of months. Because of them and i don’t know in what moment the problem start coming Up. Because I wasn’t sharing my display and not recording. Can be better a clean install. Saving Up my work directory on something and the rest can be deleted with no worry.

How do you configure this? Maybe there is a difference between your system and the install on the external drive?
Normally we suggest using the iGPU and use the dGPU only when needed, like explained here:

1 Like

I had a prolbem with obs and a rtx 2060 and using prime-run. I installed chaotic-aur/ffmpeg-obs instead for ffmpeg. It worked for me, maybe it will work for you?

1 Like

I reinstall the system and try with a clean install the problems remain. And on the external continue to do the same bug… Its hard to tell because the error apears randomly. And the monitor is directory atached to the graphics card not the motherboard.

I LOVE the smoothness of this distro and more if you compare them with Windows.

Its a desktop PC and is not a cheap desktop.

Maybe change this, more power, less glitches? :slight_smile:


SGS is right, your CPU can do 4.4 GHz but it is getting throttled all the way down to .8:

Powersave is helpful for a laptop running on the battery, but since you have a desktop I’d say let 'er rip. Enable the performance tweaks in Garuda Assistant and see if it helps with the video issue.


It doesn’t solve the thing. I change that and the performance and the CPU is running on the same. I wasn’t expect the cpu going at that low frecuency, because on minecraft goes to 3000FPS maybe a bad report.

OK, Guys. I put the display cable attached direct to the motherboard. Using now the intel UHD of my procesor. It apears to be working now. Its sure a nvidia thing with kwin or something related betwen Nvidia and kwin.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.