Screen freezes and I have to manually reboot

Hello.

I'm experiencing random crashes/freezes on Garuda i3. It doesn't happen specific times or when i open specific applications. But it happened several times while I was on Mailspring mail client.
Also it can happen 2-3 times a day and then it can happen again after a week... It's random completely.

inxi -Faz

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ce118470-4f53-49b9-b500-9ddd71f75162 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: i3 4.20.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: B450-A PRO (MS-7B86) v: 2.0 serial: <superuser required>
           UEFI: American Megatrends v: A.21 date: 09/20/2018
CPU:       Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
           microcode: 800820D cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81590
           Speed: 3243 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 1: 3243 2: 3278 3: 3790 4: 3778 5: 3801
           6: 3798 7: 3457 8: 3495 9: 3724 10: 3770 11: 3772 12: 3776
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 1c:00.0 chip-ID: 10de:1c82 class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 driver: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.0x10.7") s-diag: 554mm (21.8")
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 1c:00.1 chip-ID: 10de:0fb9 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 1e:00.3 chip-ID: 1022:1457 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel
           port: f000 bus-ID: 18:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp24s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           IF-ID-1: br-c38dd7569bf8 state: down mac: <filter>
           IF-ID-2: br-c473b5e2278b state: down mac: <filter>
           IF-ID-3: br-c573e5d4dcb3 state: down mac: <filter>
           IF-ID-4: docker0 state: down mac: <filter>
Drives:    Local Storage: total: 1.59 TiB used: 103.1 GiB (6.3%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8500G size: 465.76 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 32.9 C scheme: MBR
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
           ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A02 scheme: GPT
Partition: ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 28.62 GiB (14.7%) fs: btrfs dev: /dev/nvme0n1p3
           maj-min: 259:3
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 596 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 254.16 GiB size: 254.16 GiB (100.00%) used: 21.29 GiB (8.4%) fs: btrfs dev: /dev/nvme0n1p4
           maj-min: 259:4
           ID-4: /var/log raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 28.62 GiB (14.7%) fs: btrfs
           dev: /dev/nvme0n1p3 maj-min: 259:3
           ID-5: /var/tmp raw-size: 195.31 GiB size: 195.31 GiB (100.00%) used: 28.62 GiB (14.7%) fs: btrfs
           dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 31.36 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 384 Uptime: 51m wakeups: 0 Memory: 31.36 GiB used: 8.65 GiB (27.6%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 Packages: pacman: 1460 lib: 335 Shell: Zsh v: 5.8 running-in: electron inxi: 3.3.09

Also I have experienced frame rate drops or general lag when sometimes I open private Firefox browser and play YouTube music. I don't know if this has something to do.

Please post full output of inxi -Faz.

I use i3wm on PC and laptop every day for many hours and nothing crash or freeze.

Maybe try with a full btrfs balance.
Sometimes it helps in these cases...

Test other kernels.

1 Like

And how I'm going to do that about full btrfs and also how to test other kernels?

Look in Garuda Assistant. :eyes:

The forum does have a search engine.

Look in Garuda Settings Manager. :eyes:

3 Likes

I downloaded a recommended kernel version
image

But inxi -Faz still shows Kernel: 5.15.6-zen2-1-zen

Now You need to boot into at grub or set grub to use it as default

3 Likes

I have same issue , Are there any solution ?

Hi there, welcome.
There's no specific fix if an issue is not reproducible, and so identified.
In those cases there are recommendations, like those above, but you can further search in the forum.
Have you tried at least what was mentioned above (other kernels and btrfs balance)?
I take the chance to ask the OP @panagiss if there were inprovements with the suggestions above.
I see you're connecting to the forum, so, please, consider that a feedback or marking a solution is important for future readers.

Yes, there are many troubleshooting solutions ranging from hardware/bios/kernel issues to bad cabling, power supply, ram, failing hard drive, and perhaps even sun spots. in other words the list could be as long as my arm. There is no one simple answer to this question. You must search the forum for the extensive list of recommended troubleshooting steps you must take to pin down the cause.

There is no easy one command solution for this problem. You must do all the footwork if you desire to find a fix. Keep detailed records of every single fix you have tried and the results. Be sure to record all command inputs you performed, with the outputs as well for good documentation purposes. When you have all this together open your own help request and be sure to include your inxi -Faz output on your initial post.

There is nothing to be gained from tacking your help request onto someone else's abandoned help request. Please open your own help requests with full specs, logs. and background information.

I'm closing down this thread now, as this thread was pointless to begin with, as you did not even provide an inxi -Faz output.

1 Like