Screen flickering in recordings in OBS-Studio

My garuda-inxi

System:
Kernel: 5.15.17-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=ec76a39d-f66f-478b-bbb5-75e495cd2ad4 rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=d0968eaf-3b7d-4f77-b00c-d64156f0a9c2 loglevel=3 quiet splash
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
serial: <filter> Chassis: type: 10 serial: N/A
Mobo: HP model: 81EC v: 61.61 serial: <filter> UEFI: Insyde v: F.49
date: 06/26/2020
Battery:
ID-1: BAT1 charge: 15.8 Wh (54.7%) condition: 28.9/41.4 Wh (69.6%)
volts: 14.7 min: 14.8 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: Discharging
CPU:
Info: model: Intel Core i5-6200U socket: U3E1 bits: 64 type: MT MCP
arch: Skylake family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEA
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 500 min/max: 400/2800 base/boost: 2200/8300 scaling:
driver: intel_pstate governor: powersave volts: 0.8 V ext-clock: 100 MHz
cores: 1: 500 2: 500 3: 500 4: 500 bogomips: 19200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 /
Radeon 520 Mobile]
vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu
bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380
Device-3: Chicony HP TrueVision HD type: USB driver: uvcvideo
bus-ID: 1-5:6 chip-ID: 04f2:b56c class-ID: 0e02 serial: <filter>
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: ati,intel,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d70 class-ID: 0403
Sound Server-1: ALSA v: k5.15.17-1-lts running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:4 chip-ID: 0bda:b008 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 19.57 GiB (8.2%)
ID-1: /dev/sda maj-min: 8:0 vendor: Faspeed model: K5-256G
size: 238.47 GiB block-size: physical: 512 B logical: 512 B sata: 3.2
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 232P temp: 40 C
scheme: GPT
SMART: yes state: enabled health: PASSED on: 20d 19h cycles: 491
read: 30.9 MiB written: 29.6 MiB
Partition:
ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 19.57 GiB (8.5%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 19.57 GiB (8.5%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 19.57 GiB (8.5%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 19.57 GiB (8.5%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 7.66 GiB used: 14.2 MiB (0.2%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 29.8 C pch: 33.5 C mobo: 27.8 C gpu: radeon
temp: 32.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 212 Uptime: 2h 30m wakeups: 3 Memory: 7.66 GiB
used: 2.92 GiB (38.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1317 lib: 321
Shell: Bash (sudo) v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda:
System install date:     2022-01-28
Last full system update: 2022-01-29
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       No/Undetected
Snapshots:               Snapper

I read on previous forum posts and found out that some have used ffmpeg as encoder in Obs studio advance option. I tried that but it is still flickering. It has reduced in some extent but not fixed completely.
I saw a guy on youtube using garuda. And he disabled the vsync in compositor and solved it but in my case there is no option to disable vsync in compositor. I tried with all different options in it but seems nothing is working.

From this page: Intel graphics - ArchWiki

Disable Vertical Synchronization (VSYNC)

The intel-driver uses Triple Buffering for vertical synchronization; this allows for full performance and avoids tearing. To turn vertical synchronization off (e.g. for benchmarking) use this .drirc in your home directory:

### ~/.drirc
<device screen="0" driver="dri2">
	<application name="Default">
		<option name="vblank_mode" value="0"/>
	</application>
</device>
5 Likes

worked for me.
Thank you :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.