Screen Flickering for CPU intensive tasks

Hi

Just wanted to understand if I missed anything.
I recently started using Garuda Linux (to be specific Arch) and was a full time Ubuntu user.

Here the issue is when I am running my Virtual Machines or doing any CPU intensive tasks, my laptop screen flickers.

I am not sure what is the issue, so after digging a little I found some post to disable "PSR" and setting idle state to '4' and did all that in grub but still have all these issues.

Request you all to please assist and do let me know what I missed.

Command Dumps: (Edited)

╰─λ inxi -Fxxxza
System:    Kernel: 5.10.4-107-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=916e7adc-dccb-43e6-8146-f7872c90289f rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 i915.enable_psr=0 intel_idle.max_cstate=4 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62469 
           Speed: 4050 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4050 2: 4039 3: 4041 4: 4005 5: 3780 6: 3977 7: 4088 
           8: 4098 9: 4098 10: 4104 11: 4098 12: 4093 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU106BM [GeForce RTX 2060 Mobile] vendor: Lenovo driver: nvidia v: 455.45.01 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f51 
           Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo bus ID: 1-7:4 chip ID: 04ca:7070 
           Display: x11 server: X.org 1.20.10 compositor: kwin_x11 driver: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f9 
           Sound Server: ALSA v: k5.10.4-107-tkg-bmq 
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): N/A 
systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1121 lib: 279 Shell: fish v: 3.1.2 running in: konsole inxi: 3.2.01 

I have blacklisted 'nouveau' to install Nvidia graphic drivers

Thanks in advance

You have removed some of the most vital information from you system specs.

Are you using Garuda or Arch? There is a difference.

Hi

My apologies for the confusion.
I am using Garuda Linux on my laptop and I recently started with arch based distros, so mentioned as above.

Ok, I you may please tell me what I missed because I removed only the lines with serial numbers and
Battery information and Machine information with serial number and other confidential information.

Thanks again.

The kernel params are targeting Intel iGPU, which is not shown in your Graphics info. It's about the CPU, sorry, I was confused, multitasking.
If you had left your non-private info, we would know if it is a laptop or desktop. What is it?
Have you disabled Intel iGPU from BIOS?
Please post

mhwd -li --pci
3 Likes

Hi

As I mentioned earlier, I am using Garuda Linux on laptop.
Also, intel graphics is disabled because I have set it to 'discrete' in BIOS settings, thus by default it will run on 'Nvidia'.

I am having Nvidia - 2060 on my laptop.
Please find the output of the command :slight_smile:

╰─λ sudo mhwd -li --pci       
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-nvidia-dkms            2020.12.19               false            PCI

Additionally, thank you for your assistance.

I know Garuda is heavily customized for performance, though I am not aware of the details.
I would wait for an experienced Garuda dev to assist on this.
In the meantime you would find Archwiki interesting to read.

Hi

Thank you for all your support.
I am trying to search for solutions but as of now no luck.

This is the current status :

  • While installing selected "drivers: non-free"
  • After installation updated the system
  • Disabled Flipping in Nvidia Settings
  • Enabled 'Force Full Composition Pipeline' from Nvidia X Windows Server Config
  • In system settings > compositor > changed the settings to 'XRender'

All these things didn't fixed the issue.

Also, in BIOS I have enabled "Discrete" option rather than "Switchable" so the desktop is running on Nvidia only.

Please do let me know if you have any solution to this.

NOTE : Screen flickering only happens when the fan kicks in like after running VM or doing some CPU intensive task, rest its ok and very negligible.

1 Like

I an not sure it's a video driver issue, since it happens when CPU/fan top up. Maybe a CPU related config (performance, governor etc).
As I said, it is better to wait a dev for an answer.
@librewish ?

2 Likes

Hi

Thank you for your prompt assistance but the issue is resolved now.
Steps ( sorry to elaborate )

  • I never saw this when I was using Ubuntu so I thought of reinstalling "Garuda" with the same steps I use to perform when I install Ubuntu
  • As I mentioned earlier, I have disabled Intel Graphics from BIOS and my Xwindow was purely using NVIDIA so there were some discrepancies which I am not sure of
  • So this is what I did :slight_smile:

Enabled my Intel Graphics by changing the BIOS from 'DISCRETE' to 'SWITCHABLE'

We need to disable 'NOUVEAU' explicitly when we are installing Ubuntu via 'nouveau.modset=0' param, but this is already present in Garuda kernel boot params when you boot with 'drivers : non-free'

THAT's it :clap: :clap: :clap:

  • After the installation is complete, I went on to "COMPOSITOR" and changed the values

Scale : Crisp

Rendering backend : OpenGL 3.1

NOTE : This is just to make the display more sharper and has nothing to do with the issue we are addressing.

With this I understood one thing, with Garuda, what all you have just place it while you are installing Garuda and it will auto-detect and do the magic for you and you just have to blink

Loved it :slight_smile:

3 Likes