Screen blanking and sleep on idle

Dumb question: what is the best way to set-up screen blanking and sleep on idle?

Please post the output of garuda-inxi for all Issues & Assistance topics as requested in the template.

Try the solution suggested in this thread:

Another solution would be to add this to your Hyprland config:

exec-once = swayidle idlehint 1

That will send an idlehint after you log in, and from there you can configure your desired settings in /etc/systemd/logind.conf (or, even better, a drop-in file in /etc/systemd/logind.conf.d/).


Was this format we have got in hyprland recently ?

Because , to execute at once during startup is done like this :

exec-once = swayidle idlehint 1

As far as I remember , that format is for sway config :sweat_smile:

Tell me if I am wrong :slightly_smiling_face:


You are not wrong, I just grabbed that right out of my Sway config. :shushing_face: :sweat_smile:

Thanks for the correction, I edited the post above .