Screen blacking in and out after updating nvidia-drivers [solved]

Edit: Solved it by lowering my displays refresh-rate to 120hz.


I have a problem with my main screen blacking in and out after updating my drivers.
So, short backstory, I wanted to play some minecraft but due to driver-issues it didn't wanna start up. So, next thing I did was check with yay -Ss what version of the drivers (for an Nvidia 2070) I had installed and it seemed like I had installed the newest ones, which struck me as odd so I went to check with nvidia X server settings, and there it said that instead of 535.something I had installed 530.something. Following that I tried garuda-update, which did nothing, yay -S nvidia which wanted to install the default kernel which I then abruptly stopped and then I reinstalled the dkms package with yay -S nvidia-dkms and rebooted to have the new drivers initialize.
After rebooting I could play minecraft, however as described now my main screen blacks out every 1-2 seconds, if not more often, which is unusable. I have two monitors, one old 1080p@60hz one connected via HDMI and a new 1440p@144hz one, which is the one blacking out. Any idea on how to resolve this?

I kinda don't wanna necessarily downgrade my drivers in the long-term as I do wanna be able to play minecraft, and I do wanna use the zen-kernel so it seems I can't just install the nvidia-package.

I didn't have that issue before updating, rebooting doesn't fix it. I installed the garuda lxqt-kwin version and then installed stock kde over it as I don't want to have the dragonized theme, and no other version either wanted to boot off the usb successfully at all or wanted to boot after installing.

Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=a9faa8f0-ade7-465f-903f-b206fb49a916 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7B85 v: 1.0
Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) v: 1.0
serial: UEFI: American Megatrends v: 1.10
date: 08/06/2018
Info: model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3237 high: 3428 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2771 2: 3200
3: 3396 4: 3200 5: 3351 6: 3423 7: 3200 8: 3200 9: 3200 10: 3200 11: 3428
12: 3200 13: 3200 14: 3200 15: 3425 16: 3200 bogomips: 102387
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] driver: nvidia v: 535.54.03
alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 1c:00.0 chip-ID: 10de:1f07
class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1532 s-dpi: 107 s-size: 1064x363mm (41.89x14.29")
s-diag: 1124mm (44.26")
Monitor-1: DP-0 pos: primary,top-right res: 2560x1440 hz: 144 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-2: HDMI-0 pos: bottom-l res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX
2070/PCIe/SSE2 direct-render: Yes
Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel v: kernel
pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 1c:00.1 chip-ID: 10de:10f9
class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1e:00.3 chip-ID: 1022:1457 class-ID: 0403
API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 17:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlo1 state: down mac:
Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 18:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp24s0 state: up speed: 100 Mbps duplex: full mac:
IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-4:5
chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Local Storage: total: 20.46 TiB used: 356.66 GiB (1.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: fw-rev: 2B2QEXE7 temp: 46.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MG09ACA18TE
size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: fw-rev: 0104 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40EZRZ-00GXCB0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial:
fw-rev: 0A80 scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 127.6 GiB (27.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 127.6 GiB (27.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 127.6 GiB (27.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 127.6 GiB (27.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 94.5 MiB (0.3%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 37.9 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 29%
Processes: 434 Uptime: 3m wakeups: 1 Memory: available: 31.3 GiB
used: 6 GiB (19.2%) Init: systemd v: 253 default: graphical tool: systemctl
Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman pkgs: 2141
libs: 480 tools: octopi,paru,yay Shell: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.27
Garuda (2.6.16-1):
System install date: 2023-04-22
Last full system update: 2023-06-17 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut nvidia-dkms
Windows dual boot: No/Undetected
Failed units:

First, please reboot.
Second, please look for any BIOS updates.


As I said, I already tried rebooting. Will look for BIOS-Updates though.

1 Like

That indicates a reboot is needed. Or is your garuda-inxi outdated?

1 Like

I'm not quite sure, if that may help:

try using the right "OSI" and "APIC" params for your kerlnel.
try use the systemctl enable nvidia-persistenced

1 Like

I already updated, literally yesterday, then updated my nvidia-dkms today, and after updating dkms I directly rebooted. After rebooting, the blacking in and out issues occurred.

Yeah, seems to be an issue reported in many of places on the net.

If you have a single Gsync compatible HRR monitor you may experience frequent full screen flashing in these new drivers.


1 Like

Do you know how I might be able to downgrade drivers?

Nvm, thanks a lot for the link, I solved it by lowering my refresh-rate to 120hz for now. Will build a new computer with an AMD-GPU in the near future anyway.


Complicated since tied to the kernel. Here is a Manjaro thread on downgrading nvidia proprietary drivers, but Manjaro is different than regular arch on how they handle package mgmt, so use with caution.

P/S: you will have to change his links to the Garuda/Arch nvidia drivers of choice.

1 Like

Hi. I had exactly the same problems. This is the fault of the underdeveloped driver, which a lot of people complain about (I don't know why they released the 535 version hastily, and they are already boasting about the revolutionary 545).

You can downgrade the driver to the working version 530 by:

git clone GitHub - Frogging-Family/nvidia-all: Nvidia driver latest to 396 series AIO installer
cd nvidia-all
makepkg -si

What driver version do you want?
> 1. Vulkan dev: 525.47.26
2.535 series: 535.54.03
3.530 series: 530.41.03
4.525 series: 525.116.04
5.520 series: 520.56.06
6.515 series: 515.86.01
7.510 series: 510.85.02
8.495 series: 495.46
9.470 series: 470.182.03
10. Older series
11.Custom version (396.xx series or higher)

I don't use the TKG kernel. I didn't like them. Whereas the drivers (nvidia-tkg) solved all the problems with my hardware.

Additionally, if it helps someone, I use envycontrol because I have a hybrid optimus laptop (intel + nvidia). I'm in nvidia mode all the time. The ultimate gaming experience is:

sudo envycontrol -s nvidia --force-comp --coolbits 24

I alternate between linux-clear, xanmod and liquorix kernels. Everything works flawlessly. It's not the kernel's fault. You don't need a standard kernel (zen or lts). Tested on many games.

Problems with image display, black screen or flickering are over. I don't think it has anything to do with the bios. This is the only solution in this post (topic).

We don't like to link to Manjaro so much anymore.
They removed the online archived version of the old forum not long ago.
As a result, a reference work has been lost.

Better would be with the link also to insert the corresponding content here.

Garuda Linux will always try to keep the dataset unharmed.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.