Samsung Buds2 Pro and Garuda connected but no audio coming out

Hi guys,

I’m new to Linux and Garuda. I’ve installed Garuda as my first Linux OS journey because I really like the look of it. I’m learning and enjoying it so far, but I’m having issues trying to get my Samsung Buds2Pro to work with Garuda.

I’ve tried the Galaxy Buds Manager for Linux, but it didn’t help. It kept saying my Buds aren’t connected, but the Bluetooth in the SystemTray says it it. I also tried to delete the Buds and then reconnect.

If anyone has any ideas on what software/drivers I need to install to make my Buds2Pro work, I’d appreciate the help. Thanks in advance.

1 Like

We need the garuda-inxi.

In KDE it is easy to set the settings, other DE’s not, so, post the garuda-inxi, please.

Read the template

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


If you don’t know how to use the Terminal they made a really awesome application. It’s called Garuda Assistant. There is a tab called “system spec”. Click it and at the bottom right is copy to forum

Click that and then paste it in the reply. If you figure out a solution please come back and let us know what it was so we can close the issue and share the knowledge.

Welcome to Garuda, the best distro I know of.


solid 40% chance audio is just being sent to the wrong place and 5 seconds in audio devices to change it would fix this.

1 Like


╰─λ garuda-inxi
Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1b3c8c03-7285-4fb0-9206-7bc95933b85f rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Acer product: Swift SF314-55 v: V1.07
serial: <superuser required>
Mobo: WL model: MILLER_WL v: V1.07 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required>
UEFI: American Megatrends v: 1.07 date: 12/24/2018
ID-1: BAT0 charge: 44.8 Wh (99.3%) condition: 45.1/50.8 Wh (88.7%)
volts: 16.6 min: 15.3 model: AC14B7K type: Li-ion serial: N/A
status: discharging
Device-1: hidpp_battery_1 model: Logitech Wireless Mouse M510
serial: <filter> charge: 50% (should be ignored) rechargeable: yes
status: N/A
Info: model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Whiskey Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 450 high: 800 min/max: 400/3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 800
5: 400 6: 400 7: 400 8: 400 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
Device-2: Chicony HD WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:5 chip-ID: 04f2:b5c5
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.6
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1536x864 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (WHL
GT2) device-ID: 8086:3ea0 memory: 7.43 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: Intel
UHD Graphics 620 (WHL GT2) driver: mesa intel v: 24.0.5-arch1.1
device-ID: 8086:3ea0 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Cannon Point-LP High Definition Audio
vendor: Acer Incorporated ALI driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0401
API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:6
chip-ID: 8087:0aaa class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c010c
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 3060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 465.76 GiB used: 17.42 GiB (3.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 3B4QFXO7 temp: 28.9 C
scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 17.42 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 17.42 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 17.42 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 17.42 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.61 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
System Temperatures: cpu: 38.0 C pch: 36.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 8 GiB available: 7.61 GiB used: 2.79 GiB (36.6%)
Processes: 285 Power: uptime: 3h 54m states: freeze,mem,disk
suspend: s2idle avail: deep wakeups: 3 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 3.03 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1517 pm: pacman pkgs: 1511 libs: 431
tools: gnome-software,octopi,paru pm: flatpak pkgs: 6 Compilers: gcc: 13.2.1
Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-20
Last full system update: 2024-04-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units: ```
1 Like

I also tried going into the audio settings and see if it is a setting I can change but still can’t get the earbuds to work. It does the same thing with other bluetooth earbuds, too. I’m thinking it’s my bluetooth driver on my laptop?

Thank you for the suggestion, but I’m forcing myself to learn the Terminal to get used to Linux. haha.

So if you guys have any solutions that involve in using the Terminal, that would be even better. Looking forward to learning and hopefully pay-it-back and teach/guide someone else later on in life.

1 Like



in termial.
Search in arch wiki for the ID number xxxx:xxxx if there are problems.

Bus 003 Device 005: ID 8087:0026 Intel Corp. AX201 Bluetooth

You can search also by

Hardware PCI/USB ID Working?
Bluetooth 8087:0026 Yes
8087:0033 Yes

According to the wiki page, my bluetooth should be working.

Bus 001 Device 006: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)```

Did you check also “Sound” in “System Settings” ?
Or you mean audio = sound?

Upps, wrong idea :slight_smile:

1 Like

Sadly I know nothing about plasma, I still use cinnimon desktop and it has blueberry. From what I read you might be using bluedevil as a GUI.

For the most part the bluetooth works, sometimes i have to delete the device, make sure the headphones are in pairing then re-connect. Sometimes I have to turn off and on my head phones. for it to connect and have sound.

but again I am using a different app and have no experience with bluedevil. I will say that I have the same device as you “Bluetooth 9460/9560”

I have no idea if the galaxy software for linux conflicts in anyway, but it might be good to uninstall it and reboot. Then try to pair again.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.