Samba Connectivity

I am getting "Could not connect to host for smb://.local/" when trying to connect to other machines via "shared folders (SMB)" option under network in dolphin file manager

From other machine i am able to browse the same. Both machine have similar smb.conf file.

By other machine I meant is that i am able to connect to connect to Garuda Install from other Arch DE

Is there anything i am missing? Any help or pointers, much appreciated

Probably you need to enable
smb and nmb service and add your user to
sambashare group

You can do this by

Going to garuda-welcome > settings tab

2 Likes

Does Samba need a specific port? If yes firewalld could be blocking the access.

2 Likes

Do you use Windoze on other computers in your network? If not, I would suggest installing the native Linux NFS (Network File System).

@librewish has done a great job of configuring Samba OOTB, yet the fact remains it is a reverse engineered M$ creation intended for Win based systems.

I haven't used Samba in quite some time. I consider it just not worth the effort to configure and maintain on Linux. Samba is just too prone to breakages IMO, NFS is rock solid in comparisson. NFS would always be my first choice, but that's just me.

If you're not running Windoze, ditch Samba.

2 Likes

Yes i have both smb and nmb service enabled and systemctl status shows that they are up and running

No. I don't use Windoze on any computers...but will try to give it try and upate you.

Then I think NFS is totally the method for you. My own personal opinion is even if you get Samba configured and working it won't be too long before some Samba update breaks your configuration.

Once you have NFS configured, (and that is simpler than Samba) you're good for the long haul. The Arch wiki has lots of info on NFS.

3 Likes

i have couple of Windows machine..that i would to share with and hence trying to see if i could make Samba working...will try few things over the weekend...to see if i am missing anything trivial in configuration or settings.

by default; dolphin tries to connect using smb;//.local and getting error

tried, it with smb:// and it worked fine....

I am not sure why dolphin is not able to resolve it....will look into it further....if anyone knows or point me to right direction....much appreciate

You could try mounting Your shares either via fstab or a systemd mount unit.

1 Like

adding mdns4_minimal in hosts line under /etc/nsswitch.conf was able to connect via samba from all the machines.

3 Likes

now that i think about it

we should change /etc/nsswitch.conf
and edit hosts: to

hosts: files mymachines myhostname mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns wins
2 Likes

How about we just ban all M$, file systems and protocols.

Problems solved. :rofl:

4 Likes

Hey, just was struggling with the same. Couldn't reach my QNAP over SMB from Dolphin, getting Could not connect to host for smb://... error.

Also I wasn't able to ping/ssh to other machines in my network using .local resolution from Avahi.

It turned out that I was missing nss-mdns package,

pacman -S nss-mdns

solved the problem.

2 Likes

Thanks, this fixed my problem today! Just installed Garuda this week.
added all my drives to fstab and nfs shares to exports, but forgot to start nfs service.
facepalm

1 Like

Awesome, I feel great anytime I convert someone to using NFS. Personally I feel it is not only superior to Samba, but also far easier to setup IMO.

Welcome to Garuda @Griever.

1 Like

Was already using NFS on Pop OS! tho, just been a while since I've set it up :}

1 Like

That's OK, I feel the more exposure NFS gets the better. I don't have a very high opinion of Samba (if you didn't notice).

Not only can Samba be far more difficult to setup IMO, the worst part is it suffers many breakages from constant upstream revisions.

Samba is just one more holdover from the Windows world that a Linux box is far better off without IMO.

Ya used to use samba, because I was still logging on windows, for gaming.
Then when I made the full switch I figured, why not get something is optimized for linux and not to work with windows.
Sounds better and more optimized.

1 Like