S.o.S (beginner made a mistake)

I CANNOT access my terminal or enter in garuda-inxi. I RENAMED my home/___ folder and CANNOT access my desktop even via snapshot restoration. How do I fix it from the GRUB

Your opinion in honor, but it would be kind to follow the template.
If we discuss every time whether it makes sense or is helpful to post garuda-inxi, the effect of making the helpers’ work easier would be obsolete.


I apologize but I dont think you understand my situation I literally cannot do anything what do I do to change it back

Restore a snapshot from before the edits took place. Then we can take a look and see if there is a better approach to accomplish what you want to do.

No that literally doesnt work
Ive tried restoring the snapshots but it tells me to remount the folder that i renamed i need to rename it back how do I do that from grub

Ahh…right, because /home is not in the snapshots by default. Too bad, that would have made things a little easier.

Boot to the live environment with your USB stick you installed with, and mount the hard drive from there to make the edits.

1 Like

That USB stick doesnt exist in that state anymore.

I literally have no option but grub but I have no clue what command to use and I know I could make my system worse with the wrong one

You need to get further than Grub. Are you not getting to the login screen?

1 Like

When i log in it gives me black screen and a million errors telling me that they cant find the old folder

Just do a new install.

It is enough just to get to the login screen. From there, switch to a TTY and sign in as root to make the edits.

I know all that needs to happen is for my folder to have the name it did less than an hour ago how do i make that happen

I have no options for logging in besides my user

Switch to a TTY by pressing CTRL+ALT+F2, or F3 from the login screen. Sign in as the user root.

1 Like

Alright now whats the command

(I appreciate the help)
Ive logged in as root, now what

I think your plan was to rename the directory?

mv /home/new-name-which-isn't-working /home/old-name-which-worked

So now i just reboot and everything goes back? This feels like a time travel movie
It didnt work :frowning:

Please post the actual error you are getting when you sign in. Take a picture of the screen with your phone if you want to.

If you can describe in as much detail as possible what you changed and how you changed it, that would be helpful.

1 Like

Please edit your last post as long as no one has replied to this one. This is not reddit or telegram, thank you :slight_smile:

1 Like