Running both a DE and a tilling windows manger

Hello all,

Is it possible to run both a de and a tilling windows manger?
I want to be able to chose between a de and a tilling windows manger when I go to login. Similar to how Exodia OS lets you chose different tilling mangers when you login.

Kernel: 6.5.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e9d8a1aa-090b-4240-b14f-835cec7432bf rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=d917fd01-2a15-4f55-b767-88d48e8527ed loglevel=3
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Detachable System: ASUSTeK product: ROG Flow Z13 GZ301ZC_GZ301ZC
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GZ301ZC v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: GZ301ZC.317 date: 05/18/2023
ID-1: BAT0 charge: 32.8 Wh (68.5%) condition: 47.9/56.0 Wh (85.5%)
volts: 16.0 min: 16.0 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 142
Device-1: hid-0018:04F3:2ED7.000A-battery model: ELAN9008:00 04F3:2ED7
serial: N/A charge: N/A status: N/A
Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x42C
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 635 high: 1054 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 640 2: 645 3: 1054 4: 971
5: 971 6: 400 7: 713 8: 400 9: 826 10: 400 11: 926 12: 400 13: 400
14: 1021 15: 947 16: 400 17: 400 18: 400 19: 400 20: 400 bogomips: 107520
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 535.xx+
status: current (as of 2023-09) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-23 bus-ID: 0000:01:00.0
chip-ID: 10de:25a2 class-ID: 0300
Device-3: Microdia USB 2.0 Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 0c45:636d
class-ID: 0e02 serial: <filter>
Device-4: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:6 chip-ID: 13d3:5492
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
s-diag: 599mm (23.57")
Monitor-1: eDP-1 model: Sharp LQ134N1JW54 built: 2021 res: 1920x1200
hz: 120 dpi: 169 gamma: 1.2 size: 288x180mm (11.34x7.09")
diag: 340mm (13.4") ratio: 16:10 modes: 1920x1200
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 14.96 GiB unified: yes
API: Vulkan v: 1.3.264 layers: 8 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:46a6 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
API: ALSA v: k6.5.7-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:8 chip-ID: 8087:0033 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 7c0000
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Local Storage: total: 476.94 GiB used: 93.99 GiB (19.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN735 SDBPTHH-512G-1002 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 70626000 temp: 35.9 C scheme: GPT
ID-1: / raw-size: 97.66 GiB size: 97.66 GiB (100.00%)
used: 18.17 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 400 MiB size: 399.2 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 361.89 GiB size: 361.89 GiB (100.00%)
used: 75.81 GiB (20.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 97.66 GiB size: 97.66 GiB (100.00%)
used: 18.17 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 97.66 GiB size: 97.66 GiB (100.00%)
used: 18.17 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.32 GiB used: 516.5 MiB (3.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20
dev: /dev/zram0
ID-2: swap-2 type: partition size: 17 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 61.0 C mobo: N/A
Fan Speeds (rpm): cpu: 5400
Processes: 459 Uptime: 3h 42m wakeups: 26 Memory: total: 16 GiB note: est.
available: 15.32 GiB used: 10.18 GiB (66.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1609 libs: 429 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-13
Last full system update: 2023-10-20 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            grub-btrfs-snapper.service

There is a little tiling manager included in KDE.
Or you can use Bismuth or something.
In the end I use i3wm and Hyprland with my favorite apps from KDE :slight_smile: ,
Anything else would only destroy your system in the long run.

Check this.

1 Like

it actually works … even it is possible to install multiple DE also.

i tried that things in Linux mint(mate) … by installing both mate and gnome.…+ awesome WM… it works… (though after every first boot it shows “some system error occurs”… :slightly_smiling_face:or some kind of that)…
but system stays unbreak.

IDK if there is any toxic relationship between gnome and kde … can we use both DE in one system :melting_face:??? (i have no dare to do that)
if anyone has experience … share it please.
but i think , may be this kind of experiment break arch like distros.

Recently i am trying to install hyprland alongside kde, but when i boot in hyprland it crashes every time

There are many/some topics in the forums about, and the basic opinion is, besides the knowledge you should only try it as an experienced user, at some point it breaks.
On top of that, you’re on your own. There is already no official help with dual boot with M$ :smiley:


If you create separate users for the different desktop environments, it can help prevent things from becoming broken to a degree.

Larger, more “opinionated” desktop environments like Gnome or KDE are generally harder to mix with other DEs or WMs because they have a lot of processes they directly control and it is easy to introduce conflicts. I have seen folks have success with a simpler combo like XFCE and i3. See here for example:


My Englisch is very bad, but I read both like together and not separate, or misunderstand the hole question :crazy_face:


derp GIF

1 Like

No DeepL?

You have been studying more English I think! :student:


That was a really good setup. I used it for quite a while. It also integrates well with MATE. Even the updates thread I made is pretty old at this point. Gnome and plasma have better ways to do this without messing things up so much. Bismuth or pop shell work well.

Today if I were going to try again I would probably just do i3 and install xfce panel and be done with it.


i tried gnome and mate … and i think it is good combination as both use gtk 2/3/4…etc.

but i have a qustion?
how can i try Hyprland with kde …(without conflicting with garuda-hyprland-settings)
You gyus have more experiences…

I think what most of us are trying to say here is stuff will break if you do that. Additionally, sometimes breakages caused by merging multiple DEs can be hard to troubleshoot or resolve, because it’s not always obvious what things are conflicting or why. DE 1 may need such-and-such environment variable set, but DE 2 needs another, etc.

If you want to install multiple DEs or WMs, one way to minimize breakage is to have separate users so the dotfiles don’t get mixed. Log in as appu1 when you want to use KDE, appu2 when you want to use Hyprland for example.

Having a “hybrid” setup with a DE and WM coexisting simultaneously like in the tutorial above is not easy to do unless the DE and WM are both simple, like XFCE and i3 are. I have no idea what would be involved with trying to set up something like that with KDE and Hyprland, where both DE and WM are complex and/or opinionated. I would probably not recommend trying it unless you are already very experienced with both environments.


You can definitely swap out kwin for i3, is nowhere near as fluid as on xfce though. For a while I think I had tried about every imaginable combination.

I’ve never tried hyperland, but I’d guess like everything else, it’s probably easiest to do with xf4wm.

@appu what is the ultimate goal? I mean if it’s just to make it work, that’s fine, but like what pieces of each are you missing from the other? Is it just the tiling like in bismuth, or is it more than that? What hyperland features are unavailable in plasma currently?

1 Like

Actually plasma is great , i wanna try Hyprland…i mean just for fun :slightly_smiling_face:. As a student, plasma workspace i great and fully functional for me.
And also for customizing look and feel :smiling_face_with_three_hearts:

I like the easier customization capability than other WM’s … cause whenever i have tried to customize a wm … i fell into sea :smiling_face_with_tear: :slightly_smiling_face: :melting_face:

why you guys are posting exciting screenshots, they attracted me(and also others who like look and feel) :stuck_out_tongue_winking_eye:


Then try everything! Vm and break things. You’ll have more interesting questions once you start digging in!

Maybe you’ll find the next great setup.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.