RTX 2060 driver from NVIDIA won't install

Hi All,
This is such a great distro, makes arch usable! - I love it.

I'm having an issue getting the GFX in my laptop to work using NVIDIA drivers. I have downloaded from NVIDIA (however, I don't think that I'm supposed to do that from doing some reading) but that won't install as nouveau is running, and I can't seem to blacklist it.

I've seen someone with an older GTX card get them working by running a pacman command (sudo pacman -Syu nvidia-470xx-dkms) - but I have no idea what nvidia package (if one exists) I need to install via pacman.

Cany anyone help me get proper hardware accelerated GFX working on my Garuda installation, I love it so much and would very much like to keep using it

Thanks!

You're correct, so rather than trying to get something to work that you know is the wrong approach, why not try the correct approach and install the NVIDIA drivers using the Garuda tools?

2 Likes

Hi there, welcome.
Please always include the output of your garuda-inxi, as instructed in the template.
As regards your issue, I'm not a Nvidia user nor expert but I've seen many troubles starting installing wrong drivers at first.

Anyway, in general, you can install the proprietary drivers from the setup assistant or with the HW assistant (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration).

2 Likes

"You're correct, so rather than trying to get something to work that you know is the wrong approach, why not try the correct approach and install the NVIDIA drivers using the Garuda tools?"

I have tried that - but then the display scale is HUGE, even when in display settings the scale is set to 100%. Makes it look like I'm using a super low res.

I'll post the output from garuda-inxi ASAP.
As mentioned above, I did try the installation using the built-in tool in the Setup Assistant, and also via Hardware Manager - but the display res looked like 800x600 even though in Display Settings it was showing 1920x1080 and scaled to 100%.
Odd.

Here is the output from garuda-inxi:

System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=8d47e4f0-3764-4bc2-8d77-85cae44f6ea0 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: HP product: OMEN by HP Laptop 15-dh1xxx v: N/A
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: HP model: 8746 v: 04.34 serial: <filter> UEFI: AMI v: F.35
date: 04/01/2022
Battery:
ID-1: BAT1 charge: 6.3 Wh (11.2%) condition: 56.0/69.0 Wh (81.2%)
volts: 12.1 min: 11.6 model: COMPAL PABAS0241231 type: Li-ion
serial: <filter> status: charging
CPU:
Info: model: Intel Core i7-10750H socket: U3E1 bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEC
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/5000 base/boost: 2574/8300
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
7: 801 8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Hewlett-Packard
driver: nouveau v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Device-2: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 04f2:b627 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x82ed built: 2018 res: 1920x1080
hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x350
OpenGL: renderer: NV166 v: 4.3 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA TU106 High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f9
class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 3c:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp60s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5020 bus-ID: 00:17.0 chip-ID: 8086:282a rev: class-ID: 0104
Drives:
Local Storage: total: 1.62 TiB used: 8.99 GiB (0.5%)
ID-1: /dev/mmcblk1 maj-min: 179:0 vendor: Lexar model: LX256
size: 238.48 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB1T0HBLR-000H1 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS0NEXF temp: 33.9 C scheme: GPT
SMART: yes health: PASSED on: 33d 14h cycles: 619
read-units: 11,277,967 [5.77 TB] written-units: 11,517,933 [5.89 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
family: Micron Client SSDs size: 465.76 GiB block-size: physical: 512 B
logical: 512 B sata: 3.3 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 043 temp: 28 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 2 hrs cycles: 7
written: 21.48 GiB
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 8.99 GiB (1.9%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 8.99 GiB (1.9%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 8.99 GiB (1.9%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 8.99 GiB (1.9%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C pch: 42.0 C mobo: 10.0 C gpu: nouveau
temp: 34.0 C
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
Processes: 325 Uptime: 1m wakeups: 2 Memory: 15.47 GiB
used: 1.82 GiB (11.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1117 lib: 278 Shell: Bash (sudo) v: 5.1.16
running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-06
Last full system update: 2022-05-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:

In which case this is the problem you need to fix - installing the same driver via a different route isn't going to help.

Can you switch your laptop to discrete graphics mode in the UEFI? If so, that's going to be the most reliable way of getting the dGPU to work correctly.

My machine only has the RTX2060, no other GFX chips - i.e. it doesn’t have an Intel Iris as well.

I just tried to install via Hardware Configuration and now it won’t boot. Stuck at “Loading Linux linux-zen…..
Loading initial ramdisk….”

I’ll have a look at the UEFI settings though

1 Like

As I thought - there are no settings in UEFI to switch to discrete GFX as the only GFX card in the machine is the RTX2060.

I'm now re-installing Garuda as installing via Hardware Manager has stopped the machine from booting.

1 Like

Restoring the previous snapshot might be quicker.

I seem to remember that there was a certain range of cards that were "unknown" within the NVIDIA PCIID list - I wonder if this was one of them, and it's installing the wrong driver package.

Which driver does the Hardware Manager pick to install?

It tries to install video-nvidia-dkms

Then says “Partial upgrade detected, please fully update your system to prevent system instability. Performing partial upgrades is unsupported”

Then won’t boot.

I have managed to get back up using a snapshot before installing the dkms package using nouveau driver.

Thanks for your replies btw

This is the driver I used to get my GT-730 running,
http://aur.archlinux.org/packages/rtl8821cu-dkms-git
Find it in pamac search.

By the way I founs navidia cards need xorg. For some reason wayland hasnt caught up yet.

I found that out last night! There was no xorg.conf

I have now solved the issue. I used the auto installed driver. Turns out I had to use Nvidia server settings tool to create an X11 conf file, and add in an option to "Monitor" specifying a custom DPI setting.

well done and yes sometimes you do need to let Nvidia create that file but for most its not needed

Ideally you wouldn't have a xorg.conf file at all. Just having the DPI settings on its own in xorg.conf.d should be enough and is the preferred solution to having a full xorg.conf.

Interesting.... how would that entry look in xorg.conf.d?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.