[RTL8822CE] Wifi option is not showing in garuda linux Dr460nized

Hello! Everyone,
Today I installed garuda linux in my pc(hp 14s), but I am unable to connect to a wifi network cause its not showing at all.

This is my pc info :-

Kernel: 6.2.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9a7d04fc-3ed6-4e9b-81b8-dafc2fb88bf9 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=2aff6f50-56b4-4329-b259-442819cafc73 loglevel=3
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP Laptop 14s-dy2xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 87FD v: 57.20 serial: <superuser required> UEFI: AMI
v: F.21 date: 03/21/2022
ID-1: BAT0 charge: 18.7 Wh (51.4%) condition: 36.4/41.0 Wh (88.8%)
volts: 11.1 min: 11.3 model: HP Primary type: Li-ion serial: <filter>
status: discharging cycles: 143
Info: model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xA6
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 2.5 MiB desc: 2x1.2 MiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 976 high: 1399 min/max: 400/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 1241 2: 1399 3: 559
4: 705 bogomips: 23961
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a78 class-ID: 0300
Device-2: Luxvisions Innotech HP TrueVision HD Camera type: USB
driver: uvcvideo bus-ID: 1-3:4 chip-ID: 30c9:0035 class-ID: fe01
serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1400 built: 2018 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel UHD Graphics (TGL GT2)
direct-render: Yes
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
API: ALSA v: k6.2.10-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.68 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: N/A modules: rtw88_8822ce port: 3000
bus-ID: 0000:01:00.0 chip-ID: 10ec:c822 class-ID: 0280
IF-ID-1: enp0s20f0u1 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: MediaTek RMX3286 type: USB driver: rndis_host v: kernel
bus-ID: 1-1:2 chip-ID: 0e8d:2004 class-ID: 0a00 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-10:5 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Local Storage: total: 238.47 GiB used: 6.69 GiB (2.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLQ256HAJD-000H1 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS4NFXV temp: 48.9 C scheme: GPT
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 6.59 GiB (6.6%)
fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 129.97 GiB size: 129.97 GiB (100.00%)
used: 99.7 MiB (0.1%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 6.59 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 6.59 GiB (6.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.41 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
System Temperatures: cpu: 71.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0 fan-2: 0
Processes: 202 Uptime: 6m wakeups: 11436 Memory: 7.41 GiB
used: 2.19 GiB (29.6%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1156
libs: 313 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-13
Last full system update: 2023-04-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hi there, welcome to the forum!

Tip: If you use the forum search function, network issues can be easily spotted / narrowed down limiting the search to the Networking category, where Topics are Solved, and of course you could search for your wifi card.
I'd try this solution first:

If you don't have an Ethernet card, you will need of course to use your mobile phone in tethering mode.

I tried but this is showing while installing

ERROR: Missing 6.2.10-arch1-1 kernel modules tree for module rtw88/r218.37c8025.

Please help me

What to do now

I still waiting for your reply
please answer something

Please don't be pushy.
We are all unpaid volunteers here.
I, for example, check the forum only during some breaks, but I am at work now and will have to dedicate some time to family soon after back home...
Sorry, I will try again in a few hours.


Try installing the linux kernel:

sudo pacman -S linux linux-headers

and then again that package.
If not working again, try to build it yourself with an helper:

paru rtw88-dkms-git

I am so sorry sir, actually I was so nervous that time. I apologies :frowning:
Now I am trying your fix.

It shows this error
Error! The module/version combo: rtw88-r219.0f1890b is not located in the DKMS tree.
error: command failed to execute correctly

There might be something wrong with that package...
My last idea is to try with the LTS kernel:

sudo pacman -S linux-lts linux-lts-headers

Of course, every time you install a new kernel make sure you reboot and select the new kernel in the GRUB menu.

Shouldn’t this be moved to issues and not community?

1 Like

I'm getting an error message "500 Internal Server Error" , since the very first moment I saw the topic.
Tried with PC, mobile, ...


It should be fine now, thanks to @dr460nf1r3 :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.