RTL8822bu Wifi adapter shut down when my RAM running out and system used swap

Hi. My external USB wifi adapter shutting down when my RAM running out and system begin use swap file. I meet this error on cachyos too.In dmesg i see the following error:

may 11 19:11:21 noname-ms7e27 kernel: rtw_8822bu 5-1:1.0: failed to get tx report from firmware
may 11 19:11:24 noname-ms7e27 systemd-journald[491]: Under memory pressure, flushing caches.

My garuda-inxi

Kernel: 6.8.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=bfc36042-8f8e-4781-beaa-4e24b4c8225c rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_x11 dm: SDDM
Distro: Garuda base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7E27 v: 1.0 serial: N/A
Mobo: Micro-Star model: PRO B650M-P (MS-7E27) v: 1.0 serial: <filter>
uuid: 91e77887-6e0e-2b1f-a73a-d843ae5ca4e6 UEFI: American Megatrends LLC.
v: 1.50 date: 12/15/2023
Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
Mouse serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: AMD Ryzen 5 7600 socket: AM5 bits: 64 type: MT MCP arch: Zen 4
gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601206
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 6 MiB desc: 6x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 1505 high: 3870 min/max: 400/5170 base/boost: 3800/5150
scaling: driver: amd-pstate-epp governor: powersave volts: 1.3 V
ext-clock: 100 MHz cores: 1: 400 2: 3833 3: 400 4: 3870 5: 3608 6: 400
7: 400 8: 400 9: 400 10: 400 11: 400 12: 3558 bogomips: 91196
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA AD104 [GeForce RTX 4070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
chip-ID: 10de:2783 class-ID: 0300
Device-2: AMD Raphael vendor: Micro-Star MSI driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-4, DP-5,
DP-6, HDMI-A-2, Writeback-1 bus-ID: 10:00.0 chip-ID: 1002:164e
class-ID: 0300 temp: 33.0 C
Display: server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x292mm (20.87x11.50")
s-diag: 605mm (23.82")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: V24FAB-RA
serial: <filter> built: 2022 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
size: 527x293mm (20.75x11.54") diag: 603mm (23.7") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: nvidia inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4070
SUPER/PCIe/SSE2 memory: 11.71 GiB
API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 4070 SUPER driver: nvidia v: 550.78 device-ID: 10de:2783
surfaces: xcb,xlib device: 1 type: integrated-gpu name: AMD Radeon
Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv v: 24.0.6-arch1.2
device-ID: 1002:164e surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.6-arch1.2 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:22bc
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 10:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 10:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.8.9-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.6 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0c:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp12s0 state: down mac: <filter>
Device-2: ASUSTek ASUS USB-AC58 USB Wireless adapter driver: rtw_8822bu
type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:6
chip-ID: 0b05:19aa class-ID: 0000 serial: <filter>
IF: wlp16s0f4u1 state: up mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Local Storage: total: 953.87 GiB used: 267.52 GiB (28.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
model: XPG GAMMIX S11 Pro size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 42BFU6MI temp: 34.9 C scheme: GPT
SMART: yes health: PASSED on: 6d 3h cycles: 31
read-units: 5,427,645 [2.77 TB] written-units: 3,231,504 [1.65 TB]
ID-1: / raw-size: 237.98 GiB size: 237.98 GiB (100.00%)
used: 44.73 GiB (18.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: /boot raw-size: 500 MiB size: 500 MiB (100.00%)
used: 341.2 MiB (68.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-3: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 34 MiB (35.5%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-4: /home raw-size: 237.98 GiB size: 237.98 GiB (100.00%)
used: 44.73 GiB (18.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-5: /var/log raw-size: 237.98 GiB size: 237.98 GiB (100.00%)
used: 44.73 GiB (18.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-6: /var/tmp raw-size: 237.98 GiB size: 237.98 GiB (100.00%)
used: 44.73 GiB (18.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 14.81 GiB used: 14.55 GiB (98.2%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
ID-2: swap-2 type: file size: 16 GiB used: 2.95 GiB (18.4%) priority: -2
file: /swap/swapfile
System Temperatures: cpu: 39.8 C mobo: N/A
Fan Speeds (rpm): N/A
GPU: device: nvidia screen: :0.0 temp: 40 C fan: 0% device: amdgpu
temp: 33.0 C
Memory: total: 16 GiB note: est. available: 14.82 GiB
used: 14.15 GiB (95.5%)
Processes: 409 Power: uptime: 1h 31m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 5.89 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1943 libs: 573 tools: octopi,pamac,paru
Compilers: clang: 17.0.6 gcc: 14.1.1 alt: 13 Shell: garuda-inxi (sudo)
default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-11
Last full system update: 2024-05-11 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Yes
Failed units:

Have you tried rebooting


I just noticed your post, as I was extremely busy yesterday. Just FYI, it is usually best if you are experiencing a WiFi issue to open your help request in the networking sub-forum. I took the liberty of moving your thread there as that is the preferred location.

I would not expect a relatively modern desktop to have issues with running out of RAM with 16 GB present. I install 32GB on any desktop system I build nowadays, but that is more for futureproofing. With Linux I never even come close to using 16GB of RAM.

What programs are you running when you experience these issues?

Could you please run a utility such as top, htop, or psmem to diagnose what is using up all this ram. Please post the top 10 listed users of your systems ram.

Unfortunately, I’m also very busy today. I will try to make some time to check into your issue later on. Have no fear, someone will be here to help you address this abnormal situation before long.

My first suggestion off the top of my head would be to disable WiFi power saving.


After this happens, if you unplug the WiFi adapter and plug another device into that same USB port (a mouse, keyboard, USB stick, whatever), does the new device work?

Many modern motherboards have built-in protection mechanisms to prevent damage to USB ports and connected devices. If a USB port detects an overcurrent condition (i.e., too much power being drawn), it may shut off power to that port to prevent damage to the motherboard or connected devices. It is possible the situation with your memory is just a red herring, and the actual issue is your computer’s power usage is ramping up because you are running a demanding job.

If this is what is happening, double-check that your PSU is up to the task.


In relation to what @BluishHumility already stated, If running through a hub be sure to check the hub and cabling for faults. If using longer, or multiple USB cables to extend your range be sure to check operation on USB2 & USB3 ports directly from your MOBO, (no USB cabling used).


Yes. It doesn’t help

I tried to launch Stable Diffusion XL model with refiner. It is spends all my ram.

Yes. Other usb devices works well. I have Montech Century 650 psu in my computer. It must to satisfied my computer needs

Wow that program is quite the RAM glutton.

Did you try this?

We are not clairvoyant. You need to provide proper feedback to make progress on any issue.


If you haven’t tested the realtek out of kernel driver, I suggest you try installing the rtl88x2bu-dkms-git driver.

Be sure to reboot after the driver installation is complete.

Also be sure to read the configuration file 88x2bu.conf for information on how to change its USB WiFi driver options:

Testing different USB driver options may possibly help with your WiFi adapter’s issues.

Another suggestion that might help troubleshoot this issue is to remove your realtek WiFi dongle, then attach you cell phone via USB cable on the same USB port. Enable USB phone tethering through your phone’s settings utility, then test your internet connection. Once you have established a working internet connection with your phone, start up your RAM gobbling program and test to see if the same thing happens when using your phone for an internet connection.


Sorry for the late reply. Disable powersafe doesn’t worked. Changing driver to rtl88x2bu-dkms-git solved problem, but wifi adapter doesn’t see 5Hz networks anymore

Try some different kernels such as linux, linux-lts, linux-hardened, and possibly others.

Test adding the different driver options as I suggested on my last post.

Have you searched the forum and the internet for “Arch Linux realtek wifi can’t see 5Ghz” or similar terms?


Yes. But haven’t found a solution yet. In any case, this seems to be a driver problem and not a system problem. I’ll try to write to Github of driver developer

1 Like

I’m thinking your search could have been a little more thorough.

Below is the usual fix:


Thank you. I changed channel to 40 on router and it is worked


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.