[RTL8822bu] How do I install archer T3u Drivers on a desktop PC?

garuda-inxi: System:Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 - Pastebin.com

I would to install the drivers needed for this device

For info on your wifi chip and driver see here:

From the Chaotic AUR install the package below:


After the driver is installed, run the command below in terminal:

echo "blacklist rtw88_8822bu" | sudo tee /etc/modprobe.d/rtw8822bu.conf


I altered your thread title to include your Wifi model as you posted your garuda-inxi on an external link. Hope you don’t mind.


How do I install from chaotic aur?

You can use the GUI installer Octopi as you are using KDE, or pacman from the terminal:


1 Like

what’s it called in octopi?

what’s the package name?

see post #2 by tbg


Just FYI, I closed your other help request on this same topic from a few days ago. Please do not repeatedly make help requests on the same issue. The policy here is, one issue, one thread.

A thread may be auto-locked if no one has replied within our forum’s specified time limits. Even if this were to occur in the future, the best way to continue discussion of your problem is to message a moderator to reopen your original help thread. This helps to ensure there is always a continuity of assistance on a single thread. In the future please adhere to our forum’s policy of one thread per help request.



the sudo part of the command won’t launch

Sorry, but without seeing the input and output of the command run, it never happened (according to the forum assistant’s rule book). :wink:

You need to post both the input and the output of any command you run.


cp and paste, did work here

╭─[email protected] in ~ took 1m18s
╰─λ echo "blacklist rtw88_8822bu" | sudo tee /etc/modprobe.d/rtw8822bu.conf
[sudo] password for veitw:         
blacklist rtw88_8822bu

 ╭─[email protected] in ~ as 🧙 took 5s
 ╰─λ cat /etc/modprobe.d/rtw8822bu.conf 
File: /etc/modprobe.d/rtw8822bu.conf
blacklist rtw88_8822bu

1 Like

Works for me too. :man_shrugging:

$ echo "blacklist rtw88_8822bu" | sudo tee /etc/modprobe.d/rtw8822bu.conf
[sudo] password for htpc:         
blacklist rtw88_8822bu
htpc@htpc2: /home/htpc 
Fri Nov 24 04:23 PM 
$ cat /etc/modprobe.d/rtw8822bu.conf
blacklist rtw88_8822bu

This is all that happens.

╰─λ echo “blacklist rtw88_8822bu” | sudo tee /etc/modprobe.d/rtw8822bu.conf
[sudo] password for steamrex25:
blacklist rtw88_8822bu

yup, you just created a conf file that prevents the kernel from loading the driver module that comes with the kernel, but because it just doesn’t work with your specific model it had to be blacklisted.
If you’ve followed tbg’s post #2 instruction you surely have installed the git driver
already ? for example by

sudo pacman -S rtl88x2bu-dkms-git

If not, do it now and then reboot.


On another topic @Steamrex25, why are you not simply using the Intel Wifi on your mobo.

Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 29:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlo1 state: up mac:

The onboard wifi adapter’s state is reported as up, so it should be functional. If the connection is flaky the Intel iwlwifi driver has quite a few options that can be applied to help improve its performance.

I was simply curious why you would want to use a Realtek USB adapter that requires installation of out of kernel drivers, when you have an Intel adapter with in-kernel driver support of comparable speed?

1 Like

The speed of my Mobo wifi is trash, the usb adapter has better speeds

idk how to fix the speeds

Let’s not worry about that separate issue ATM.

Did you get the driver I recommended installed and then rebooted?

1 Like

yes I did

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.