[RTL8821CE] cannot connect to wifi

Hello.

iwconfig
lo        no wireless extensions.

enp2s0f3u4  no wireless extensions.

please help me to solve it

Please post you inxi -Faz as requested in (and deleted from) the template.

4 Likes
inxi -Faz
System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=81a0db31-04a1-4fa8-b9d9-e159d68d3c51
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=3b94d816-ac38-4ab7-b95c-3c298f115565 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_D509DA v: 1.0 serial: <filter>
Mobo: ASUSTeK model: X509DA v: 1.0 serial: <filter> UEFI: American Megatrends v: X509DA.308
date: 03/29/2021
Battery:   ID-1: BAT0 charge: 27.2 Wh (100.0%) condition: 27.2/32.1 Wh (85.0%) volts: 7.8 min: 7.8
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging cycles: 48
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33535
Speed: 1685 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1685 2: 1393
3: 1996 4: 2486 5: 1659 6: 2213 7: 1582 8: 1230
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 02:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 3-2.2:5
chip-ID: 13d3:5a11 class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.42.0 5.14.14-zen1-1-zen LLVM 12.0.1)
v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: snd_pci_acp3x v: kernel
alternate: snd_rn_pci_acp3x bus-ID: 02:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave
driver: N/A modules: rtw88_8821ce port: f000 bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF-ID-1: enp2s0f3u4 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 3-2.1:4
chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 3.86 TiB used: 27.94 GiB (0.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS240G2G0B-00EPW0 size: 223.58 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10SPZX-80Z10T2 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A04 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD30NPZZ-00PDPT0
size: 2.73 TiB block-size: physical: 4096 B logical: 4096 B type: HDD rpm: 5400
serial: <filter> scheme: MBR
Partition: ID-1: / raw-size: 216.05 GiB size: 216.05 GiB (100.00%) used: 27.94 GiB (12.9%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 216.05 GiB size: 216.05 GiB (100.00%) used: 27.94 GiB (12.9%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 216.05 GiB size: 216.05 GiB (100.00%) used: 27.94 GiB (12.9%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 216.05 GiB size: 216.05 GiB (100.00%) used: 27.94 GiB (12.9%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.23 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
ID-2: swap-2 type: zram size: 3.29 GiB used: 1.28 GiB (38.9%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 90.0 C mobo: N/A gpu: amdgpu temp: 90.0 C
Fan Speeds (RPM): cpu: 3600
Info:      Processes: 298 Uptime: 46m wakeups: 1 Memory: 3.29 GiB used: 2.34 GiB (71.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2106 lib: 395
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Hello root programmer

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

help

3 Likes

Is this a new installation or an existing system?
I have the same WiFi chip and for me the kernel module works fine.
Some others had troubles and there could be at least one alternative driver in the AUR repository.
First try
sudo modprobe rtw_8821ce
to see if the kernel module comes up.
Try also to check
rfkill list
Just in case there is a hw or sw lock ...

2 Likes

yes, new installation.

sudo modprobe rtw_8821ce
[sudo] password for zamaan:
modprobe: FATAL: Module rtw_8821ce not found in directory /lib/modules/5.14.14-zen1-1-zen

╭─[email protected] in ~ took 17s
[🔴] × rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

Maybe you could try with the driver and procedure used here

3 Likes

Okay let me try. I'll let you know what happened. :heart:

It should work.
It is also suggested in the Arch wiki for your model.
https://wiki.archlinux.org/title/Laptop/ASUS#Vivobook

1 Like

Sometimes the manufacturers modules intended for Windows can interfere with WiFi on Linux. You might want to try rmmodding the assus-wlan module along with all wifi driver modules (whichever wifi modules that are loaded). Once you have completed the rmmod of those modules, then modprobe the wifi driver module you want to use.

You can enter man rmmod or man modprobe for details on those commands usage. The lsmod command will show you your modules that are loaded.

2 Likes

Hello. You need driver. Install this from aur (AUR (en) - rtl8821ce-dkms-git)

1 Like

SLOVED by @filo :heart:

It's working. Just had to install rtl8821ce-dkms-git package by AUR helper.

THANK YOU SOOO MUCH, BRO, YOU ARE AWESOME :heart:

1 Like

THANKS :heart:
YES, I JUST SAW YOUR CMNT AFTER SOLVING IT.
YOU ARE AWESOME TOO! :heart:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.