RTL8192EU - TP-LINK TL-WN822N wireless adapter not working

I installed Garuda Linux and tried to connect to wifi . After several minutes of waiting i got a notification <Wireless Interface (wlp0s20f0u1)
The WiFi network could not be found >
My wireless adapter: TP-Link TL-WN822N Version 4 RTL8192EU
Is there any solution ?

https://aur.archlinux.org/packages/8192eu-dkms/

Just download the snapshot and see what happens :wink:

1 Like

I installed it , rebooted and nothing changed

I'm sorry, I can't help you, as I am unfamiliar with W-LAN problems and never had to deal with them.
You have to wait for someone competent to take care of your problem.
Have you already scoured the forum and Archwiki?

1 Like

You could read this solved thread _

https://bbs.archlinux.org/viewtopic.php?id=223033

2 Likes

yes, i did

Good job. Now you're going to have to wait for more expert users - they'll be along, so be patient. :slightly_smiling_face:

You have given an expert's advice, so you tend to becoming an expert :wink:

An expert is one that knows what he doesn't know and is just capable of RTFMing and DDGing
Words of @petsam wisdom :joy:

5 Likes

"An expert is a person who knows more and more about less and less, until - in the end - they know everything about nothing." - @Stroke_Finger (Norm!) wisdom-isms.

We are both painfully aware I am that type of 'expert', my friend! :rofl:

2 Likes

Maybe there's something wrong with the commands I used . I'm not an advanced user . Btw after cloning into it I used cd 8192eu-dkms then sudo dkms add . and sudo dkms install

I'm sorry, I am of very limited help. Wait for others. :slightly_smiling_face:

If a crack takes care of your cause, he will most likely ask you for your inxi -Fxxxza output as text. Get ahead of him. :slightly_smiling_face:

2 Likes

Installing AUR packages is done easily with an AUR helper like paru or trizen.
For example

paru 8192eu-dkms

You only need to be a normal user. Without reading any theory or instructions of usage, then you will learn from your mistakes. That's the ultimate rule.
You have to decide how you will go :wink:

4 Likes

You should always post your specs on a wifi help request first thing. Your manufacturers model number is irrelevant as they can change the wifi chip used inside without any notice. What is always required is your wifi's chip ID,.

Please post:

inxi -Fxxxza

Post this even if your issue is resolved for others benefit.

Be sure to disable MAC Address randomization. After doing so reboot both your computer and router.

And as @petsam has already mentioned, do not git clone the driver, use an AUR helper such as he listed or yay or pamac to install the driver.

This command should work without the need to install a separate AUR helper:

pamac build 8192eu-dkms

Only install this driver if it corresponds to the chip ID returned from the inxi command. This model from tp-link has also used the RTL8192CU chip in the past (so be sure to check and provide your chip ID). You must install the correct driver corresponding to the chip ID from the AUR.

If your wifi still doesn't work on your current kernel after installing the driver then install and test the linux-lts kernel.

6 Likes
inxi -Fxxxza output : System:
  Kernel: 5.10.4-107-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive 
  BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=3b89e06b-a36d-4a0d-9634-d3e7f83814f0 rw [email protected] 
  quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Garuda Linux 
Machine:
  Type: Desktop System: Turbo-X product: SK90 v: 1.0 serial: <filter> 
  Mobo: Micro-Star model: H310M_Pro_VH_Plus v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: 1.50 date: 01/07/2020 
CPU:
  Info: Quad Core model: Intel Core i3-9100F bits: 64 type: MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) 
  stepping: B (11) microcode: DE L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28828 
  Speed: 2145 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2145 2: 3600 
  3: 3601 4: 3601 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 460.27.04 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:128b 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1680x1050 s-dpi: 99 s-size: 431x272mm (17.0x10.7") 
  s-diag: 510mm (20.1") 
  Monitor-1: VGA-0 res: 1680x1050 hz: 60 dpi: 98 
  size: 434x270mm (17.1x10.6") diag: 511mm (20.1") 
  OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 460.27.04 
  direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0e0f 
  Sound Server: ALSA v: k5.10.4-107-tkg-bmq 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: TP-Link TL-WN822N Version 4 RTL8192EU type: USB 
  driver: rtl8xxxu bus ID: 1-1:6 chip ID: 2357:0108 serial: <filter> 
  IF: wlp0s20f0u1 state: down mac: <filter> 
  IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 223.57 GiB used: 6.79 GiB (3.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: TeamGroup model: T253LE240G 
  size: 223.57 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: BB.3 
Partition:
  ID-1: / raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 6.79 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 6.79 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 6.79 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-5: /var/tmp raw size: 223.27 GiB size: 223.27 GiB (100.00%) 
  used: 6.79 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 967.6 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 967.6 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 967.6 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 967.6 MiB used: 0 KiB (0.0%) 
  priority: 32767 dev: /dev/zram3 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:
  Processes: 198 Uptime: 5m wakeups: 0 Memory: 3.78 GiB 
  used: 2.47 GiB (65.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1161 lib: 276 Shell: fish v: 3.1.2 running in: konsole 
  inxi: 3.2.01

How can I do that?

This is not a common term that can be easily misinterpreted by a search engine. Users incapable of inputing a suggestion into a search engine and performing a rudimentary search for themselves may be suffering from overinflated expectations and an underwhelming level of self motivation.

I already provided a very large amount of information for you on my last post. Are you not capable of searching for directions yourself. If not, perhaps Garuda is not for you, as we do not believe in spoon feeding users the answer for every question. Users are expected to do some research for themselves.

3 Likes

I did a research before and I spent a large amount of time . That's why i asked for help , but ok . I'll try to be a less spoon feeding user next time or probably use a beginner distro again . Thanks for replying to my problem !

1 Like

Glad you figured it out, but if you couldn't find that info you need to brush up on your search skills. There is no shortage of info on this topic.

A Google search will provide more hits than I care to count:

Arch Linux disable MAC Address randomization - Google Search..

Even the Garuda forum in its short existence has many hits for this term as it is a frequent suggestion and solution:

https://forum.garudalinux.org/search?context=topic&context_id=7056&q=Disable%20MAC%20Address%20randomization%20&skip_context=true

This solution is so common it is even baked right into the Garuda Network Assistant by default. You can simply toggle MAC randomization on/off through that utility if you want.

I don't go out of my way to be mean, but it can get very frustrating when an easily searched issue is required to be repeated constantly.

Glad you found your answer, and welcome to Garuda.

3 Likes