RTL8192eu - Fresh install, cannot get wi fi to work

Edit: Forgot greeting you people :smiley:
Hello this place looks nice!

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=80343442-7c16-4057-a189-0f561ed24e1c rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=9ce08bf3-2e28-49af-8a3e-82c102e47087 loglevel=3
Desktop: KDE Plasma 5.23.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop Mobo: MSI model: Z170A PC MATE (MS-7971) v: 2.0 serial: <filter> UEFI: American Megatrends v: A.G0
date: 06/23/2018
CPU:       Info: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S family: 6 model-id: 5E (94)
stepping: 3 microcode: EA cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27999
Speed: 3642 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3642 2: 3691 3: 3648 4: 3746
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1912
class-ID: 0380
Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: ZOTAC driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:13c2
class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5")
Monitor-1: DVI-I-1 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x269mm (18.8x10.6") diag: 548mm (21.6")
OpenGL: renderer: NV124 v: 4.3 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:0fbb class-ID: 0403
Device-3: Samson C01U Pro condenser microphone type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:4
chip-ID: 17a0:0303 class-ID: 0300
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel
port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: TP-Link TL-WN822N Version 4 RTL8192EU type: USB driver: rtl8xxxu bus-ID: 1-6:5 chip-ID: 2357:0108
class-ID: 0000 serial: <filter>
IF: wlp0s20f0u6 state: down mac: <filter>
IF-ID-1: enp0s20f0u3 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth: Device-1: Samsung Galaxy series misc. (tethering mode) type: USB driver: rndis_host v: kernel bus-ID: 1-3:3
chip-ID: 04e8:6863 class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:    Local Storage: total: 1.24 TiB used: 20.44 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: OCZ model: TRION100 size: 111.79 GiB block-size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 11.2 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Transcend model: TS240GSSD220S size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 5F8 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD10EZEX-22BN5A0 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: GPT
Partition: ID-1: / raw-size: 95.48 GiB size: 95.48 GiB (100.00%) used: 20.43 GiB (21.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 95.48 GiB size: 95.48 GiB (100.00%) used: 20.43 GiB (21.4%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 95.48 GiB size: 95.48 GiB (100.00%) used: 20.43 GiB (21.4%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 95.48 GiB size: 95.48 GiB (100.00%) used: 20.43 GiB (21.4%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.05 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 14.59 GiB used: 2.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 41.5 C mobo: 29.8 C gpu: nouveau temp: 42.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 814
Info:      Processes: 218 Uptime: 10m wakeups: 0 Memory: 14.59 GiB used: 3.03 GiB (20.8%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1738 lib: 514 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: yakuake inxi: 3.3.07

When I try to connect any network: after entering password, it stays in "configuring interface" for a while then "wireless interface (wlp0s20f0u6)" error pops up "The WiFi network could not be found". I tried both home wi-fi and mobile hotspot. Wired hotspot is working. I use a tp-link external wifi adapter.

Any idea why?

Also: Update function not working in Garuda Assistant. Terminal returns: "/bin/bash: line 1: update: command not found"

Edit 2: I tried restarting wi-fi module and selecting 2.4 / 5 GHz methods found in some other posts.

Edit 3: Thank you for updating the title.

Hi there, welcome.
Have you already tried disabling MAC address randomization and IPv6?

Will try everything suggested in the morning. I need to sleep now. Thank you for the answer
btw how to do those :confused:

You can disable MAC address randomization from the Garuda Network Assistant, IPv6 from Advanced Network Configuration / Network Connections.

did not work :frowning:

First you could try installing some other kernels, using the ethernet connection and Garuda setting manager, eg the linux-lts.
You might also try installing this driver from AUR, although I'm a bit skeptical, because some comments are negative and it seems a bit old.
But it could be worth trying...
paru 8192eu-dkms

Is that a terminal command to install the driver?

Please show some effort to try to learn.
Search on the internet for terms, suggestions given, etc...
Otherwise it will get tough.

This is me trying to learn :frowning: Used only ubuntu zorin elementary up until now. Got my hands on a arch based distro for the fisrst time after seeing Garuda on suggestion lists. It really is different what I experrienced earlier. Solved some problems on my own but this one proved to be handfull. Will try suggestions in the morning and if I am unable to solve things. I will return to my confort zone. Thank you so much for replying as a dev for the os.

I fully understand. I'm everything but a dev :wink:.
I fell in love with this distro because it helped me to learn a lot of things... It really opened a new world.
If you manage to exit that comfort zone you'll find a lot of fun. And it will be a one-way out... :muscle:



sudo pacman -S 8192eu-dkms


sudo echo -e "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu_blacklist.conf


Also, the changes @filo recommended usually require you to reboot both your router and computer for any improvement to take effect.


This topic was automatically opened after 4 hours.

I am back from work going to try these.

Edit: Now the pc wont even detect external wi fi adapter lol.
Thank you for the reply though.

The blacklist blocks the kernel module from loading. If your adapter is not being detected after creating that blacklist, then you likely don't have the proprietary driver installed properly.

This is all conjecture of course because you have provided no outputs from the driver installation or regarding which realtek modules you have loaded. Without this information it is pretty hard to guess what is going on.

Please post the output of:

lsmod | sort

can you instead recommend a cheap wifi adapter that can be found in most countries? I live in Turkey therefore it may be unavailable. I don't want to bother you people anymore and never liked this adapter anyways.

Yes, that is a very problem prone adapter. I personally would suggest an Intel based adapter so that you don't have to mess with installing drivers. Intel's drivers are all open source and included in the kernel.


thank you for your answers will look for an intel one on payday!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.