Root in File Manager: No longer able to open

I used to be able to open files in my manager as the root by right clicking on the context menu and selecting from the root options: Open in file manager, but now as soon as I enter my password, nothing happens anymore and it doesn't open at all nor do any of the root actions from the context menu no longer work!

I think I've messed something up. Is there a package I could reinstall to get Dolphin to do this function again?

I am still somewhat new to Linux.

inxi output:

System:
Kernel: 6.1.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e0e527e8-421a-4af0-b5ff-e25e575c66ad rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=2f90342f-aae6-4ec2-b185-7f46e006503b loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450I GAMING PLUS AC (MS-7A40) v: 2.0
serial: <superuser required> UEFI: American Megatrends v: A.C0
date: 06/11/2020
CPU:
Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ gen: 2
level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3880 high: 3900 min/max: N/A cores: 1: 3900 2: 3900
3: 3900 4: 3900 5: 3900 6: 3900 7: 3900 8: 3900 9: 3582 10: 3900 11: 3900
12: 3900 13: 3900 14: 3900 15: 3900 16: 3900 bogomips: 124796
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X] vendor: Micro-Star MSI
driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
active: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 29:00.0 chip-ID: 1002:67ff
class-ID: 0300 temp: 33.0 C
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-5.1.2.3:9 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: right
model: ViewSonic VX2252 Series serial: <filter> built: 2020 res: 1920x1080
hz: 60 dpi: 102 gamma: 1.2 size: 477x268mm (18.78x10.55")
diag: 547mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: AOC 2752H
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon RX 560 Series
(polaris11 LLVM 14.0.6 DRM 3.49 6.1.1-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: Micro-Star MSI driver: snd_hda_intel bus-ID: 1-5.1.2.3:9 v: kernel
pcie: chip-ID: 046d:0825 class-ID: 0102 gen: 3 speed: 8 GT/s
serial: <filter> lanes: 8 bus-ID: 29:00.1 chip-ID: 1002:aae0
class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
Device-4: Kingston HyperX 7.1 Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:2 chip-ID: 0951:16a4
class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.1.1-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 26:00.0
chip-ID: 8086:24fb class-ID: 0280
IF: wlp38s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-8:6 chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 2.73 TiB used: 1.3 TiB (47.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 023 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO M.2 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
Partition:
ID-1: / raw-size: 327.7 GiB size: 327.7 GiB (100.00%)
used: 139.1 GiB (42.4%) fs: btrfs dev: /dev/sdb7 maj-min: 8:23
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/sdb6 maj-min: 8:22
ID-3: /home raw-size: 327.7 GiB size: 327.7 GiB (100.00%)
used: 139.1 GiB (42.4%) fs: btrfs dev: /dev/sdb7 maj-min: 8:23
ID-4: /var/log raw-size: 327.7 GiB size: 327.7 GiB (100.00%)
used: 139.1 GiB (42.4%) fs: btrfs dev: /dev/sdb7 maj-min: 8:23
ID-5: /var/tmp raw-size: 327.7 GiB size: 327.7 GiB (100.00%)
used: 139.1 GiB (42.4%) fs: btrfs dev: /dev/sdb7 maj-min: 8:23
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 3.34 GiB (10.7%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb5 maj-min: 8:21
Sensors:
System Temperatures: cpu: 42.2 C mobo: N/A gpu: amdgpu temp: 34.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1307
Info:
Processes: 466 Uptime: 8h 6m wakeups: 0 Memory: 31.29 GiB
used: 7.28 GiB (23.3%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 1869 libs: 569 tools: octopi,paru,yay Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-12-31
Last full system update: 2022-12-31 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

I,ve edited your post to include

garuda-inxi

to make it more readable

First I would reboot and see if it is still happening.

1 Like

I rebooted! Now I'm getting an error as I try and perform the actions from the context menu: Could not find the program 'rootactions-servicemenu.pl'

A bit of background: When I first saw that the context actions did nothing, I tried to go into settings> configure dolphin > context menu > download new services > search > and I found one called Root Actions Servicemenu and I installed that, but it didn't seem to help, unfortunately.

Is there a way I could reset it back to how it used to work?

Yes reboot into an earlier snapshot before you installed it

1 Like

No luck...

I rolled back like you suggested, but I'm back to the original problem where I just has a dead root context menu.

I don't have that many snapshots back, so I must have dissected something before this. Is there a package I'm missing that gives me this functionality, to open something as root in the file manager?

Try to reinstall kde-servicemenus-rootactions
If not helping reinstall dolphin-plugins.
Finally try reinstalling Dolphin.

1 Like

I think I may have fixed it...

First of all, the one I got from KDE didn't work. Reinstalling Dolphin did not work either, I was still left with a broken context menu. I decided to dig a bit deeper.

When Garuda was first installed upon my system it came with a package called rootactions-servicemenu (This was not by KDE, it seems.)

I looked into an old virtual machine running Garuda and noticed that it was installed by default, however, on my main system, when I tried to add this package, it said that it couldn't find it. Is there anyway to get information about this package that Garuda installed by default?

Anyways, digging even further, a package that I needed could have been removed by accident, so I went to: AUR (en) - rootactions-servicemenu-git and installed it with yay. Functionality to the root menu soon returned afterwards, thankfully.

It's strange, though, I can't find any trace of the original package that was on the machine by default (rootactions-servicemenu)

1 Like

If you were curious, this is what I'm looking at, from a fresh install from my VM running Garuda:

╰─λ pacman -Q --info rootactions-servicemenu
Name : rootactions-servicemenu
Version : 2.7.3-1
Description : Allows admin users to perform several root only actions from dolphin via polkit agent developed by
Architecture : any
URL : https://netrunner.com
Licenses : GPL
Groups : None
Provides : None
Depends On : dolphin kdialog perl polkit
Optional Deps : kate [installed]
Required By : None
Optional For : None
Conflicts With : kde-servicemenus-rootactions
Replaces : None
Installed Size : 92.56 KiB
Packager : Chaotic-AUR Wild Bear Node [email protected]
Build Date : Sun 20 Feb 2022 08:35:08 AM EST
Install Date : Tue 18 Oct 2022 10:15:31 PM EDT
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Any ideas what that could be and if I could get it back?

I seem to have this package installed, but it does say * Package not found in repositories/AUR * under the description.

In my case, the right-click root actions are working normally. There is a KDE Polkit popup, then I enter my password and it does whatever the root action is.

I think Filo is right, this package may have been replaced by kde-servicemenus-rootactions. Do you have kdesu installed? I believe it is needed for these packages to work properly.

pacman -Ss kdesu
extra/kdesu 5.101.0-1 (kf5) [installed]
    Integration with su for elevated privileges
3 Likes

That's odd. I wonder where that package could have come from then.

I did a reinstall of both the kdesu and kde-servicemenus-rootactions packages, but they still seem broken, so I had to go back to the package I found on the AUR using yay ( servicemenus-rootactions-git )

Is there any other way to find out information about this mystery package so I could get it back then?

Actually, I wonder if the package even exists anymore, seeing as how that came with my Garuda image.

Should be this one (see also linked upstream site):
https://aur.archlinux.org/packages/rootactions-servicemenu-git
If I remember correctly, this package was kind of replaced by the kde- version because it was not considered "secure", meaning that it allowed to execute actions protected by design, while the KDE version should be less "open". You should be able to find some discussions about it also in the forum.
Eg (just a quick search...):

3 Likes

It was a security risk? That explains why it just disappeared then...

It's interesting to note that the author here has said that the package, kde-servicemenus-rootactions doesn't work: https://store.kde.org/p/998469 , he admits that the actions to open the folder as root are amongst the known issues right now. Even if I did want to use that one, it looks like I'm out of luck until a fix is published.

Fortunately, I can just swap them out easily, no worries.

Thank you for helping me with this, guys. Have a happy new year!

2 Likes

If you really need to use a root capable file explorer, then I would highly recommend the TUI app Midnight Commander. It is a dual pane file explorer reminiscent of the old Norton Commander utility from days of yore. It has full mouse support. It even has double click mouse functionality that allows you to easily browse through the file directory hierarchy.

There is no better tool than MC for performing root file manipulations. Super powerful (with its own built in editor), yet as easy and straightforward as a GUI file explorer to use. I find the stock MC skins ugly as sin, but there are much more beautiful skins available for download to tune it exactly to your liking.

I can't recommend Midnight Commander highly enough, it is the best tool of its kind IMO. It has saved my ass many times in tough situations.

4 Likes

A user can open and edit any root-owned file, but may need the root passwd to save and close. That's as Gawd intended it, anyway. You weeny-assed poseurs. :wink: :rofl:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.