RGB issues on new laptop (ASUS Zenbook Pro Flip 15)

Hello, I just bought a new laptop it’s an Asus Zenbook Pro flip 15.
The install went very well with only a few minor issues that I was able to fix within a few minutes. Unfortunately, the one thing that’s been difficult to fix is I would like to be able to change the RGB colors of the keyboard.

I have tried all the fixes I could find online, I tried OpenRGB, supergfxctl, Asusctl, and several other fixes mentioned online.

Unfortunately nothing has worked. It’s obviously not a huge issue but it’s the only thing that’s not working flawlessly. Any help would be greatly appreciated!
Thank you!

  Kernel: 6.9.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=96d2f8d1-3941-4838-9d38-5b2aca7dfcad rw rootflags=subvol=@
    quiet resume=UUID=77d5c38a-605b-4162-8d9a-62b27db75c49 loglevel=3 ibt=off
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.42 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 46.0 Distro: Garuda base: Arch Linux
  Type: Convertible System: ASUSTeK product: Zenbook UP6502ZD_Q539ZD v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UP6502ZD v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: UP6502ZD.312
    date: 11/28/2023
  ID-1: BAT0 charge: 64.7 Wh (100.0%) condition: 64.7/96.0 Wh (67.4%)
    volts: 12.9 min: 11.7 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: full cycles: 43
  Device-1: hid-0018:04F3:2F09.0001-battery model: ELAN9008:00 04F3:2F09
    serial: N/A charge: N/A status: N/A
  Device-2: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x433
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 410 high: 604 min/max: 400/4600:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 400 8: 400 9: 604 10: 400 11: 400 12: 400 13: 400 14: 400
    15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 bogomips: 107520
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
    built: 2021-22+ ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: Intel DG2 [Arc A370M] vendor: ASUSTeK driver: i915 v: kernel
    alternate: xe arch: Gen-12.7 code: Alchemist process: TSMC n6 (7nm)
    built: 2022+ bus-ID: 0000:04:00.0 chip-ID: 8086:5693 class-ID: 0380
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-9:3 chip-ID: 13d3:5497
    class-ID: fe01 serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Samsung 0x416e built: 2021 res: 2880x1620 dpi: 213
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 2880x1620
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: iris device: 2 drv: swrast gbm: drv: iris surfaceless:
    drv: iris wayland: drv: iris x11: drv: iris
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a6 memory: 14.95 GiB unified: yes display-ID: :0.0
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
    Graphics (ADL GT2) driver: mesa intel v: 24.0.7-arch1.3
    device-ID: 8086:46a6 surfaces: xcb,xlib,wayland device: 1
    type: discrete-gpu name: Intel Arc A370M Graphics (DG2) driver: mesa intel
    v: 24.0.7-arch1.3 device-ID: 8086:5693 surfaces: xcb,xlib,wayland
    device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits)
    driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM 17.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel, snd_soc_avs,
    snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
    class-ID: 0401
  API: ALSA v: k6.9.1-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
    lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0000
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 1.05 TiB used: 145.52 GiB (13.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM001TD3JX013N
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 41000C20 temp: 33.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 model: N/A size: 117.19 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: 3.00 scheme: MBR
  ID-1: / raw-size: 936.73 GiB size: 936.73 GiB (100.00%)
    used: 121.95 GiB (13.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.73 GiB size: 936.73 GiB (100.00%)
    used: 121.95 GiB (13.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 936.73 GiB size: 936.73 GiB (100.00%)
    used: 121.95 GiB (13.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 936.73 GiB size: 936.73 GiB (100.00%)
    used: 121.95 GiB (13.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.3 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.84 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: N/A mobo: N/A
  Fan Speeds (rpm): cpu: 2900
  Memory: total: 16 GiB note: est. available: 15.3 GiB used: 3.36 GiB (21.9%)
  Processes: 440 Power: uptime: 24m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.11 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1694 libs: 569 tools: gnome-software, octopi,
    pamac, paru Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish
    v: 3.7.1 running-in: gnome-terminal inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-17
  Last full system update: 2024-05-18
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:   </kbd> ```

Hi there, welcome to the forum.
Try to give a look at this article (i’m pointing to the gnome chapter but a general reading could help)
I guess your model is quite new, or anyway not listed here
There is only a suggestion for another model (kernel boot parameters), but I think it’s too old stuff.
Good luck!


Hi, I actually went through the website followed all instructions and downloaded the apps but they don’t seem to work for my machine. Maybe because I’m not running a ROG pc? It’s possible i’m doing something wrong or missing something but I couldn’t get it to work.

yea, I did try that but I couldn’t get it to work. But Thank you for the reply!

1 Like

Your laptop has a “1-zone RGB” keyboard - neither on the Asus homepage, nor in the manual, nor in the reviews is there anything about the fact that the color of the keyboard can be changed. On the contrary, I only find statements like this about your laptop: “Keyboard lights don’t change color”.

Are you sure this can be adjusted?

1 Like

What happens when you give this command?
asusctl led-mode static -c 0000ff

Thanks for mentioning this. I’ll give it a spin and see if it can enhance my Zenbook experience.

1 Like

I’m pretty sure it can be modified. I only had windows on it long enough to install Garuda but I remember it being different than this yellow/green it is now,.


The Asus Zenbook Pro 15 Flip OLED features a single-zone RGB keyboard backlight that can be customized. The keyboard also has a NumberPad. The hinge automatically lifts the rear of the laptop when the screen is opened, tilting the keyboard for better ergonomics.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.