Resolution stuck at 1024x768 +Super lags [Garuda super noob]

You booted onto a Wayland session. Try x11 (you can select it in the login screen), or with Wayland use the kernel boot parameter suggested here (maybe use the Garuda Boot Assistant, or micro as our default terminal editor instead of nano):

You don’t have that driver problem. This is just to explain what parameter to setup, how and why.