Resizing partition option greyed out|dualbooting garuda/windows

System:
  Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a5cf564e-a3a3-46ec-885a-2a124386f2d8 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: GNOME v: 42.4 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Razer product: Book 13 - RZ09-0357 v: 0.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Razer model: MA310 v: 4 serial: <superuser required> UEFI: Razer
    v: 2.00 date: 11/20/2020
Battery:
  ID-1: BAT0 charge: 57.1 Wh (100.0%) condition: 57.1/55.2 Wh (103.4%)
    volts: 13.1 min: 11.6 model: Razer Blade type: Unknown serial: <filter>
    status: full
CPU:
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2649 high: 2800 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2399 2: 2800 3: 2400
    4: 2800 5: 2400 6: 2800 7: 2800 8: 2800 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Razer USA
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 13d3:5447 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 model: Sharp LQ134N1JW48 built: 2020 res: 1920x1200
    hz: 60 dpi: 169 gamma: 1.2 size: 288x180mm (11.34x7.09")
    diag: 340mm (13.4") ratio: 16:10 modes: 1920x1200
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Razer USA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 238.47 GiB used: 13.84 GiB (5.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: NVMe CA5-8D256 size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: CQ20904 temp: 33.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 13.79 GiB
    (35.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 51 MiB
    (53.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /home raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 13.79 GiB
    (35.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 13.79
    GiB (35.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 13.79
    GiB (35.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.39 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 335 Uptime: 1m wakeups: 1 Memory: 15.39 GiB used: 2.33 GiB
  (15.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 Packages: pacman: 1253 lib: 341 Shell: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-08-20
  Last full system update: 2022-08-21
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

Hello, i have been using garuda for a couple of days now and have given garuda 40GB of disk space just to try it out, as I really like it, I would like to make the partition bigger. it was no problem to make the windows partition smaller, but the option to resize the partition is always greyed out. I have tried using the windows disk manager, the disk manager in the installed instance of garuda and off a live usb stick, but I cant make the partition bigger. any help would be appreciated.

Welcome to the community @cromyl. :slightly_smiling_face:

Your post has been edited to use code formatting, which you can apply to terminal output by adding three tildes (~) before and after the output
~~~
like this.
~~~

Can you enter sudo parted /dev/nvme0n1 (I am assuming that is the disk) and post the output of print into the thread so we can take a look at how the disk is setup?

Also post the output of lsblk -f.

3 Likes
Model: NVMe CA5-8D256 (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.3GB  17.3GB  ntfs         Basic data partition          diag
 2      17.3GB  17.4GB  105MB   fat32        EFI system partition          boot, esp
 3      17.4GB  17.4GB  16.8MB               Microsoft reserved partition  msftres
 4      17.4GB  161GB   143GB   ntfs         Basic data partition          msftdata
 5      213GB   255GB   41.9GB  btrfs        root                          hidden
 6      255GB   256GB   1049MB  ntfs         Basic data partition          hidden, diag
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
     squash 4.0                                                    0   100% /var/lib/anbox/rootfs
zram0
                                                                            [SWAP]
nvme0n1

β”œβ”€nvme0n1p1
β”‚    ntfs         Recovery
β”‚                       A83AF6553AF6204C
β”œβ”€nvme0n1p2
β”‚    vfat   FAT32 SYSTEM
β”‚                       54F8-1A6A                                45M    53% /boot/efi
β”œβ”€nvme0n1p3
β”‚
β”œβ”€nvme0n1p4
β”‚    ntfs         Book 13
β”‚                       6A12F89712F86989
β”œβ”€nvme0n1p5
β”‚    btrfs              a5cf564e-a3a3-46ec-885a-2a124386f2d8   23.8G    35% /var/lib/anbox/rootfs/data
β”‚                                                                           /var/lib/anbox/rootfs/cache
β”‚                                                                           /var/tmp
β”‚                                                                           /var/log
β”‚                                                                           /var/cache
β”‚                                                                           /srv
β”‚                                                                           /root
β”‚                                                                           /home
β”‚                                                                           /
└─nvme0n1p6
     ntfs         Winre C684F8EA84F8DDBD

here are the outputs

You need to boot from USB and move your Garuda partition to left before growing it.

2 Likes

what is meant by "moving to left"?

You cannot expand a partition "to the left", in other words the expansion has to be from the end of the partition instead of the beginning. In your case, the unused space is located at the "beginning" end of the partition (between 161 GB and 213 GB):

So first you need to move the entire p5 partition so the beginning of the partition is at the 161 GB mark. You need to do this from a live session because you cannot move a partition while it is mounted. In a GUI disk manager like GParted, you will drag the partition "to the left".

Once the partition has been moved, you should be able to extend it the normal way.

You should back up the partition to a separate (external) device before you do any of this work.

5 Likes

ok will try

last question, I will have to do it again in a couple of months when I upgrade my ssd, is there any way to back up the whole system, not only the files? as the most important thing for me is the customizations I have made and the programs I have installed, not the files that I have on the system.

You might think of them as a speprate thing, but the customizations you have made are files. You can capture a lot of them just by saving the "dot files" in your home folder (hidden files and folders unique to your user, type ls -la ~ to see what I mean).

Search the forum and you will find a hundred different ways to make a proper backup. I'm partial to rsync but some reading/experimentation is required: rsync - ArchWiki

Other ideas: System backup - ArchWiki

2 Likes

i have tried using a live garuda gnome usb stick, and I wasn't able to "move the partition to the left"

Just move the empty partion to the right / end

2 Likes

I was not able to moove the empty partition too

You will need to make the free space unallocated then you will be able to move it to the end or to the right of the partion you wish to enlarge

2 Likes

If the partition is mounted, you won't be able to move it.

3 Likes

I hope you backup your drive before you started.

3 Likes

https://gparted.org/documentation.php

3 Likes

the partition is not mounted

If you are unable to move the partition, another option available to you (since the unused space is larger than the Btrfs partition) is to:

  • Create a new partition in the unused space between 161 GB and 213 GB (let's call this p7)
  • Migrate data from p5 to p7 with btrfs replace (you can instead use dd or rsync or something else if you prefer)
  • Delete p5
  • Expand p7 (to the right) to fill the unused space

how do I know that it is between 161 and 213 gb?

Examine the output you posted above when you ran the print command from within parted. It reveals the beginning and end of each of your partitions.

1 Like