Removing / updating saved entries in ksshaskpass

Hello Garuda users,

I am having trouble using ksshaskpass. I tried to clone a private repo from Github which requires authentication. I mistakenly entered my password in the prompt that opened which was actually asking for my username. Now it seems that my password is forever set as my Github username and I was not able to find a way to delete / reset the entry.
The only relevant information I found was this SO post which describes my exact problem: github - Git asks a password for a wrong URL - Stack Overflow
which however provides no solution either.
I also found this: Reddit - Dive into anything however I would like to keep using ksshaskpass or a utility like it.
I found one more post: Ksshaskpass - delete remembered credentials - Help - NixOS Discourse. This seems to be a common problem with apparently no documented solution. I do not have kwalletmanager as described there.

  1. How can I edit / remove saved usernames in ksshaskpass? Running the program only opens a prompt where I can enter a password, which then simply prints this password on the terminal.
  2. Given all the linked posts, is there a better (more usable) alternative to ksshaskpass? I'm only using it because it was already installed.

Thank you for your time.

System information:

Kernel: 6.2.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=72e0724c-168d-4e42-9fe9-92c648a94321 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 1407
date: 04/02/2020
Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4200 high: 4201 min/max: 2200/4910 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4200 2: 4200
3: 4200 4: 4200 5: 4200 6: 4200 7: 4200 8: 4201 9: 4200 10: 4200 11: 4200
12: 4200 13: 4200 14: 4200 15: 4200 16: 4200 bogomips: 134400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate]
vendor: Micro-Star MSI driver: nvidia v: 525.89.02
alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-03) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:2488 class-ID: 0300
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
s-diag: 1108mm (43.63")
Monitor-1: DP-0 pos: primary,top-right res: 2560x1440 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-2: HDMI-0 pos: bottom-l res: 1920x1080 hz: 60 dpi: 102
size: 476x268mm (18.74x10.55") diag: 546mm (21.51") modes: N/A
API: OpenGL v: N/A renderer: N/A direct-render: N/A
Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 2-2:2 pcie: chip-ID: 0d8c:0014
class-ID: 0300 gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 09:00.1
chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media Audio Adapter (Unitek Y-247A) type: USB
driver: cmedia_hs100b,snd-usb-audio,usbhid
API: ALSA v: k6.2.7-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 3.67 TiB used: 10.86 GiB (0.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 211070WD temp: 41.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 39.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: Patriot model: N/A
size: 28.9 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 505.58 GiB size: 505.58 GiB (100.00%)
used: 10.83 GiB (2.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.6 MiB (26.7%) fs: vfat dev: /dev/nvme1n1p2 maj-min: 259:5
ID-3: /home raw-size: 505.58 GiB size: 505.58 GiB (100.00%)
used: 10.83 GiB (2.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 505.58 GiB size: 505.58 GiB (100.00%)
used: 10.83 GiB (2.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 505.58 GiB size: 505.58 GiB (100.00%)
used: 10.83 GiB (2.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 47.5 C mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 374 Uptime: 47m wakeups: 0 Memory: 31.26 GiB
used: 4.33 GiB (13.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1200
libs: 308 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-21
Last full system update: 2023-04-21 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

first i would reboot

secondly i would not worry to much as this is a fresh install, just reinstall :slight_smile:

1 Like

Surely there must be a better way? :sweat_smile:
I'm dual booting with Windows which I am very surprised worked immediately given all the warnings I read.
I would also like to know in case this happens again, since the prompt was somewhat misleading and I could see myself doing the same mistake again (or simply wrongly entering my username?).

I finally found a solution.
kwalletmanager is required to edit passwords, but is not installed by default.
Installing this and then running it allowed me to delete the incorrect entry for Github.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.